aboutsummaryrefslogtreecommitdiff
path: root/net/p5-URI-FromHash/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-08-02 11:37:28 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-08-02 11:37:28 +0000
commit16304de1c5433912754c59a215d1f0421ea7fda7 (patch)
tree5d2ddfc2c797eb147458e4707ee7e84121b7f8d3 /net/p5-URI-FromHash/Makefile
parentaaed6be69df33ca83523dc35b11ad5ae3dff76fe (diff)
downloadports-16304de1c5433912754c59a215d1f0421ea7fda7.tar.gz
ports-16304de1c5433912754c59a215d1f0421ea7fda7.zip
Add port net/p5-URI-FromHash:
This module provides a simple functional "named parameters" style interface for creating URIs. Underneath the hood it uses URI.pm, though because of the simplified interface it may not support all possible options for all types of URIs. It was created for the common case where you simply want to have a simple interface for creating syntactically correct URIs from known components (like a path and query string). Doing this using the native URI.pm interface is rather tedious, requiring a number of method calls, which is particularly ugly when done inside a templating system such as Mason or TT2. WWW: http://search.cpan.org/dist/URI-FromHash/ Justification: socialtext dependency
Notes
Notes: svn path=/head/; revision=169460
Diffstat (limited to 'net/p5-URI-FromHash/Makefile')
-rw-r--r--net/p5-URI-FromHash/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/net/p5-URI-FromHash/Makefile b/net/p5-URI-FromHash/Makefile
new file mode 100644
index 000000000000..6bf7c5a71828
--- /dev/null
+++ b/net/p5-URI-FromHash/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-URI-FromHash
+# Date created: 2 August 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= URI-FromHash
+DISTVERSION= 0.02
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Create URI from hash of components
+
+BUILD_DEPENDS= p5-URI>=1.22:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= YES
+
+MAN3= ${PORTNAME:S/-/::/g}.3
+
+.include <bsd.port.mk>