aboutsummaryrefslogtreecommitdiff
path: root/net/pathchar
diff options
context:
space:
mode:
authorJacques Vidrine <nectar@FreeBSD.org>1998-11-15 21:25:16 +0000
committerJacques Vidrine <nectar@FreeBSD.org>1998-11-15 21:25:16 +0000
commit15b58fe6a1b27d6049c9366fd92b0b46e49abbd0 (patch)
tree726e38faca6999c75741f1810255586350b6c4bb /net/pathchar
parentdf912b9261c9c56afbfc5577ca7d0e1164bb4457 (diff)
downloadports-15b58fe6a1b27d6049c9366fd92b0b46e49abbd0.tar.gz
ports-15b58fe6a1b27d6049c9366fd92b0b46e49abbd0.zip
pathchar alpha 0 for a.out systems, pathchar alpha 1 for ELF systems.
LBNL Internet path characterization tool PR: ports/8588 Submitted by: Josh Gilliam <josh@quick.net>
Notes
Notes: svn path=/head/; revision=14539
Diffstat (limited to 'net/pathchar')
-rw-r--r--net/pathchar/Makefile51
-rw-r--r--net/pathchar/distinfo1
-rw-r--r--net/pathchar/files/README.pathchar39
-rw-r--r--net/pathchar/pkg-comment1
-rw-r--r--net/pathchar/pkg-descr9
-rw-r--r--net/pathchar/pkg-plist2
6 files changed, 103 insertions, 0 deletions
diff --git a/net/pathchar/Makefile b/net/pathchar/Makefile
new file mode 100644
index 000000000000..8e944e42afbc
--- /dev/null
+++ b/net/pathchar/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: pathchar
+# Version required: a0 (a.out systems), a1 (ELF systems)
+# Date created: 7 November 1998
+# Whom: Josh Gilliam <josh@quick.net>
+#
+# $Id$
+#
+
+DISTNAME= pathchar-a1-freebsd-3.0
+PKGNAME= pathchar-a1
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.ee.lbl.gov/pathchar/
+
+MAINTAINER= josh@quick.net
+
+.include <bsd.port.pre.mk>
+.if ${PORTOBJFORMAT} == "aout"
+DISTNAME= pathchar-a0-freebsd-2.2
+PKGNAME= pathchar-a0
+MD5_FILE= ${FILESDIR}/md5.aout
+.endif
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+ZCAT?= zcat
+TAR?= tar
+
+# wierd .. pathchar-a0 is a gzip'd gzip'd tar, while pathchar-a1
+# is just a tar. both have the extension .tar.gz though...
+.if ${PORTOBJFORMAT} == "aout"
+do-extract:
+ @${RM} -rf ${WRKDIR}
+ @${MKDIR} ${WRKDIR}
+ @for file in ${EXTRACT_ONLY}; do \
+ if ! (cd ${WRKDIR} && ${ZCAT} ${DISTDIR}/$$file | \
+ ${TAR} ${EXTRACT_BEFORE_ARGS} - ${EXTRACT_AFTER_ARGS}); \
+ then \
+ exit 1; \
+ fi \
+ done
+.else
+EXTRACT_BEFORE_ARGS= -xf
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pathchar ${PREFIX}/bin
+ ${INSTALL_DATA} ${FILESDIR}/README.pathchar \
+ ${PREFIX}/share/doc/README.pathchar
+
+.include <bsd.port.post.mk>
diff --git a/net/pathchar/distinfo b/net/pathchar/distinfo
new file mode 100644
index 000000000000..0c14ce022cb2
--- /dev/null
+++ b/net/pathchar/distinfo
@@ -0,0 +1 @@
+MD5 (pathchar-a1-freebsd-3.0.tar.gz) = c6cd5b36ee5dbce6e9a79d371eb29478
diff --git a/net/pathchar/files/README.pathchar b/net/pathchar/files/README.pathchar
new file mode 100644
index 000000000000..f0c5d5654829
--- /dev/null
+++ b/net/pathchar/files/README.pathchar
@@ -0,0 +1,39 @@
+Pathchar finds bandwidth, delay, average queue and loss rate
+of hops between source and destination.
+
+This tool, written by Van Jacobson (author of traceroute), is
+alpha quality. Source code is not available.
+
+Command line arguments
+ -a:
+ -A:
+ -d:
+ -D: filename for debug output
+ -f: initial hop #
+ -F: probefilter
+ -i: intersampletime
+ -l: max ttl
+ -L: locality
+ -m: maxsize maximum packet size in bytes
+ (if absent, pathchar determines path MTU)
+ -M: minsize default: smallest possible
+ (want large differential between max and min size,
+ o/w a node w/queue will impact later nodes )
+ -n: don't dns-resolve
+ -p: port @@?
+ -q: #queries, default 32
+ -Q: bytes,
+ if (-), packet size increment per query, defaults to 92.
+ if (+), number of sizes, defaults to 32
+ -s: lsrr?
+ -S: fit spacing
+ -t: tos
+ -v: verbose mode
+ -V: verbose?
+ -w: seconds wait time
+
+"Please report problems to pathchar@ee.lbl.gov. But please
+don't ask questions -- if it doesn't make sense, wait for the
+beta release. Thanks. Have fun."
+
+http://www.caida.org/Pathchar/
diff --git a/net/pathchar/pkg-comment b/net/pathchar/pkg-comment
new file mode 100644
index 000000000000..4c4f49d52ab1
--- /dev/null
+++ b/net/pathchar/pkg-comment
@@ -0,0 +1 @@
+LBNL Internet path characterization tool
diff --git a/net/pathchar/pkg-descr b/net/pathchar/pkg-descr
new file mode 100644
index 000000000000..8fc097de0d70
--- /dev/null
+++ b/net/pathchar/pkg-descr
@@ -0,0 +1,9 @@
+Pathchar finds bandwidth, delay, average queue and loss rate
+of hops between source and destination.
+
+This tool, written by Van Jacobson (author of traceroute), is
+alpha quality. Source code is not available.
+
+See also http://www.caida.org/Pathchar/
+--
+Josh Gilliam <josh@quick.net>
diff --git a/net/pathchar/pkg-plist b/net/pathchar/pkg-plist
new file mode 100644
index 000000000000..57370b1dc885
--- /dev/null
+++ b/net/pathchar/pkg-plist
@@ -0,0 +1,2 @@
+bin/pathchar
+share/doc/README.pathchar