aboutsummaryrefslogtreecommitdiff
path: root/net/pear-Net_DNSBL/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
commita1993564e04f29ecbaa05be740547c8677d423cd (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /net/pear-Net_DNSBL/Makefile
parent868fb29f23bfae4d55ab923ea34259adf63b4886 (diff)
downloadports-a1993564e04f29ecbaa05be740547c8677d423cd.tar.gz
ports-a1993564e04f29ecbaa05be740547c8677d423cd.zip
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Notes
Notes: svn path=/head/; revision=463917
Diffstat (limited to 'net/pear-Net_DNSBL/Makefile')
-rw-r--r--net/pear-Net_DNSBL/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/net/pear-Net_DNSBL/Makefile b/net/pear-Net_DNSBL/Makefile
index 42c24b660b97..f396f7ec49d2 100644
--- a/net/pear-Net_DNSBL/Makefile
+++ b/net/pear-Net_DNSBL/Makefile
@@ -11,14 +11,14 @@ COMMENT= PEAR DNSBL Checker
LICENSE= PHP30
-BUILD_DEPENDS= ${PEARDIR}/Cache/Lite.php:sysutils/pear-Cache_Lite \
- ${PEARDIR}/Net/CheckIP.php:net/pear-Net_CheckIP \
- ${PEARDIR}/Net/DNS2.php:dns/pear-Net_DNS2 \
- ${PEARDIR}/HTTP/Request2.php:www/pear-HTTP_Request2
-RUN_DEPENDS:= ${PEARDIR}/Cache/Lite.php:sysutils/pear-Cache_Lite \
- ${PEARDIR}/Net/CheckIP.php:net/pear-Net_CheckIP \
- ${PEARDIR}/Net/DNS2.php:dns/pear-Net_DNS2 \
- ${PEARDIR}/HTTP/Request2.php:www/pear-HTTP_Request2
+BUILD_DEPENDS= ${PEARDIR}/Cache/Lite.php:sysutils/pear-Cache_Lite@${PHP_FLAVOR} \
+ ${PEARDIR}/Net/CheckIP.php:net/pear-Net_CheckIP@${PHP_FLAVOR} \
+ ${PEARDIR}/Net/DNS2.php:dns/pear-Net_DNS2@${PHP_FLAVOR} \
+ ${PEARDIR}/HTTP/Request2.php:www/pear-HTTP_Request2@${PHP_FLAVOR}
+RUN_DEPENDS:= ${PEARDIR}/Cache/Lite.php:sysutils/pear-Cache_Lite@${PHP_FLAVOR} \
+ ${PEARDIR}/Net/CheckIP.php:net/pear-Net_CheckIP@${PHP_FLAVOR} \
+ ${PEARDIR}/Net/DNS2.php:dns/pear-Net_DNS2@${PHP_FLAVOR} \
+ ${PEARDIR}/HTTP/Request2.php:www/pear-HTTP_Request2@${PHP_FLAVOR}
USES= pear