aboutsummaryrefslogtreecommitdiff
path: root/net/penguintv/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-05-31 00:41:02 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-05-31 00:41:02 +0000
commit1c1f0634c062377a76d1c166897a4b8e364cf685 (patch)
treeb284969febdac4e1a7d52a8cd74e08060a644417 /net/penguintv/Makefile
parent4520e0b6191d9383adaeebf2a08c5f329a23ba34 (diff)
downloadports-1c1f0634c062377a76d1c166897a4b8e364cf685.tar.gz
ports-1c1f0634c062377a76d1c166897a4b8e364cf685.zip
Update to 3.0-stable
Notes
Notes: svn path=/head/; revision=192432
Diffstat (limited to 'net/penguintv/Makefile')
-rw-r--r--net/penguintv/Makefile46
1 files changed, 21 insertions, 25 deletions
diff --git a/net/penguintv/Makefile b/net/penguintv/Makefile
index c513544a86f8..6436f2a3aecf 100644
--- a/net/penguintv/Makefile
+++ b/net/penguintv/Makefile
@@ -1,52 +1,53 @@
-# New ports collection makefile for: PenguinTV-devel
+# New ports collection makefile for: PenguinTV
# Date created: 14 March 2006
# Whom: Edwin Groothuis <edwin@mavetju.org>
#
# $FreeBSD$
PORTNAME= PenguinTV
-PORTVERSION= 2.0.3
-PORTREVISION= 2
+PORTVERSION= 3.0
CATEGORIES= net audio multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= penguintv
MAINTAINER= edwin@mavetju.org
-COMMENT= Graphical RSS feed reader with incorperated playback functions
+COMMENT= Graphical RSS feed reader with incorperated playback functions - development version
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/pysqlite2/_sqlite.so:${PORTSDIR}/databases/py-pysqlite21 \
${PYTHON_SITELIBDIR}/pycurl.so:${PORTSDIR}/ftp/py-curl \
- ${PYXML}
+ ${PYTHON_SITELIBDIR}/gtk-2.0/pynotify/_pynotify.so:${PORTSDIR}/devel/py-notify \
+ ${PYTHON_SITELIBDIR}/gst-0.10/gst/__init__.py:${PORTSDIR}/multimedia/py-gstreamer \
+ ${PYXML} \
+ ${PYTHON_SITELIBDIR}/Pyrex/__init__.py:${PORTSDIR}/devel/pyrex
.if defined(PACKAGE_BUILDING)
BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT} \
${X11BASE}/lib/X11/fonts/misc/8x13O.pcf.gz:${X_FONTS_MISC_PORT}
.endif
RUN_DEPENDS= ${BUILD_DEPENDS}
-OPTIONS= MOZILLA "Use Mozilla rendered (experimental)" OFF
+WRKSRC= ${WRKDIR}/PenguinTV-${PORTVERSION}
-USE_GNOME= gnomehier pygnomeextras pygnome2
-USE_PYTHON= yes
+OPTIONS= PYLUCENE "Use Lucene search engine" ON \
+ GSTREAMER "Use GStreamer engine" ON
-GCONF_SCHEMAS= penguintv.schema
+USE_GNOME= pygnomeextras pygnome2
+USE_PYTHON= yes
+USE_GECKO= firefox
CONFLICTS= PenguinTV-devel-[0-9]*
.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
-.if defined(WITH_MOZILLA)
-BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/Pyrex/__init__.py:${PORTSDIR}/devel/pyrex \
- mozilla-config:${PORTSDIR}/www/mozilla
-PLIST_SUB+= WITH_MOZILLA=""
-.else
-EXTRA_PATCHES+= ${FILESDIR}/patchmozilla-setup.py
-PLIST_SUB+= WITH_MOZILLA="@comment "
+.if defined(WITH_GSTREAMER)
+RUN_DEPENDS+= ${LOCALBASE}/lib/python2.4/site-packages/pygst.py:${PORTSDIR}/multimedia/py-gstreamer
.endif
-pre-fetch:
- @${ECHO_MSG} If you are upgrading from 1.x, please export your subscriptions for save-keeping!
- @${ECHO_MSG} The database scheme should be upgraded automatically.
- @sleep 5
+.if defined(WITHOUT_PYLUCENE)
+#BROKEN= Cannot be run without PyLucene
+.else
+RUN_DEPENDS+= ${LOCALBASE}/lib/python2.4/site-packages/PyLucene.py:${PORTSDIR}/textproc/py-lucene
+.endif
do-build:
cd ${WRKSRC} && ${PYTHON_CMD} setup.py build
@@ -54,9 +55,4 @@ do-build:
do-install:
cd ${WRKSRC} && ${PYTHON_CMD} setup.py install
-post-install:
- @${MKDIR} ${LOCALBASE}/etc/gconf/schemas
- @${INSTALL_DATA} ${WRKSRC}/share/penguintv.schema \
- ${LOCALBASE}/etc/gconf/schemas/
-
.include <bsd.port.post.mk>