aboutsummaryrefslogtreecommitdiff
path: root/net/pfinger
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-26 17:20:34 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-26 17:20:34 +0000
commit644a4edbeae6acf7e0d2dd4199384b4f63fe7392 (patch)
tree713586c3a145890c599e42da4deab7f5c59a9fe4 /net/pfinger
parent92625bccb397b1cc96c3f7c0cd72d0c208ef0428 (diff)
downloadports-644a4edbeae6acf7e0d2dd4199384b4f63fe7392.tar.gz
ports-644a4edbeae6acf7e0d2dd4199384b4f63fe7392.zip
add pfinger
Highly configurable, secure and portable finger daemon
Notes
Notes: svn path=/head/; revision=41928
Diffstat (limited to 'net/pfinger')
-rw-r--r--net/pfinger/Makefile27
-rw-r--r--net/pfinger/distinfo1
-rw-r--r--net/pfinger/files/patch-src::configfile.c11
-rw-r--r--net/pfinger/files/patch-src::finger.h16
-rw-r--r--net/pfinger/pkg-comment1
-rw-r--r--net/pfinger/pkg-descr14
-rw-r--r--net/pfinger/pkg-plist4
7 files changed, 74 insertions, 0 deletions
diff --git a/net/pfinger/Makefile b/net/pfinger/Makefile
new file mode 100644
index 000000000000..8ce163bf5952
--- /dev/null
+++ b/net/pfinger/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# New ports collection makefile for: pfinger
+# Date created: Apr 25, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pfinger
+PORTVERSION= 0.7.6
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.xelia.ch/pub/unix/ \
+ http://www.xelia.ch/unix/pfinger/
+
+MAINTAINER= ijliao@FreeBSD.org
+
+USE_GTK= yes
+GNU_CONFIGURE= yes
+
+MAN1= finger.1 pfinger.1
+MAN5= fingerconf.5
+MAN8= in.fingerd.8
+
+post-patch:
+ @${PERL} -pi -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/src/configfile.c
+
+.include <bsd.port.mk>
diff --git a/net/pfinger/distinfo b/net/pfinger/distinfo
new file mode 100644
index 000000000000..277b1ecdea1b
--- /dev/null
+++ b/net/pfinger/distinfo
@@ -0,0 +1 @@
+MD5 (pfinger-0.7.6.tar.gz) = a6e7fbbe05eb0affed859b4f041fb06a
diff --git a/net/pfinger/files/patch-src::configfile.c b/net/pfinger/files/patch-src::configfile.c
new file mode 100644
index 000000000000..ebdeeee673e2
--- /dev/null
+++ b/net/pfinger/files/patch-src::configfile.c
@@ -0,0 +1,11 @@
+--- src/configfile.c.orig Thu Apr 26 01:50:01 2001
++++ src/configfile.c Thu Apr 26 01:50:20 2001
+@@ -45,7 +45,7 @@
+ #define S_IWUSR 00200
+ #endif
+
+-#define GLOBAL_FINGERCONF "/etc/fingerconf"
++#define GLOBAL_FINGERCONF "%%PREfiX%%/etc/fingerconf"
+
+ char *configfile = GLOBAL_FINGERCONF;
+ Node * readconfig(char *filename);
diff --git a/net/pfinger/files/patch-src::finger.h b/net/pfinger/files/patch-src::finger.h
new file mode 100644
index 000000000000..2bb361779a93
--- /dev/null
+++ b/net/pfinger/files/patch-src::finger.h
@@ -0,0 +1,16 @@
+--- src/finger.h.orig Thu Apr 26 01:39:28 2001
++++ src/finger.h Thu Apr 26 01:39:38 2001
+@@ -21,12 +21,12 @@
+ #ifndef FINGER_H
+ #define FINGER_H
+
++#include <sys/types.h>
+ #include <utmp.h>
+ #ifndef UT_NAMESIZE
+ #define UT_NAMESIZE 16
+ #endif
+
+-#include <sys/types.h>
+
+ /* This structure contains information about the user
+ *
diff --git a/net/pfinger/pkg-comment b/net/pfinger/pkg-comment
new file mode 100644
index 000000000000..8e999ff4b6f2
--- /dev/null
+++ b/net/pfinger/pkg-comment
@@ -0,0 +1 @@
+Highly configurable, secure and portable finger daemon
diff --git a/net/pfinger/pkg-descr b/net/pfinger/pkg-descr
new file mode 100644
index 000000000000..0d68c841395c
--- /dev/null
+++ b/net/pfinger/pkg-descr
@@ -0,0 +1,14 @@
+PFinger consists of server and client for the standard finger service.
+
+The PFinger server is a replacement for the standard Unix finger server. It
+also implements the pip-protocol which could become the finger v2 protocol.
+Its advantage over existing finger servers like GNU Finger or similar
+enhanced Finger servers are its configurability, compatibility and security
+(e.g. the server does not run as root).
+
+The Pfinger client can be used for several tasks: First it provides an easy
+way to edit the information the PFinger Server gives out about you. Then it
+can be used as graphical version of the standard finger client to monitor
+who is online.
+
+WWW: http://www.xelia.ch/unix/pfinger/
diff --git a/net/pfinger/pkg-plist b/net/pfinger/pkg-plist
new file mode 100644
index 000000000000..c9d40e44ac26
--- /dev/null
+++ b/net/pfinger/pkg-plist
@@ -0,0 +1,4 @@
+bin/finger
+bin/pfinger
+sbin/fingerd
+sbin/in.fingerd