aboutsummaryrefslogtreecommitdiff
path: root/net/pptpclient
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2009-11-04 21:08:12 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2009-11-04 21:08:12 +0000
commit8e4a24203580548cd692c5039ab186885b29dc38 (patch)
tree3e4ddab887c07e425fab83235775d1135142a182 /net/pptpclient
parent00257216ecbfbdcbbce236a3d441c3116161585a (diff)
downloadports-8e4a24203580548cd692c5039ab186885b29dc38.tar.gz
ports-8e4a24203580548cd692c5039ab186885b29dc38.zip
- Install missing manpages.
- Install custom files and respect PORTDOCS. - Fix pkg-plist. - Fix PREFIX hardcoded in pptp scripts(should fix ports/137115). - Bump PORTREVISION. Submitted by: myself
Notes
Notes: svn path=/head/; revision=243800
Diffstat (limited to 'net/pptpclient')
-rw-r--r--net/pptpclient/Makefile25
-rw-r--r--net/pptpclient/pkg-plist3
2 files changed, 22 insertions, 6 deletions
diff --git a/net/pptpclient/Makefile b/net/pptpclient/Makefile
index acef3e920708..219d6e6b9e97 100644
--- a/net/pptpclient/Makefile
+++ b/net/pptpclient/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pptpclient
PORTVERSION= 1.7.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}/pptp/pptp-${PORTVERSION}
DISTNAME= pptp-${PORTVERSION}
@@ -17,15 +17,28 @@ COMMENT= PPTP client for establishing a VPN link with an NT server
USE_PERL5= yes
-MAN8= pptp.8
+MAN8= pptp.8 pptpsetup.8
+FILES= README ppp.conf
+PORTDOCS= AUTHORS COPYING ChangeLog DEVELOPERS INSTALL NEWS \
+ PROTOCOL-SECURITY README TODO USING
MAKE_ARGS= DEBUG=""
+post-patch:
+ ${REINPLACE_CMD} -e 's|/usr|/usr/local|g' -e 's|/etc|/usr/local/etc|g' \
+ ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} 's|/etc|/usr/local/etc|g' ${WRKSRC}/pptpsetup
+
do-install:
+ ${MKDIR} ${EXAMPLESDIR} ${ETCDIR}
${INSTALL_PROGRAM} ${WRKSRC}/pptp ${PREFIX}/sbin
- ${MKDIR} ${PREFIX}/share/examples/pptpclient
- ${INSTALL_DATA} ${FILESDIR}/README ${PREFIX}/share/examples/pptpclient
- ${INSTALL_DATA} ${FILESDIR}/ppp.conf ${PREFIX}/share/examples/pptpclient
- ${INSTALL_MAN} ${WRKSRC}/pptp.8 ${PREFIX}/man/man8
+ ${INSTALL_SCRIPT} ${WRKSRC}/pptpsetup ${PREFIX}/sbin
+ ${INSTALL_MAN} ${MAN8:S,^,${WRKSRC}/,} ${MAN8PREFIX}/man/man8
+ ${INSTALL_DATA} ${FILES:S,^,${FILESDIR}/,} ${EXAMPLESDIR}
+ ${CP} ${FILESDIR}/ppp.conf ${ETCDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/net/pptpclient/pkg-plist b/net/pptpclient/pkg-plist
index a1d7a93067f7..332892c398f0 100644
--- a/net/pptpclient/pkg-plist
+++ b/net/pptpclient/pkg-plist
@@ -1,4 +1,7 @@
sbin/pptp
+sbin/pptpsetup
%%EXAMPLESDIR%%/README
%%EXAMPLESDIR%%/ppp.conf
+%%ETCDIR%%/ppp.conf
+@dirrm %%ETCDIR%%
@dirrm %%EXAMPLESDIR%%