aboutsummaryrefslogtreecommitdiff
path: root/net/proxy-suite/Makefile
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-10-19 15:52:02 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-10-19 15:52:02 +0000
commit1e2d710bb99c6ef1b6e7a8b70c4af208fcc7a9a7 (patch)
tree4ec5d260afe5952bf9cbe04e7dbeed34958d517e /net/proxy-suite/Makefile
parente9aeb747060a8bff587763d5938fd5c6195e1bef (diff)
downloadports-1e2d710bb99c6ef1b6e7a8b70c4af208fcc7a9a7.tar.gz
ports-1e2d710bb99c6ef1b6e7a8b70c4af208fcc7a9a7.zip
- Add suport LDAP
- Add pkg-message - Bump PORTREVISION PR: 31351 Submitted by: MAINTAINER
Notes
Notes: svn path=/head/; revision=48950
Diffstat (limited to 'net/proxy-suite/Makefile')
-rw-r--r--net/proxy-suite/Makefile31
1 files changed, 29 insertions, 2 deletions
diff --git a/net/proxy-suite/Makefile b/net/proxy-suite/Makefile
index 28acbcb80461..32e27054b614 100644
--- a/net/proxy-suite/Makefile
+++ b/net/proxy-suite/Makefile
@@ -7,6 +7,7 @@
PORTNAME= proxy-suite
PORTVERSION= 1.7
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.suse.com/pub/projects/proxy-suite/src/ \
ftp://ftp.crc.ca/pub/systems/linux/suse/projects/proxy-suite/src/ \
@@ -15,11 +16,37 @@ MASTER_SITES= ftp://ftp.suse.com/pub/projects/proxy-suite/src/ \
MAINTAINER= thomas@cuivre.fr.eu.org
-CONFIGURE_ARGS= --with-libwrap=/usr/lib/
-
USE_AUTOCONF= yes
USE_GMAKE= yes
+#
+# basic configure args
+#
+CONFIGURE_ARGS= --prefix=${PREFIX} --with-libwrap=/usr/lib --with-regex \
+ --sysconfdir=${PREFIX}/etc/proxy-suite \
+ --localstatedir=/var/run \
+ --enable-warnings --enable-so-linger --enable-rfc1579 \
+ --disable-proc-mods
+
+#
+# OPTIONAL: include ldap-support - currently ldap.2 needs minor fixes...
+#
+.if defined(WITH_LDAP)
+CONFIGURE_ARGS+= --with-libldap
+LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap
+.else
+CONFIGURE_ARGS+= --without-libldap
+.endif
+
+#
+# OPTIONAL: re-build the sgml documentation (postscript, html)
+# unfortunatenly this docu it is not up to date :-((
+# reading of the manual pages and HOWTO's makes more sense...
+#
+.if !defined(WITH_SGMLDOC)
+ALL_TARGET= -C ftp-proxy
+.endif
+
MAN8= ftp-proxy.8
MAN5= ftp-proxy.conf.5