aboutsummaryrefslogtreecommitdiff
path: root/net/py-google/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-05-23 00:32:04 +0000
committerPatrick Li <pat@FreeBSD.org>2002-05-23 00:32:04 +0000
commit797bc0968f6c141c034212ff2d71f0d1f5e35194 (patch)
treeae9f52a6cc5a1541ffff20edd302bcbcb336a823 /net/py-google/Makefile
parent5fdaa85b0d76467676b8f9a6cb38497c8fb02688 (diff)
downloadports-797bc0968f6c141c034212ff2d71f0d1f5e35194.tar.gz
ports-797bc0968f6c141c034212ff2d71f0d1f5e35194.zip
Fix ports for building with -current without perl
PR: 38359 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=59747
Diffstat (limited to 'net/py-google/Makefile')
-rw-r--r--net/py-google/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/net/py-google/Makefile b/net/py-google/Makefile
index 5c2116e04df9..cf9e7a7be960 100644
--- a/net/py-google/Makefile
+++ b/net/py-google/Makefile
@@ -24,15 +24,24 @@ EXTRACT_BEFORE_ARGS= -q -aa
WRKSRC= ${WRKDIR}/pygoogle
EXAMPLESDIR= ${PREFIX}/share/examples/py-google
+.include <bsd.port.pre.mk>
+
post-patch:
# www/py-websvcs has an incompatible version of SOAP.py
@${MV} ${WRKSRC}/SOAP.py ${WRKSRC}/SOAPgoogle.py
+.if ${OSVERSION} < 500036
@cd ${WRKSRC}; for f in *.py; do \
${PERL} -pi -e 's,import SOAP,import SOAPgoogle as SOAP,g' $$f; \
done
+ @${PERL} -pi -e 's,.*extra_path.*,,g' ${WRKSRC}/setup.py
+.else
+ @cd ${WRKSRC}; for f in *.py; do \
+ ${SED} -i "" -e 's,import SOAP,import SOAPgoogle as SOAP,g' $$f; \
+ done
+ @${SED} -i.orig -e 's,.*extra_path.*,,g' ${WRKSRC}/setup.py
+.endif
@${MKDIR} ${WRKSRC}/tests
@${MV} ${WRKSRC}/*test*.py ${WRKSRC}/tests
- @${PERL} -pi -e 's,.*extra_path.*,,g' ${WRKSRC}/setup.py
post-install:
.if !defined(NOPORTDOCS)
@@ -41,4 +50,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>