aboutsummaryrefslogtreecommitdiff
path: root/net/py-yadis/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-12-20 01:03:59 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-12-20 01:03:59 +0000
commit93dc0495a503d7aa7a0b3b74614bac61ba4179a4 (patch)
tree3b7d4356009d1bc90551a788b63dc93b7f8a8200 /net/py-yadis/Makefile
parente4a7f7221a17701ff625ceaee4679f537e83561d (diff)
downloadports-93dc0495a503d7aa7a0b3b74614bac61ba4179a4.tar.gz
ports-93dc0495a503d7aa7a0b3b74614bac61ba4179a4.zip
Python YADIS
------------ This code implements relying party support for the Yadis service discovery protocol. The protocol was developed for use by decentralized URL-based identity systems, but is useful for advertising services provided by or on behalf of a certain URL. To learn more about Yadis, see http://www.openidenabled.com/yadis The module yadis.xrires also provides a method of resolving XRI. The JanRain Python OpenID library uses this library for discovery of OpenID service endpoints. See that library for an example of library usage. WWW: http://www.openidenabled.com/yadis/libraries/python/
Notes
Notes: svn path=/head/; revision=180223
Diffstat (limited to 'net/py-yadis/Makefile')
-rw-r--r--net/py-yadis/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/net/py-yadis/Makefile b/net/py-yadis/Makefile
new file mode 100644
index 000000000000..c63665793d5d
--- /dev/null
+++ b/net/py-yadis/Makefile
@@ -0,0 +1,21 @@
+# Ports collection makefile for: py-yadis
+# Date created: Dec 19, 2006
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= yadis
+PORTVERSION= 1.1.0
+CATEGORIES= net python
+MASTER_SITES= http://www.openidenabled.com/resources/downloads/python-openid/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Python support for the Yadis service discovery protocol
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>