aboutsummaryrefslogtreecommitdiff
path: root/net/redir
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-10 19:47:52 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-10 19:47:52 +0000
commit0911d806ccbddc2c7f5942699fe54113e3e2adef (patch)
treef0ca60e5f5d39cea72f2545648ef1610cc922a0a /net/redir
parenta125c5fcbde01b39912d80b7f082bf9dfda03053 (diff)
downloadports-0911d806ccbddc2c7f5942699fe54113e3e2adef.tar.gz
ports-0911d806ccbddc2c7f5942699fe54113e3e2adef.zip
Add redir 2.2.1, a tcp connection redirection utility.
PR: 26481 Submitted by: Mark Pulford <mark@kyne.com.au>
Notes
Notes: svn path=/head/; revision=41219
Diffstat (limited to 'net/redir')
-rw-r--r--net/redir/Makefile21
-rw-r--r--net/redir/distinfo1
-rw-r--r--net/redir/files/patch-Makefile45
-rw-r--r--net/redir/pkg-comment1
-rw-r--r--net/redir/pkg-descr4
-rw-r--r--net/redir/pkg-plist1
6 files changed, 73 insertions, 0 deletions
diff --git a/net/redir/Makefile b/net/redir/Makefile
new file mode 100644
index 000000000000..a3b9d83832e1
--- /dev/null
+++ b/net/redir/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: redir
+# Date created: Apr 10, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= redir
+PORTVERSION= 2.2.1
+CATEGORIES= net
+MASTER_SITES= http://sammy.net/~sammy/hacks/
+
+MAINTAINER= mark@kyne.com.au
+
+MAN1= redir.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/redir ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/redir.man ${PREFIX}/man/man1/redir.1
+
+.include <bsd.port.mk>
diff --git a/net/redir/distinfo b/net/redir/distinfo
new file mode 100644
index 000000000000..cf217656673b
--- /dev/null
+++ b/net/redir/distinfo
@@ -0,0 +1 @@
+MD5 (redir-2.2.1.tar.gz) = 4342fadac30504c86c8db7beefe01995
diff --git a/net/redir/files/patch-Makefile b/net/redir/files/patch-Makefile
new file mode 100644
index 000000000000..6fbdb0c39a64
--- /dev/null
+++ b/net/redir/files/patch-Makefile
@@ -0,0 +1,45 @@
+--- Makefile.orig Mon Dec 27 07:21:55 1999
++++ Makefile Tue Apr 10 17:56:11 2001
+@@ -1,7 +1,7 @@
+ ### user configuration section
+
+ # if your system lacks getopt_long(), remove the comment from this line
+-GETOPT_OBJS = # getopt/getopt.o getopt/getopt1.o
++GETOPT_OBJS = getopt/getopt.o getopt/getopt1.o
+
+ # if your system lacks strrchr() or strdup(), edit this line
+ STR_CFLAGS = # -DNEED_STRRCHR -DNEED_STRDUP
+@@ -9,8 +9,8 @@
+ # if you would like support for TCP wrappers (and have libwrap.a
+ # installed), remove these comments.
+
+-WRAP_CFLAGS = # -DUSE_TCP_WRAPPERS
+-WRAP_LIBS = # -lwrap
++WRAP_CFLAGS = -DUSE_TCP_WRAPPERS
++WRAP_LIBS = -lwrap
+
+ # if your system needs any additional libraries (solaris, for example,
+ # needs the ones commented out below), edit this line.
+@@ -27,12 +27,11 @@
+ ### end of user configuration section
+
+ # redir requires gcc. if you're lucky, another compiler might work.
+-CC = gcc
+
+ # if your system lacks getopt_long, remove the comment from this line
+ OBJS = redir.o $(GETOPT_OBJS)
+
+-CFLAGS = -O2 -Wall $(STR_CFLAGS) $(WRAP_CFLAGS) $(EXTRA_CFLAGS)
++CFLAGS += -Wall -Igetopt $(STR_CFLAGS) $(WRAP_CFLAGS) $(EXTRA_CFLAGS)
+ LDFLAGS = -s
+
+ # solaris, and others, may also need these libraries to link
+@@ -49,7 +48,7 @@
+ rm -f $(OBJS) redir core
+
+ redir: ${OBJS}
+- ${CC} ${LDFLAGS} -o redir ${OBJS} ${LIBS}
++ ${CC} ${LDFLAGS} -o redir redir.o getopt.o getopt1.o ${LIBS}
+
+
+
diff --git a/net/redir/pkg-comment b/net/redir/pkg-comment
new file mode 100644
index 000000000000..4d9fd1e3dcb7
--- /dev/null
+++ b/net/redir/pkg-comment
@@ -0,0 +1 @@
+A tcp connection redirection utility
diff --git a/net/redir/pkg-descr b/net/redir/pkg-descr
new file mode 100644
index 000000000000..4f08cabd2209
--- /dev/null
+++ b/net/redir/pkg-descr
@@ -0,0 +1,4 @@
+Redir is a port redirector. It can run under inetd or standalone. Redir
+also supports tcp wrappers.
+
+WWW: http://sammy.net/~sammy/hacks/
diff --git a/net/redir/pkg-plist b/net/redir/pkg-plist
new file mode 100644
index 000000000000..7ed92e6cfbbf
--- /dev/null
+++ b/net/redir/pkg-plist
@@ -0,0 +1 @@
+bin/redir