aboutsummaryrefslogtreecommitdiff
path: root/net/rsync
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-10-24 01:59:41 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-10-24 01:59:41 +0000
commit24d242e01abfb7ac8b4fdd6ba351b2a871f37f02 (patch)
tree94cd9f0ade42973d45652332bc33f8d28e107429 /net/rsync
parent268a3a5edb924964524bc6289a4aadb39b8f78ef (diff)
downloadports-24d242e01abfb7ac8b4fdd6ba351b2a871f37f02.tar.gz
ports-24d242e01abfb7ac8b4fdd6ba351b2a871f37f02.zip
- Re-enable "!"s in .cvsignore files
- Fix an off-by-one error in the handling of --max-delete=N
Notes
Notes: svn path=/head/; revision=120053
Diffstat (limited to 'net/rsync')
-rw-r--r--net/rsync/Makefile3
-rw-r--r--net/rsync/files/patch-exclude.c27
-rw-r--r--net/rsync/files/patch-receiver.c15
3 files changed, 44 insertions, 1 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index d5e5411b9030..7ac45e1893cc 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -7,9 +7,10 @@
PORTNAME= rsync
PORTVERSION= 2.6.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= http://rsync.samba.org/ftp/%SUBDIR%/ \
+ ftp://ftp.samba.org//pub/%SUBDIR%/ \
ftp://sunsite.auc.dk/pub/unix/%SUBDIR%/ \
ftp://ftp.sunet.se/pub/unix/admin/%SUBDIR%/ \
ftp://ftp.fu-berlin.de/pub/unix/network/%SUBDIR%/ \
diff --git a/net/rsync/files/patch-exclude.c b/net/rsync/files/patch-exclude.c
new file mode 100644
index 000000000000..e54eb21f8cf2
--- /dev/null
+++ b/net/rsync/files/patch-exclude.c
@@ -0,0 +1,27 @@
+#
+# Re-enable "!"s in .cvsignore files
+# https://bugzilla.samba.org/show_bug.cgi?id=1873
+#
+--- exclude.c.orig Wed Sep 22 06:11:15 2004
++++ exclude.c Wed Oct 6 19:04:55 2004
+@@ -235,8 +235,9 @@
+ /* Get the next include/exclude arg from the string. The token will not
+ * be '\0' terminated, so use the returned length to limit the string.
+ * Also, be sure to add this length to the returned pointer before passing
+- * it back to ask for the next token. This routine parses the +/- prefixes
+- * and the "!" token unless xflags contains XFLG_WORDS_ONLY. The *flag_ptr
++ * it back to ask for the next token. This routine parses the "!" (list-
++ * clearing) token and (if xflags does NOT contain XFLG_WORDS_ONLY) the
++ * +/- prefixes for overriding the include/exclude mode. The *flag_ptr
+ * value will also be set to the MATCHFLG_* bits for the current token.
+ */
+ static const char *get_exclude_tok(const char *p, unsigned int *len_ptr,
+@@ -273,7 +274,7 @@
+ } else
+ len = strlen(s);
+
+- if (*p == '!' && len == 1 && !(xflags & XFLG_WORDS_ONLY))
++ if (*p == '!' && len == 1)
+ mflags |= MATCHFLG_CLEAR_LIST;
+
+ *len_ptr = len;
diff --git a/net/rsync/files/patch-receiver.c b/net/rsync/files/patch-receiver.c
new file mode 100644
index 000000000000..f4d0639975f7
--- /dev/null
+++ b/net/rsync/files/patch-receiver.c
@@ -0,0 +1,15 @@
+#
+# Fix an off-by-one error in the handling of --max-delete=N
+# http://lists.samba.org/archive/rsync/2004-October/010853.html
+#
+--- receiver.c.orig Tue Sep 21 11:24:06 2004
++++ receiver.c Wed Oct 20 08:12:19 2004
+@@ -116,7 +116,7 @@
+ rprintf(FINFO, "deleting in %s\n", safe_fname(fbuf));
+
+ for (i = local_file_list->count-1; i >= 0; i--) {
+- if (max_delete && deletion_count > max_delete)
++ if (max_delete && deletion_count >= max_delete)
+ break;
+ if (!local_file_list->files[i]->basename)
+ continue;