aboutsummaryrefslogtreecommitdiff
path: root/net/rtg/Makefile
diff options
context:
space:
mode:
authorStefan Walter <stefan@FreeBSD.org>2010-06-30 20:05:46 +0000
committerStefan Walter <stefan@FreeBSD.org>2010-06-30 20:05:46 +0000
commita43ffc48e2f1247a6440206cfcf2b94cdd0ece83 (patch)
tree59d2b128e4bf382e3e62df405d0c68a5f4a225ac /net/rtg/Makefile
parentd6de5eda748967b8b9ceb21e45e3bca9aa155799 (diff)
downloadports-a43ffc48e2f1247a6440206cfcf2b94cdd0ece83.tar.gz
ports-a43ffc48e2f1247a6440206cfcf2b94cdd0ece83.zip
- Add rc.d script.
- Optimise db table creation with indexes. - Add PID file option. - Fix a few warnings in the Makefile. - Assign maintainership to submitter. PR: 145924 Submitted by: Daniel Austin <freebsd-ports@dan.me.uk> Feature safe: yes
Notes
Notes: svn path=/head/; revision=257226
Diffstat (limited to 'net/rtg/Makefile')
-rw-r--r--net/rtg/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/net/rtg/Makefile b/net/rtg/Makefile
index 929410092201..27eb83e6486e 100644
--- a/net/rtg/Makefile
+++ b/net/rtg/Makefile
@@ -7,24 +7,32 @@
PORTNAME= rtg
PORTVERSION= 0.7.4
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd-ports@dan.me.uk
COMMENT= A flexible, high-performance SNMP statistics monitoring system
-LIB_DEPENDS= netsnmp.20:${PORTSDIR}/net-mgmt/net-snmp
+LIB_DEPENDS= netsnmp:${PORTSDIR}/net-mgmt/net-snmp
MAN1= rtgplot.1 rtgpoll.1
-USE_MYSQL= yes
+USE_RC_SUBR= rtgpoll
+USE_MYSQL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc/${PORTNAME} \
--with-mysql=${LOCALBASE} \
--with-snmp=${LOCALBASE}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800040
+CFLAGS+= -fstack-protector
+LDFLAGS+= -fstack-protector
+.endif
+
pre-configure:
@${REINPLACE_CMD} -e 's,-pthread,${PTHREAD_LIBS},g' ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>