aboutsummaryrefslogtreecommitdiff
path: root/net/ruby-icmp
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-10-31 20:57:31 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-10-31 20:57:31 +0000
commit12050036281f09397b4a2a73d127486d6462bbf4 (patch)
tree3e932151760abebc3f796e9a23fe832960673949 /net/ruby-icmp
parentff52862e7a0a67760474565ffba8c3dcff343c2c (diff)
downloadports-12050036281f09397b4a2a73d127486d6462bbf4.tar.gz
ports-12050036281f09397b4a2a73d127486d6462bbf4.zip
Add ruby-icmp, Ruby module for handling ICMP packets.
Notes
Notes: svn path=/head/; revision=34511
Diffstat (limited to 'net/ruby-icmp')
-rw-r--r--net/ruby-icmp/Makefile32
-rw-r--r--net/ruby-icmp/distinfo1
-rw-r--r--net/ruby-icmp/pkg-comment1
-rw-r--r--net/ruby-icmp/pkg-descr5
-rw-r--r--net/ruby-icmp/pkg-plist4
5 files changed, 43 insertions, 0 deletions
diff --git a/net/ruby-icmp/Makefile b/net/ruby-icmp/Makefile
new file mode 100644
index 000000000000..b1c556e934d4
--- /dev/null
+++ b/net/ruby-icmp/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: ICMPModule for Ruby
+# Date created: 1 Nov 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= icmp
+PORTVERSION= 0.1.0
+CATEGORIES= net ruby
+MASTER_SITES= http://www.notwork.org/~gotoyuzo/ruby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+EXAMPLES= ping.rb
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/icmp.rb ${RUBY_SITELIBDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/icmp
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/icmp/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/ruby-icmp/distinfo b/net/ruby-icmp/distinfo
new file mode 100644
index 000000000000..377984d246dd
--- /dev/null
+++ b/net/ruby-icmp/distinfo
@@ -0,0 +1 @@
+MD5 (icmp-0.1.0.tar.gz) = 382bdf4b69affcb6fcfb24d4519d55e5
diff --git a/net/ruby-icmp/pkg-comment b/net/ruby-icmp/pkg-comment
new file mode 100644
index 000000000000..059969c447ac
--- /dev/null
+++ b/net/ruby-icmp/pkg-comment
@@ -0,0 +1 @@
+Ruby module for handling ICMP packets
diff --git a/net/ruby-icmp/pkg-descr b/net/ruby-icmp/pkg-descr
new file mode 100644
index 000000000000..f30973670cf8
--- /dev/null
+++ b/net/ruby-icmp/pkg-descr
@@ -0,0 +1,5 @@
+This is a Ruby module for handling ICMP packets.
+
+Note that it requires root permission to handle any ICMP packets.
+
+Author: GOTOU YUUZOU <gotoyuzo@notwork.org>
diff --git a/net/ruby-icmp/pkg-plist b/net/ruby-icmp/pkg-plist
new file mode 100644
index 000000000000..6f14cc684a42
--- /dev/null
+++ b/net/ruby-icmp/pkg-plist
@@ -0,0 +1,4 @@
+%%RUBY_SITEARCHLIBDIR%%/icmpmodule.so
+%%RUBY_SITELIBDIR%%/icmp.rb
+%%RUBY_EXAMPLESDIR%%/icmp/ping.rb
+@dirrm %%RUBY_EXAMPLESDIR%%/icmp