aboutsummaryrefslogtreecommitdiff
path: root/net/ruby-pcap
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-11-19 22:06:30 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-11-19 22:06:30 +0000
commit83076530c6795693785a2e0a11b22c06a65ecb0c (patch)
tree574e444cb603aa34d7393c63e9dcc50cf9c6fe8f /net/ruby-pcap
parent7fdc1932c00ecd886aa947ffa02752656f4e8211 (diff)
downloadports-83076530c6795693785a2e0a11b22c06a65ecb0c.tar.gz
ports-83076530c6795693785a2e0a11b22c06a65ecb0c.zip
Add ruby-pcap, Ruby interface to LBL Packet Capture library (libpcap).
Notes
Notes: svn path=/head/; revision=35271
Diffstat (limited to 'net/ruby-pcap')
-rw-r--r--net/ruby-pcap/Makefile36
-rw-r--r--net/ruby-pcap/distinfo1
-rw-r--r--net/ruby-pcap/pkg-comment1
-rw-r--r--net/ruby-pcap/pkg-descr8
-rw-r--r--net/ruby-pcap/pkg-plist40
5 files changed, 86 insertions, 0 deletions
diff --git a/net/ruby-pcap/Makefile b/net/ruby-pcap/Makefile
new file mode 100644
index 000000000000..1ec2b356fb8b
--- /dev/null
+++ b/net/ruby-pcap/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: Ruby/Pcap
+# Date created: 20 Nov 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pcap
+PORTVERSION= 0.6
+CATEGORIES= net ruby
+MASTER_SITES= http://www.goto.info.waseda.ac.jp/~fukusima/ruby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+CONFIGURE_ARGS= --with-pcap-dir=/usr
+INSTALL_TARGET= site-install
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/pcap
+ ${CP} -R ${WRKSRC}/examples/ ${RUBY_EXAMPLESDIR}/pcap/
+ ${MKDIR} ${RUBY_DOCDIR}/pcap/ja
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${WRKSRC}/README ${WRKSRC}/doc/* \
+ ${RUBY_DOCDIR}/pcap/
+ ${INSTALL_DATA} ${WRKSRC}/README.ja ${WRKSRC}/doc-ja/* \
+ ${RUBY_DOCDIR}/pcap/ja/
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/ruby-pcap/distinfo b/net/ruby-pcap/distinfo
new file mode 100644
index 000000000000..114154221fe3
--- /dev/null
+++ b/net/ruby-pcap/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ruby-pcap-0.6.tar.gz) = bf8024831bfbbf0cfbf7c7ca27c1b16a
diff --git a/net/ruby-pcap/pkg-comment b/net/ruby-pcap/pkg-comment
new file mode 100644
index 000000000000..03d666251b4a
--- /dev/null
+++ b/net/ruby-pcap/pkg-comment
@@ -0,0 +1 @@
+Ruby interface to LBL Packet Capture library (libpcap)
diff --git a/net/ruby-pcap/pkg-descr b/net/ruby-pcap/pkg-descr
new file mode 100644
index 000000000000..0d2d34e0f954
--- /dev/null
+++ b/net/ruby-pcap/pkg-descr
@@ -0,0 +1,8 @@
+Ruby interface to LBL Packet Capture library (libpcap). This library
+also includes classes to access packet header fields.
+
+It is much easier to code in Ruby/Pcap than to code in C and use
+libpcap directly.
+
+Author: Masaki Fukushima <fukusima@goto.info.waseda.ac.jp>
+WWW: http://www.goto.info.waseda.ac.jp/~fukusima/ruby/pcap-e.html
diff --git a/net/ruby-pcap/pkg-plist b/net/ruby-pcap/pkg-plist
new file mode 100644
index 000000000000..3eef454639fe
--- /dev/null
+++ b/net/ruby-pcap/pkg-plist
@@ -0,0 +1,40 @@
+%%RUBY_SITEARCHLIBDIR%%/pcap.so
+%%RUBY_SITELIBDIR%%/pcap_misc.rb
+%%RUBY_SITELIBDIR%%/pcaplet.rb
+%%RUBY_DOCDIR%%/pcap/Capture.html
+%%RUBY_DOCDIR%%/pcap/ChangeLog
+%%RUBY_DOCDIR%%/pcap/Dumper.html
+%%RUBY_DOCDIR%%/pcap/Filter.html
+%%RUBY_DOCDIR%%/pcap/ICMPPacket.html
+%%RUBY_DOCDIR%%/pcap/IPAddress.html
+%%RUBY_DOCDIR%%/pcap/IPPacket.html
+%%RUBY_DOCDIR%%/pcap/Packet.html
+%%RUBY_DOCDIR%%/pcap/Pcap.html
+%%RUBY_DOCDIR%%/pcap/PcapError.html
+%%RUBY_DOCDIR%%/pcap/Pcaplet.html
+%%RUBY_DOCDIR%%/pcap/README
+%%RUBY_DOCDIR%%/pcap/TCPPacket.html
+%%RUBY_DOCDIR%%/pcap/TruncatedPacket.html
+%%RUBY_DOCDIR%%/pcap/UDPPacket.html
+%%RUBY_DOCDIR%%/pcap/index.html
+%%RUBY_DOCDIR%%/pcap/ja/Capture.html
+%%RUBY_DOCDIR%%/pcap/ja/Dumper.html
+%%RUBY_DOCDIR%%/pcap/ja/Filter.html
+%%RUBY_DOCDIR%%/pcap/ja/ICMPPacket.html
+%%RUBY_DOCDIR%%/pcap/ja/IPAddress.html
+%%RUBY_DOCDIR%%/pcap/ja/IPPacket.html
+%%RUBY_DOCDIR%%/pcap/ja/Packet.html
+%%RUBY_DOCDIR%%/pcap/ja/Pcap.html
+%%RUBY_DOCDIR%%/pcap/ja/PcapError.html
+%%RUBY_DOCDIR%%/pcap/ja/Pcaplet.html
+%%RUBY_DOCDIR%%/pcap/ja/README.ja
+%%RUBY_DOCDIR%%/pcap/ja/TCPPacket.html
+%%RUBY_DOCDIR%%/pcap/ja/TruncatedPacket.html
+%%RUBY_DOCDIR%%/pcap/ja/UDPPacket.html
+%%RUBY_DOCDIR%%/pcap/ja/index.html
+%%RUBY_EXAMPLESDIR%%/pcap/httpdump.rb
+%%RUBY_EXAMPLESDIR%%/pcap/tcpdump.rb
+%%RUBY_EXAMPLESDIR%%/pcap/test.rb
+@dirrm %%RUBY_EXAMPLESDIR%%/pcap
+@dirrm %%RUBY_DOCDIR%%/pcap/ja
+@dirrm %%RUBY_DOCDIR%%/pcap