aboutsummaryrefslogtreecommitdiff
path: root/net/rwhois
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-10-27 20:49:26 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-10-27 20:49:26 +0000
commitc13d460af0787081fd35957b79c2e1de31be7c8e (patch)
treed75b13fa34fcccb4457f7b625a27613f05040d8f /net/rwhois
parenta10b0f06986c7d26abc6b23686b6225e9f3e36aa (diff)
downloadports-c13d460af0787081fd35957b79c2e1de31be7c8e.tar.gz
ports-c13d460af0787081fd35957b79c2e1de31be7c8e.zip
Fix build on -CURRENT.
Use DOCSDIR. Bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=92353
Diffstat (limited to 'net/rwhois')
-rw-r--r--net/rwhois/Makefile13
-rw-r--r--net/rwhois/files/patch-common-client_msgs.c35
-rw-r--r--net/rwhois/files/patch-common-client_msgs.h11
-rw-r--r--net/rwhois/files/patch-common-common.h11
-rw-r--r--net/rwhois/files/patch-common-log.c38
-rw-r--r--net/rwhois/files/patch-common-log.h23
-rw-r--r--net/rwhois/files/patch-common-rw_log.c38
-rw-r--r--net/rwhois/files/patch-server-notify.c31
-rw-r--r--net/rwhois/files/patch-server-notify.h0
-rw-r--r--net/rwhois/pkg-plist18
10 files changed, 200 insertions, 18 deletions
diff --git a/net/rwhois/Makefile b/net/rwhois/Makefile
index 5ea261996ce7..46d2aa29577f 100644
--- a/net/rwhois/Makefile
+++ b/net/rwhois/Makefile
@@ -7,6 +7,7 @@
PORTNAME= rwhois
PORTVERSION= 1.5.7.3
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.ayamura.org/pub/rwhois/ \
ftp://ftp.jp.pgpi.org/pub/rwhois/
@@ -30,22 +31,16 @@ MAN8= rwhois_indexer.8 rwhoisd.8
PORTDOCS= INSTALL.html TODO UPGRADE operations_guide.html \
operations_guide.txt rfc2167.txt security.html security.txt
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/rwhois_indexer.8 ${PREFIX}/man/man8
${INSTALL_MAN} ${WRKSRC}/doc/rwhoisd.8 ${PREFIX}/man/man8
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/rwhois
+ @${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${PREFIX}/share/doc/rwhois
+ ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
.endfor
.endif
@${ECHO_MSG} "Installing ${PREFIX}/etc/rc.d/rwhoisd.sh startup file..."
${INSTALL_SCRIPT} -m 751 ${FILESDIR}/rwhoisd.sh ${PREFIX}/etc/rc.d/rwhoisd.sh
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/rwhois/files/patch-common-client_msgs.c b/net/rwhois/files/patch-common-client_msgs.c
new file mode 100644
index 000000000000..77a8d9a2ef23
--- /dev/null
+++ b/net/rwhois/files/patch-common-client_msgs.c
@@ -0,0 +1,35 @@
+--- common/client_msgs.c.orig Tue Oct 28 02:24:02 2003
++++ common/client_msgs.c Tue Oct 28 02:25:00 2003
+@@ -145,22 +145,16 @@
+ printf ("%%ok\n");
+ }
+
+-void print_response(va_alist)
+- va_dcl
++void print_response(int resp_no, char *format, ...)
+ {
+ va_list list;
+ int i;
+- int resp_no;
+- char *format;
+ FILE *fp;
+
+- va_start(list);
++ va_start(list, format);
+
+ fp = get_out_fp();
+
+- resp_no = va_arg(list, int);
+- format = va_arg(list, char *);
+-
+ for (i = 0; i < N_RESP; i++)
+ {
+ if (resp[i].resp_no == resp_no)
+@@ -179,6 +173,7 @@
+ }
+
+ vfprintf(fp, format, list);
++ va_end(list);
+
+ fprintf(fp, "\n");
+ }
diff --git a/net/rwhois/files/patch-common-client_msgs.h b/net/rwhois/files/patch-common-client_msgs.h
new file mode 100644
index 000000000000..625697efba0b
--- /dev/null
+++ b/net/rwhois/files/patch-common-client_msgs.h
@@ -0,0 +1,11 @@
+--- common/client_msgs.h.orig Tue Oct 28 02:25:14 2003
++++ common/client_msgs.h Tue Oct 28 02:25:30 2003
+@@ -85,7 +85,7 @@
+
+ void print_error PROTO((int err_no, char *str));
+
+-void print_response PROTO(());
++void print_response PROTO((int resp_no, char *format, ...));
+
+ void print_ok PROTO((void));
+
diff --git a/net/rwhois/files/patch-common-common.h b/net/rwhois/files/patch-common-common.h
new file mode 100644
index 000000000000..84f7d11ad8fd
--- /dev/null
+++ b/net/rwhois/files/patch-common-common.h
@@ -0,0 +1,11 @@
+--- common/common.h.orig Tue Oct 28 02:23:23 2003
++++ common/common.h Tue Oct 28 02:23:33 2003
+@@ -56,7 +56,7 @@
+ # undef _VA_ALIGN
+ # undef __va_stack_arg
+ # endif
+-#include <varargs.h>
++#include <stdarg.h>
+ #endif /* HAVE_VPRINTF */
+
+ /* this should probably be #ifdef USG */
diff --git a/net/rwhois/files/patch-common-log.c b/net/rwhois/files/patch-common-log.c
new file mode 100644
index 000000000000..c4da8e6e911d
--- /dev/null
+++ b/net/rwhois/files/patch-common-log.c
@@ -0,0 +1,38 @@
+--- common/log.c.orig Tue Oct 28 02:26:55 2003
++++ common/log.c Tue Oct 28 02:28:25 2003
+@@ -139,15 +139,12 @@
+ /* log_error: prints a error message to the console. This is intended
+ for server side errors only. */
+ void
+-log_error(va_alist)
+- va_dcl
++log_error(char *format, ...)
+ {
+ va_list list;
+- char *format;
+ char err_buf[MAX_LINE];
+
+- va_start(list);
+- format = va_arg(list, char *);
++ va_start(list, format);
+
+ #ifdef HAVE_VSNPRINTF
+ vsnprintf(err_buf, sizeof(err_buf), format, list);
+@@ -164,15 +161,12 @@
+ /* log_warning: prints a warning message to the console. This is intended
+ for server side warnings only. */
+ void
+-log_warning(va_alist)
+- va_dcl
++log_warning(char *format, ...)
+ {
+ va_list list;
+- char *format;
+ char err_buf[MAX_LINE];
+
+- va_start(list);
+- format = va_arg(list, char *);
++ va_start(list, format);
+
+ #ifdef HAVE_VSNPRINTF
+ vsnprintf(err_buf, sizeof(err_buf), format, list);
diff --git a/net/rwhois/files/patch-common-log.h b/net/rwhois/files/patch-common-log.h
new file mode 100644
index 000000000000..1c105a1f8612
--- /dev/null
+++ b/net/rwhois/files/patch-common-log.h
@@ -0,0 +1,23 @@
+--- common/log.h.orig Tue Oct 28 02:25:55 2003
++++ common/log.h Tue Oct 28 02:29:55 2003
+@@ -95,8 +95,8 @@
+ /* old prototypes for backward compatibility */
+
+ #define l_strerror strerror
+-void log_error PROTO(());
+-void log_warning PROTO(());
++void log_error PROTO((char *format, ...));
++void log_warning PROTO((char *format, ...));
+ char *get_client_hostname PROTO((int sock));
+ char *timestamp PROTO(());
+
+@@ -106,7 +106,8 @@
+ (L_LOG_EMERG, L_LOG_ALERT, etc. [see internal_log_level in
+ types.h) and SECTION is one of (NETWORK, QUERY, CONFIG, etc [see
+ log_section in types.h) */
+-void log PROTO(());
++#define log Log
++void log PROTO((internal_log_levels level, int section, char *format, ...));
+
+ void setup_logging PROTO((void));
+
diff --git a/net/rwhois/files/patch-common-rw_log.c b/net/rwhois/files/patch-common-rw_log.c
new file mode 100644
index 000000000000..3807b136a551
--- /dev/null
+++ b/net/rwhois/files/patch-common-rw_log.c
@@ -0,0 +1,38 @@
+--- common/rw_log.c.orig Tue Oct 28 02:28:43 2003
++++ common/rw_log.c Tue Oct 28 02:30:14 2003
+@@ -17,13 +17,10 @@
+ #include "types.h"
+
+ void
+-log(va_alist)
+- va_dcl
++log(internal_log_levels level, int section, char *format, ...)
+ {
+ va_list ap;
+- internal_log_levels level;
+ FILE *fp;
+- char *format;
+ char *filename;
+ char *hostname;
+ char message[MAX_LINE];
+@@ -31,13 +28,9 @@
+ char *section_name;
+ int fd;
+ int use_syslog;
+- int section;
+ int syslog_level;
+
+- va_start(ap);
+- level = (internal_log_levels) va_arg(ap, int);
+- section = (int) va_arg(ap, int);
+- format = va_arg(ap, char*);
++ va_start(ap, format);
+
+ /* verbosity sets the level at which we ignore log messages */
+ if (level > get_verbosity())
+@@ -142,4 +135,5 @@
+
+ fclose(fp);
+ }
++ va_end(ap);
+ }
diff --git a/net/rwhois/files/patch-server-notify.c b/net/rwhois/files/patch-server-notify.c
new file mode 100644
index 000000000000..e4e71a95d91b
--- /dev/null
+++ b/net/rwhois/files/patch-server-notify.c
@@ -0,0 +1,31 @@
+--- server/notify.c.orig Tue Oct 28 02:30:38 2003
++++ server/notify.c Tue Oct 28 02:31:26 2003
+@@ -75,18 +75,13 @@
+
+ /* log notify information */
+ int
+-log_entry(va_alist)
+- va_dcl
++log_entry(char *filename, char *format, ...)
+ {
+ va_list ap;
+ FILE *fp;
+- char *format;
+- char *filename;
+ char *hostname;
+
+- va_start(ap);
+- filename = va_arg (ap, char*);
+- format = va_arg(ap, char*);
++ va_start(ap, format);
+
+ /* lock the file */
+ fp = get_file_lock(filename, "a", 60);
+@@ -103,6 +98,7 @@
+ fprintf(fp, " [%-15s] PID: %-8d", hostname, (int) getpid());
+ vfprintf(fp, format, ap);
+ fprintf(fp, "\n");
++ va_end(ap);
+
+ release_file_lock(filename, fp);
+
diff --git a/net/rwhois/files/patch-server-notify.h b/net/rwhois/files/patch-server-notify.h
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/net/rwhois/files/patch-server-notify.h
diff --git a/net/rwhois/pkg-plist b/net/rwhois/pkg-plist
index 65822e442674..b408906ebb78 100644
--- a/net/rwhois/pkg-plist
+++ b/net/rwhois/pkg-plist
@@ -34,15 +34,15 @@ lib/rwhois/rwhoisd.dir
lib/rwhois/rwhoisd.root
lib/rwhois/rwhoisd.x.dir
lib/rwhois/sbin/rwhoisd
-%%PORTDOCS%%share/doc/rwhois/INSTALL.html
-%%PORTDOCS%%share/doc/rwhois/TODO
-%%PORTDOCS%%share/doc/rwhois/UPGRADE
-%%PORTDOCS%%share/doc/rwhois/operations_guide.html
-%%PORTDOCS%%share/doc/rwhois/operations_guide.txt
-%%PORTDOCS%%share/doc/rwhois/rfc2167.txt
-%%PORTDOCS%%share/doc/rwhois/security.html
-%%PORTDOCS%%share/doc/rwhois/security.txt
-%%PORTDOCS%%@dirrm share/doc/rwhois
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL.html
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/UPGRADE
+%%PORTDOCS%%%%DOCSDIR%%/operations_guide.html
+%%PORTDOCS%%%%DOCSDIR%%/operations_guide.txt
+%%PORTDOCS%%%%DOCSDIR%%/rfc2167.txt
+%%PORTDOCS%%%%DOCSDIR%%/security.html
+%%PORTDOCS%%%%DOCSDIR%%/security.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm lib/rwhois/sbin
@dirrm lib/rwhois/net-10.0.0.0-8/data/referral
@dirrm lib/rwhois/net-10.0.0.0-8/data/network