aboutsummaryrefslogtreecommitdiff
path: root/net/samba-nmblookup
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-20 20:46:38 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-20 20:46:38 +0000
commit1abc97d3d906267fd9a7141cc46f909d38aa1800 (patch)
treef6f6a48876ebb9d316e363406440b8ba2416db79 /net/samba-nmblookup
parent46265967d0604ef0b642cb249653cd510fea4541 (diff)
downloadports-1abc97d3d906267fd9a7141cc46f909d38aa1800.tar.gz
ports-1abc97d3d906267fd9a7141cc46f909d38aa1800.zip
[new port] net/samba-nmblookup
There is a NetBIOS/tcp lookup tool nmblookup(1) included in samba suite. It's quite useful, but installing whole samba suite is not always necessary. I wrote a port to install nmblookup(1) only. Dutchman through the corner alert... What can I do against the wrongly added directories? PR: ports/90375 Submitted by: Hirohisa Yamaguchi <umq@ueo.co.jp>
Notes
Notes: svn path=/head/; revision=151674
Diffstat (limited to 'net/samba-nmblookup')
-rw-r--r--net/samba-nmblookup/Makefile42
-rw-r--r--net/samba-nmblookup/pkg-descr4
2 files changed, 46 insertions, 0 deletions
diff --git a/net/samba-nmblookup/Makefile b/net/samba-nmblookup/Makefile
new file mode 100644
index 000000000000..bf36d2b20cc6
--- /dev/null
+++ b/net/samba-nmblookup/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: samba-nmblookup
+# Date created: Mon Dec 5 17:00:56 JST 2005
+# Whom: Hirohisa Yamaguchi <umq@ueo.co.jp>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 1
+PORTEPOCH= 0
+PKGNAMESUFFIX= -nmblookup
+
+COMMENT= NetBIOS Name lookup tool
+
+CONFLICTS= ja-samba-2.* ja-samba-3.* samba-2.* samba-3.*
+
+SAMBA_PORT= samba3
+SAMBA_SUBPORT= yes
+
+.if ${SAMBA_PORT} != "samba3"
+BROKEN= "Does not build with samba-2 port"
+.endif
+
+MASTERDIR= ${.CURDIR}/../../net/${SAMBA_PORT}
+PKGDIR= ${.CURDIR}
+
+MAN1= nmblookup.1
+MAN5= smb.conf.5
+PLIST_FILES= bin/nmblookup
+
+# This is taken from SAMBA_PORT
+WITHOUT_ADS= yes
+
+do-build:
+ cd ${WRKSRC} && ${MAKE} include/proto.h
+ cd ${WRKSRC} && ${MAKE} bin/nmblookup
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/nmblookup ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/../docs/manpages/nmblookup.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/../docs/manpages/smb.conf.5 ${MAN5PREFIX}/man/man5
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/samba-nmblookup/pkg-descr b/net/samba-nmblookup/pkg-descr
new file mode 100644
index 000000000000..283ab61799c8
--- /dev/null
+++ b/net/samba-nmblookup/pkg-descr
@@ -0,0 +1,4 @@
+This is a tool to query NetBIOS names and map them to IP addresses
+in a network using NetBIOS over TCP/IP queries from the Samba port.
+
+WWW: http://www.samba.org/