aboutsummaryrefslogtreecommitdiff
path: root/net/samba-pdbsql
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-08-31 19:36:53 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-08-31 19:36:53 +0000
commitf5a8f8fbd0c486fe7e41eb871fb968e352dd98b0 (patch)
tree600e6aea524d2bc37e7b475df164cbbc230375d0 /net/samba-pdbsql
parentfae962b7dc1dfdc696352c93479127f4382db540 (diff)
downloadports-f5a8f8fbd0c486fe7e41eb871fb968e352dd98b0.tar.gz
ports-f5a8f8fbd0c486fe7e41eb871fb968e352dd98b0.zip
This port adds to Samba3 ability to use multiple 'passdb backends' at
the same time. Also it comes with sample MySQL and PostgreSQL backends, which allow to store passwords in the corresponding databases. This features were removed from upstream Samba3 in version 3.0.22. WWW: http://pdbsql.sourceforge.net/ PR: ports/102714 Submitted by: Timur I. Bakeyev <timur@gnu.org>
Notes
Notes: svn path=/head/; revision=171753
Diffstat (limited to 'net/samba-pdbsql')
-rw-r--r--net/samba-pdbsql/Makefile96
-rw-r--r--net/samba-pdbsql/distinfo3
-rw-r--r--net/samba-pdbsql/pkg-descr7
-rw-r--r--net/samba-pdbsql/pkg-plist12
4 files changed, 118 insertions, 0 deletions
diff --git a/net/samba-pdbsql/Makefile b/net/samba-pdbsql/Makefile
new file mode 100644
index 000000000000..25cf0313417e
--- /dev/null
+++ b/net/samba-pdbsql/Makefile
@@ -0,0 +1,96 @@
+# New ports collection makefile for: samba-pdbsql
+# Date created: 28th Aug 2006
+# Whom: Timur I. Bakeyev <timur@gnu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pdbsql
+PORTVERSION= 0.2
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= pdbsql
+PKGNAMEPREFIX= samba-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${PKGNAMEPREFIX}${SAMBA_VERSION}
+
+MAINTAINER= timur@gnu.org
+COMMENT= Multiplexor, MySQL and PostgeSQL passdb backends for Samba3
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+SAMBA_PORT= net/samba3
+SAMBA_VERSION= 3.0.23
+
+OPTIONS= MYSQL "With MySQL passdb backend" on \
+ PGSQL "With PostgreSQL passdb backend" on
+
+.include <bsd.port.pre.mk>
+
+SAMBA_WRKSRC!= cd ${PORTSDIR}/${SAMBA_PORT} && ${MAKE} -V WRKSRC
+.if !defined(SAMBA_WRKSRC) || empty(SAMBA_WRKSRC)
+IGNORE= unable to determine SAMBA_WRKSRC directory. Cannot continue
+.endif
+SAMBA_MODULEDIR!= cd ${PORTSDIR}/${SAMBA_PORT} && ${MAKE} -V SAMBA_MODULEDIR
+.if !defined(SAMBA_MODULEDIR) || empty(SAMBA_MODULEDIR)
+SAMBA_MODULEDIR= ${PREFIX}/lib/samba
+.endif
+SAMBA_PDBDIR= ${SAMBA_MODULEDIR}/pdb
+
+BUILD_DEPENDS+= ${NONEXISTENT}:${PORTSDIR}/${SAMBA_PORT}:configure
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+= --libdir=${SAMBA_PDBDIR} \
+ --with-samba-dir=${SAMBA_WRKSRC}
+
+.if exists(${LOCALBASE}/bin/mysql)
+WITH_MYSQL= yes
+. undef WITHOUT_MYSQL
+.endif
+
+.if exists(${LOCALBASE}/bin/pg_config)
+WITH_PGSQL= yes
+. undef WITHOUT_PGSQL
+.endif
+
+.if !defined(WITHOUT_MYSQL)
+USE_MYSQL= yes
+CONFIGURE_ARGS+= --with-mysql-prefix=${LOCALBASE}
+PLIST_SUB+= MYSQL=""
+.else
+PLIST_SUB+= MYSQL="@comment "
+.endif
+
+.if !defined(WITHOUT_PGSQL)
+USE_PGSQL= yes
+CONFIGURE_ARGS+= --with-pgsql-prefix=${LOCALBASE}
+PLIST_SUB+= PGSQL=""
+.else
+PLIST_SUB+= PGSQL="@comment "
+.endif
+
+pre-configure:
+ cd ${SAMBA_WRKSRC} && ${MAKE} proto
+
+do-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${SAMBA_PDBDIR}
+ @${INSTALL_PROGRAM} ${WRKSRC}/multi.so ${SAMBA_PDBDIR}
+.if !defined(WITHOUT_MYSQL)
+ @${INSTALL_PROGRAM} ${WRKSRC}/mysql.so ${SAMBA_PDBDIR}
+. for f in mysql.dump smb.conf.mysql
+ @${INSTALL_DATA} ${WRKSRC}/docs/${f} ${EXAMPLESDIR}
+. endfor
+.endif
+.if !defined(WITHOUT_PGSQL)
+ @${INSTALL_PROGRAM} ${WRKSRC}/pgsql.so ${SAMBA_PDBDIR}
+. for f in pgsql.dump smb.conf.pgsql
+ @${INSTALL_DATA} ${WRKSRC}/docs/${f} ${EXAMPLESDIR}
+. endfor
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/docs/pdb_mysql.xml ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/samba-pdbsql/distinfo b/net/samba-pdbsql/distinfo
new file mode 100644
index 000000000000..5f40e799f068
--- /dev/null
+++ b/net/samba-pdbsql/distinfo
@@ -0,0 +1,3 @@
+MD5 (pdbsql-0.2-samba-3.0.23.tar.bz2) = e2d1b65e1ae6097de58fa9709ca45ddc
+SHA256 (pdbsql-0.2-samba-3.0.23.tar.bz2) = 27ca8b8712df421691972b600ee7eaeb35285139c905539f1ef45a0765b236b0
+SIZE (pdbsql-0.2-samba-3.0.23.tar.bz2) = 69719
diff --git a/net/samba-pdbsql/pkg-descr b/net/samba-pdbsql/pkg-descr
new file mode 100644
index 000000000000..0094200fc154
--- /dev/null
+++ b/net/samba-pdbsql/pkg-descr
@@ -0,0 +1,7 @@
+This port adds to Samba3 ability to use multiple 'passdb backends' at
+the same time. Also it comes with sample MySQL and PostgreSQL backends,
+which allow to store passwords in the corresponding databases.
+
+This features were removed from upstream Samba3 in version 3.0.22.
+
+WWW: http://pdbsql.sourceforge.net/
diff --git a/net/samba-pdbsql/pkg-plist b/net/samba-pdbsql/pkg-plist
new file mode 100644
index 000000000000..0c76589b32af
--- /dev/null
+++ b/net/samba-pdbsql/pkg-plist
@@ -0,0 +1,12 @@
+lib/samba/pdb/multi.so
+%%MYSQL%%lib/samba/pdb/mysql.so
+%%PGSQL%%lib/samba/pdb/pgsql.so
+%%MYSQL%%%%EXAMPLESDIR%%/mysql.dump
+%%MYSQL%%%%EXAMPLESDIR%%/smb.conf.mysql
+%%PGSQL%%%%EXAMPLESDIR%%/pgsql.dump
+%%PGSQL%%%%EXAMPLESDIR%%/smb.conf.pgsql
+%%PORTDOCS%%%%DOCSDIR%%/pdb_mysql.xml
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%EXAMPLESDIR%%
+@dirrmtry lib/samba/pdb
+@dirrmtry lib/samba