aboutsummaryrefslogtreecommitdiff
path: root/net/samba3
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-01-06 17:59:31 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-01-06 17:59:31 +0000
commitb2a96c6df1c8809216eced623ec37a8372b3216e (patch)
tree0c994bc87e8a2f221a7e2be76b9aafc16eab32bb /net/samba3
parent87b685f5d4325ba771e96b0ef49c71f903fb3ae0 (diff)
downloadports-b2a96c6df1c8809216eced623ec37a8372b3216e.tar.gz
ports-b2a96c6df1c8809216eced623ec37a8372b3216e.zip
- Remove conditional checks for FreeBSD 5.x and older
Notes
Notes: svn path=/head/; revision=225335
Diffstat (limited to 'net/samba3')
-rw-r--r--net/samba3/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/net/samba3/Makefile b/net/samba3/Makefile
index 2c3d619b730f..929a0b124cf3 100644
--- a/net/samba3/Makefile
+++ b/net/samba3/Makefile
@@ -169,12 +169,8 @@ CONFIGURE_ARGS+= --without-utmp
CONFIGURE_ARGS+= --with-winbind
PLIST_SUB+= WINBIND=""
SUB_LIST+= WINBIND=""
-. if ${OSVERSION} >= 500112
WITH_WINBIND_NSS= yes
PLIST_SUB+= WINBIND_NSS=""
-. else
-PLIST_SUB+= WINBIND_NSS="@comment "
-. endif
.else
CONFIGURE_ARGS+= --without-winbind
PLIST_SUB+= WINBIND="@comment " WINBIND_NSS="@comment "
@@ -213,9 +209,6 @@ CONFIGURE_ARGS+= --disable-fam
.endif
.if defined(WITH_ACL_SUPPORT)
-.if ${OSVERSION} < 500018
-IGNORE= an ACL support requires 5.1-RELEASE or later. Disable ACL support
-.endif
CONFIGURE_ARGS+= --with-acl-support
.else
CONFIGURE_ARGS+= --without-acl-support
@@ -405,8 +398,8 @@ pre-configure:
@${FIND} ${WRKDIR}/${DISTNAME} -type d | ${XARGS} ${CHMOD} u+w,a+rx
@${FIND} ${WRKDIR}/${DISTNAME} -type f | ${XARGS} ${CHMOD} u+w,a+r
-# This would speedup compilation for gcc 3.4(available in FreeBSD 5.2) and higher
-.if !defined(WITHOUT_PCH) && ${OSVERSION} >= 502126
+# This would speedup compilation
+.if !defined(WITHOUT_PCH)
pre-build:
cd ${WRKSRC} && ${MAKE} pch
.endif