aboutsummaryrefslogtreecommitdiff
path: root/net/sbd/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-07-10 17:08:17 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-07-10 17:08:17 +0000
commit1c3762d85bb8e964a218dd815a4d56ba098405eb (patch)
tree8464af64dc29fb16503d0d391e8e69a1d6c707f8 /net/sbd/Makefile
parentbf26c28e8ccd9f460bb2c8678988355ffa95c56b (diff)
downloadports-1c3762d85bb8e964a218dd815a4d56ba098405eb.tar.gz
ports-1c3762d85bb8e964a218dd815a4d56ba098405eb.zip
sbd is a Netcat-clone, designed to be portable and offer strong
encryption. It runs on Unix-like operating systems and on Microsoft Win32. sbd features AES-CBC-128 + HMAC-SHA1 encryption (by Christophe Devine), program execution (-e option), choosing source port, continuous reconnection with delay, and some other nice features. Only TCP/IP communication is supported. Source code and binaries are distributed under the GNU General Public License. sbd can be used for any number of network-related things, e.g.: * Secure file transfer * Remote administration * Simple (but secure) peer-to-peer chat * Pen-test tool (crypto avoids NIDS detection and telnet-style traffic recording) PR: 68838 Submitted by: David Thiel <lx@redundancy.redundancy.org> Approved by: krion (mentor)
Notes
Notes: svn path=/head/; revision=113339
Diffstat (limited to 'net/sbd/Makefile')
-rw-r--r--net/sbd/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net/sbd/Makefile b/net/sbd/Makefile
new file mode 100644
index 000000000000..9dc7c4d79cf5
--- /dev/null
+++ b/net/sbd/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: sbd
+# Date created: 2004-07-08
+# Whom: David Thiel (lx@redundancy.redundancy.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= sbd
+PORTVERSION= 1.31
+CATEGORIES= net security
+MASTER_SITES= http://www.cycom.se/uploads/114/31/
+
+MAINTAINER= lx@redundancy.redundancy.org
+COMMENT= A netcat clone with more features and crypto
+
+ALL_TARGET= unix
+
+PLIST_FILES= bin/sbd
+PORTDOCS= README
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sbd ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>