aboutsummaryrefslogtreecommitdiff
path: root/net/scnc
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2008-05-03 09:20:44 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2008-05-03 09:20:44 +0000
commit328ce19ad879d490485ab19ec4ce1fec3450974f (patch)
tree3926914dee8cb25996206419f80910d3a5a06246 /net/scnc
parent929cd0b83816f5469e798a6c4320aa0c2fce5612 (diff)
downloadports-328ce19ad879d490485ab19ec4ce1fec3450974f.tar.gz
ports-328ce19ad879d490485ab19ec4ce1fec3450974f.zip
scnc is a SSL Capable Netcat with SSL support, TCP and UDP
proxying and IPV4/IPV6 proxying features. WWW: http://gomor.org/bin/view/GomorOrg/SslNetcat PR: ports/123300 Submitted by: Sofian Brabez <sbrabez at gmail.com> Approved by: tabthorpe (mentor)
Notes
Notes: svn path=/head/; revision=212525
Diffstat (limited to 'net/scnc')
-rw-r--r--net/scnc/Makefile36
-rw-r--r--net/scnc/distinfo3
-rw-r--r--net/scnc/pkg-descr4
3 files changed, 43 insertions, 0 deletions
diff --git a/net/scnc/Makefile b/net/scnc/Makefile
new file mode 100644
index 000000000000..a2739b1289ee
--- /dev/null
+++ b/net/scnc/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: scnc
+# Date created: 27 April 2008
+# Whom: Sofian Brabez <sbrabez@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scnc
+PORTVERSION= 1.00
+CATEGORIES= net security
+MASTER_SITES= http://gomor.org/files/ \
+ http://knkorp.info/patches/freebsd/
+#DISTFILES= ${PORTNAME}
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= # none
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= sbrabez@gmail.com
+COMMENT= SSL Capable Netcat
+
+RUN_DEPENDS= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ ${SITE_PERL}/Net/Telnet.pm:${PORTSDIR}/net/p5-Net-Telnet \
+ ${SITE_PERL}/IO/Socket/INET6.pm:${PORTSDIR}/net/p5-IO-INET6
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PLIST_FILES= bin/${PORTNAME}
+NO_BUILD= yes
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${_DISTDIR}/scnc ${WRKSRC}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/net/scnc/distinfo b/net/scnc/distinfo
new file mode 100644
index 000000000000..51b1d82e59b6
--- /dev/null
+++ b/net/scnc/distinfo
@@ -0,0 +1,3 @@
+MD5 (scnc-1.00/scnc) = 1a465d90c6788de1da6a1932cc16c6ab
+SHA256 (scnc-1.00/scnc) = c5c02a373c31c3a2ef0d5c3a1d5066713bddb2997518fbb1972bc4118343eb96
+SIZE (scnc-1.00/scnc) = 14620
diff --git a/net/scnc/pkg-descr b/net/scnc/pkg-descr
new file mode 100644
index 000000000000..ffa181fca9bb
--- /dev/null
+++ b/net/scnc/pkg-descr
@@ -0,0 +1,4 @@
+scnc is a SSL Capable Netcat with SSL support, TCP and UDP
+proxying and IPV4/IPV6 proxying features.
+
+WWW: http://gomor.org/bin/view/GomorOrg/SslNetcat