aboutsummaryrefslogtreecommitdiff
path: root/net/sendfile
diff options
context:
space:
mode:
authorJun-ichiro itojun Hagino <itojun@FreeBSD.org>1998-04-19 03:36:55 +0000
committerJun-ichiro itojun Hagino <itojun@FreeBSD.org>1998-04-19 03:36:55 +0000
commit0ca70ab97ad8d018e8e7cdea63471af2daee7d1b (patch)
tree3e8d5fc416094494ec69c5a9ba9fe88c23813efe /net/sendfile
parent7c21ec4fca26aa1343057b3ab21e991486813978 (diff)
downloadports-0ca70ab97ad8d018e8e7cdea63471af2daee7d1b.tar.gz
ports-0ca70ab97ad8d018e8e7cdea63471af2daee7d1b.zip
original distribution updated.
PR: 6210
Notes
Notes: svn path=/head/; revision=10570
Diffstat (limited to 'net/sendfile')
-rw-r--r--net/sendfile/Makefile4
-rw-r--r--net/sendfile/distinfo2
-rw-r--r--net/sendfile/files/patch-ab57
3 files changed, 41 insertions, 22 deletions
diff --git a/net/sendfile/Makefile b/net/sendfile/Makefile
index 01f5815b82e8..a8903beed415 100644
--- a/net/sendfile/Makefile
+++ b/net/sendfile/Makefile
@@ -3,10 +3,10 @@
# Date created: 30 Oct 1997
# Whom: sec@42.org
#
-# $Id: Makefile,v 1.1.1.1 1998/02/24 20:28:16 steve Exp $
+# $Id: Makefile,v 1.2 1998/03/01 21:50:37 steve Exp $
#
-DISTNAME= sendfile-19980228
+DISTNAME= sendfile-19980316
PKGNAME= sendfile-2.1
CATEGORIES= net
MASTER_SITES= ftp://ftp.uni-stuttgart.de/pub/unix/comm/sendfile/current/
diff --git a/net/sendfile/distinfo b/net/sendfile/distinfo
index 8bd6225bc85d..b1e430da3238 100644
--- a/net/sendfile/distinfo
+++ b/net/sendfile/distinfo
@@ -1 +1 @@
-MD5 (sendfile-19980228.tar.gz) = bb2a3e8c4906b37237fa958a8bf8bb1a
+MD5 (sendfile-19980316.tar.gz) = 0f540ff6c451440c909ee1e11e95c869
diff --git a/net/sendfile/files/patch-ab b/net/sendfile/files/patch-ab
index fd4f1f315bba..1e8f5e60c8df 100644
--- a/net/sendfile/files/patch-ab
+++ b/net/sendfile/files/patch-ab
@@ -1,6 +1,35 @@
---- develop/install.orig Fri Feb 27 08:29:16 1998
-+++ develop/install Sun Mar 1 15:34:53 1998
-@@ -133,14 +133,6 @@
+--- develop/install.orig Fri Mar 13 01:16:41 1998
++++ develop/install Sat Apr 4 18:53:55 1998
+@@ -113,17 +113,9 @@
+ if [ "$INETDCONF" = "" ]; then INETDCONF=/etc/inetd.conf; fi
+ if [ "$SERVICES" = "" ]; then SERVICES=/etc/services; fi
+
+-if [ -f /usr/man/man7/locale.7 -o -f /usr/man/man7/term.7 ]; then
+- manmisc=7
+-else
+- manmisc=5
+-fi
++manmisc=7
+
+-if [ -f /usr/man/man8/inetd.8 ]; then
+- manadmin=8
+-else
+- manadmin=1m
+-fi
++manadmin=8
+
+ # purge old logfiles (bug from sendfile revision < 19980310)
+ (cd $SPOOL && rm -f */.sendfile*.log)
+@@ -132,7 +124,7 @@
+ umask 022
+ cd src || exit 1
+ cp sendfile sendmsg receive utf7encode fetchfile wlock $BINDIR/
+- [ -x $SERVERDIR/sendfiled ] && mv $SERVERDIR/sendfiled $SERVERDIR/sendfiled.old && rm $SERVERDIR/sendfiled.old
++ [ -x $SERVERDIR/sendfiled ] && mv $SERVERDIR/sendfiled $SERVERDIR/sendfiled.old && rm -f $SERVERDIR/sendfiled.old
+ cp sendfiled $SERVERDIR
+ cd ..
+ install_man
+@@ -156,14 +148,6 @@
To deinstall the sendfile-daemon, simply type: rm $SERVERDIR/sendfiled
EOD
@@ -15,15 +44,16 @@
umask 022
-@@ -195,6 +187,7 @@
+@@ -213,7 +197,7 @@
echo " there is $SERVERDIR/sendfiled in makeconfig! Check it!"
fi
echo "installing the sendfile-daemon in $SERVERDIR"
-+[ -x $SERVERDIR/sendfiled ] && mv $SERVERDIR/sendfiled $SERVERDIR/sendfiled.old
+-[ -x $SERVERDIR/sendfiled ] && mv $SERVERDIR/sendfiled $SERVERDIR/sendfiled.old && rm $SERVERDIR/sendfiled.old
++[ -x $SERVERDIR/sendfiled ] && mv $SERVERDIR/sendfiled $SERVERDIR/sendfiled.old && rm -f $SERVERDIR/sendfiled.old
cp src/sendfiled $SERVERDIR || exit 1
NOSENDFILE=`dirname $DENY 2>/dev/null`/nosendfile
-@@ -240,7 +233,6 @@
+@@ -259,7 +243,6 @@
echo "saft 487/tcp # simple asynchronous file transfer" | niload services .
else
echo "configuring $SERVICES"
@@ -31,7 +61,7 @@
echo "saft 487/tcp # simple asynchronous file transfer" >>$SERVICES
fi
fi
-@@ -253,8 +245,6 @@
+@@ -272,8 +255,6 @@
fi
RESTART=true
echo "configuring $INETDCONF"
@@ -40,16 +70,7 @@
echo "saft stream tcp nowait root $SFD" >>$INETDCONF
fi
-@@ -278,7 +268,7 @@
- echo "adding check_sendfile to /etc/csh.login"
- echo >>/etc/csh.login
- echo "test -x $BINDIR/check_sendfile && $BINDIR/check_sendfile" \
-- >>/etc/profile
-+ >>/etc/csh.login
- fi
- fi
-
-@@ -318,15 +308,11 @@
+@@ -337,15 +318,10 @@
EOD
fi
@@ -69,5 +90,3 @@
+ kill -HUP `ps auxw|awk '$11 == "inetd" { print $2 } '`
+ [ -f $SERVERDIR/sendfiled.old ] && rm -f $SERVERDIR/sendfiled.old
fi
-+true
-\ No newline at end of file