aboutsummaryrefslogtreecommitdiff
path: root/net/sendsms
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-12-21 11:21:55 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-12-21 11:21:55 +0000
commit250408275e12d0aaa0119ec8543565c2f7d584f2 (patch)
tree7b34e57e07bb2523aff793dfe024924ac6c9b871 /net/sendsms
parent434ec501290f687f12392203029207b669addeb2 (diff)
downloadports-250408275e12d0aaa0119ec8543565c2f7d584f2.tar.gz
ports-250408275e12d0aaa0119ec8543565c2f7d584f2.zip
Add sendsms 0.2.3, simple perl command-line utility to send SMS via from
on provider site. PR: ports/90528 Submitted by: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
Notes
Notes: svn path=/head/; revision=151742
Diffstat (limited to 'net/sendsms')
-rw-r--r--net/sendsms/Makefile37
-rw-r--r--net/sendsms/distinfo3
-rw-r--r--net/sendsms/pkg-descr22
3 files changed, 62 insertions, 0 deletions
diff --git a/net/sendsms/Makefile b/net/sendsms/Makefile
new file mode 100644
index 000000000000..fafa2e6d91f8
--- /dev/null
+++ b/net/sendsms/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: www/sendsms
+# Date created: 2005-12-17
+# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
+#
+# $FreeBSD$
+#
+# $Tecnik: ports/www/sendsms/Makefile,v 1.1 2005/12/17 03:27:10 itetcu Exp $
+
+PORTNAME= sendsms
+PORTVERSION= 0.2.3
+CATEGORIES= net perl5
+MASTER_SITES= http://caspian.dotconf.net/menu/Software/SendSMS/ \
+ http://people.tecnik93.com/~itetcu/FreeBSD/ports/${PORTNAME}/sources/
+DISTNAME= sendSMS.pl
+EXTRACT_SUFX= .gz
+
+MAINTAINER= itetcu@people.tecnik93.com
+COMMENT= Simple perl command-line utility to send SMS via from on provider site
+
+EXTRACT_AFTER_ARGS= > ${WRKSRC}/${PORTNAME}
+
+PLIST_FILES= bin/sendsms
+
+CONFLICTS= smstools-[0-9]*
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_PERL5_RUN= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/usr/bin/perl,${PERL},g" ${WRKSRC}/${PORTNAME}
+
+do-install:
+ cd ${WRKSRC} && ${INSTALL_SCRIPT} ${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/net/sendsms/distinfo b/net/sendsms/distinfo
new file mode 100644
index 000000000000..e4603b99213f
--- /dev/null
+++ b/net/sendsms/distinfo
@@ -0,0 +1,3 @@
+MD5 (sendSMS.pl.gz) = c2658e1cd3ad0594c492bfbedb2fc023
+SHA256 (sendSMS.pl.gz) = d30e65c58fa626641939d9d413c29859cc80dbcdd76cadddbad866c2227f5e68
+SIZE (sendSMS.pl.gz) = 12725
diff --git a/net/sendsms/pkg-descr b/net/sendsms/pkg-descr
new file mode 100644
index 000000000000..e79effe4e405
--- /dev/null
+++ b/net/sendsms/pkg-descr
@@ -0,0 +1,22 @@
+If you have an AT&T Wireless, Bell Canada/Bell Mobility, Cellular One,
+Cingular, Cricket, Sprint PCS, SkyTel, or T-Mobile cell phone or pager, and you
+want the ability to send SMS messages to it via a command-line utility, this is
+what you need. All this program requires is a computer with a baseline Perl 5.x
+installation and web access. NO EXTRA PERL MODULES REQUIRED!
+
+How does it work?
+SendSMS connects to your service provider's web page and pretends to submit a
+form to their 'Instant Messaging' web page. Currently, AT&T Wireless, Bell
+Canada/Bell Mobility, Cellular One, Cingular, Cricket, SkyTel, Sprint PCS, and
+T-Mobile are supported. Users are encouraged to modify the provided templates to
+add support for any providers who are currently unsupported.
+
+Other Service Providers
+If you are interested in supporting another service provider please try to
+modify sendSMS on your own. It is not hard at all. Instructions and examples are
+included in the code, and if you're familiar with the site you're porting to, it
+takes about 15 minutes. If you get sendSMS working with any other providers' web
+sites, please email Paul Kreiner [deacon at thedeacon.org] and/or the port
+maintainer a patch so it can be added to the next release.
+
+WWW: http://caspian.dotconf.net/menu/Software/SendSMS/