aboutsummaryrefslogtreecommitdiff
path: root/net/ser
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2006-05-29 17:52:18 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2006-05-29 17:52:18 +0000
commit2e0d191f46199d8a53c6f6635bdbbc37e0f34e1d (patch)
tree9efccb7a8418053001d48e2ea0dc96ffb4047533 /net/ser
parent128460e57cc9ab1b02bd771567fdbae3760b48ef (diff)
downloadports-2e0d191f46199d8a53c6f6635bdbbc37e0f34e1d.tar.gz
ports-2e0d191f46199d8a53c6f6635bdbbc37e0f34e1d.zip
Fix problem with non-NULL values appearing as NULL properly.
Submitted by: Alexandre Snarskii <snar@paranoia.ru>
Notes
Notes: svn path=/head/; revision=163870
Diffstat (limited to 'net/ser')
-rw-r--r--net/ser/Makefile2
-rw-r--r--net/ser/files/patch-modules::auth_db::authorize.c44
-rw-r--r--net/ser/files/patch-modules::postgres::db_val.c13
3 files changed, 14 insertions, 45 deletions
diff --git a/net/ser/Makefile b/net/ser/Makefile
index 3c97f2dff50c..ab4a9e732c2e 100644
--- a/net/ser/Makefile
+++ b/net/ser/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ser
PORTVERSION= 0.9.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://download.berlios.de/ser/ \
http://download2.berlios.de/ser/
diff --git a/net/ser/files/patch-modules::auth_db::authorize.c b/net/ser/files/patch-modules::auth_db::authorize.c
deleted file mode 100644
index 15fb53b5e220..000000000000
--- a/net/ser/files/patch-modules::auth_db::authorize.c
+++ /dev/null
@@ -1,44 +0,0 @@
-
-$FreeBSD$
-
---- modules/auth_db/authorize.c
-+++ modules/auth_db/authorize.c
-@@ -101,7 +101,7 @@
- }
- pkg_free(col);
-
-- if ((RES_ROW_N(*res) == 0) || VAL_NULL(ROW_VALUES(RES_ROWS(*res)))) {
-+ if (RES_ROW_N(*res) == 0) {
- DBG("get_ha1(): no result for user \'%.*s@%.*s\'\n",
- _username->user.len, ZSW(_username->user.s), (use_domain ? (_domain->len) : 0), ZSW(_domain->s));
- return 1;
-@@ -212,9 +212,7 @@
- rpid.s = NULL;
- rpid.len = 0;
- for (i = 0; i < avps_str_n; i++) {
-- if (avps_str[i].len != 4
-- || VAL_NULL(&(result->rows[0].values[1 + avps_int_n + i]))
-- || memcmp(avps_str[i].s, "rpid", 4) != 0)
-+ if (avps_str[i].len != 4 || memcmp(avps_str[i].s, "rpid", 4) != 0)
- continue;
- rpid.s = (char*)VAL_STRING(&(result->rows[0].values[1 + avps_int_n + i]));
- if(rpid.s!=NULL)
-@@ -230,8 +228,6 @@
- return -1;
- case AUTHORIZED:
- for (i = 0; i < avps_int_n; i++) {
-- if(VAL_NULL(&(result->rows[0].values[1 + i])))
-- continue;
- iname.s = &(avps_int[i]);
- ivalue.n = VAL_INT(&(result->rows[0].values[1 + i]));
- add_avp(AVP_NAME_STR, iname, ivalue);
-@@ -240,8 +236,7 @@
- }
- for (i = 0; i < avps_str_n; i++) {
- value.s = (char*)VAL_STRING(&(result->rows[0].values[1 + avps_int_n + i]));
-- if(VAL_NULL(&(result->rows[0].values[1 + avps_int_n + i]))
-- || value.s==NULL)
-+ if(value.s==NULL)
- continue;
- iname.s = &(avps_str[i]);
- value.len = strlen(value.s);
diff --git a/net/ser/files/patch-modules::postgres::db_val.c b/net/ser/files/patch-modules::postgres::db_val.c
new file mode 100644
index 000000000000..b2d168147f52
--- /dev/null
+++ b/net/ser/files/patch-modules::postgres::db_val.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- modules/postgres/db_val.c
++++ modules/postgres/db_val.c
+@@ -185,6 +185,7 @@
+ VAL_NULL(_v) = 1;
+ return 0;
+ }
++ VAL_NULL(_v) = 0;
+
+ switch(_t) {
+ case DB_INT: