aboutsummaryrefslogtreecommitdiff
path: root/net/shelldap
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-09 00:51:12 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-09 00:51:12 +0000
commitb3dc9651f8a74a32ecd34c05b56d867130f368f0 (patch)
treedf702b857568449c580b31084bc8713ae8e65ca7 /net/shelldap
parentc8757290e859a3245448c9d2538fc71ae68b40e0 (diff)
downloadports-b3dc9651f8a74a32ecd34c05b56d867130f368f0.tar.gz
ports-b3dc9651f8a74a32ecd34c05b56d867130f368f0.zip
Add shelldap 0.1, a shell-like environment for LDAP.
PR: ports/99908 Submitted by: Mahlon E. Smith <mahlon at martini.nu> Approved by: delphij (mentor, implicit)
Notes
Notes: svn path=/head/; revision=167239
Diffstat (limited to 'net/shelldap')
-rw-r--r--net/shelldap/Makefile41
-rw-r--r--net/shelldap/distinfo3
-rw-r--r--net/shelldap/pkg-descr15
3 files changed, 59 insertions, 0 deletions
diff --git a/net/shelldap/Makefile b/net/shelldap/Makefile
new file mode 100644
index 000000000000..31d593694534
--- /dev/null
+++ b/net/shelldap/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: shelldap
+# Date created: 2006-07-07
+# Whom: Mahlon E. Smith <mahlon@martini.nu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= shelldap
+PORTVERSION= 0.1
+CATEGORIES= net
+MASTER_SITES= http://www.martini.nu/misc/
+
+MAINTAINER= mahlon@martini.nu
+COMMENT= A shell-like environment for LDAP
+
+RUN_DEPENDS= \
+ ${SITE_PERL}/Algorithm/Diff.pm:${PORTSDIR}/devel/p5-Algorithm-Diff \
+ ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap \
+ ${SITE_PERL}/Digest/HMAC_MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/Term/Shell.pm:${PORTSDIR}/devel/p5-Term-Shell \
+ ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
+ ${SITE_PERL}/${PERL_ARCH}/Term/ReadLine/Gnu.pm:${PORTSDIR}/devel/p5-ReadLine-Gnu \
+ ${SITE_PERL}/${PERL_ARCH}/YAML/Syck.pm:${PORTSDIR}/textproc/p5-YAML-Syck
+
+USE_PERL5= yes
+
+MAN1= shelldap.1
+
+PLIST_FILES= bin/shelldap
+
+NO_BUILD= yes
+
+post-extract:
+ ${MKDIR} ${WRKSRC}/man/man1
+ ${LOCALBASE}/bin/pod2man < ${WRKSRC}/shelldap > ${WRKSRC}/man/man1/shelldap.1
+
+do-install:
+ ${INSTALL_MAN} ${WRKSRC}/man/man1/shelldap.1 ${MANPREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/shelldap ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/shelldap/distinfo b/net/shelldap/distinfo
new file mode 100644
index 000000000000..1fcb09291cc2
--- /dev/null
+++ b/net/shelldap/distinfo
@@ -0,0 +1,3 @@
+MD5 (shelldap-0.1.tar.gz) = a283288b657ca0a307f12031c9e97371
+SHA256 (shelldap-0.1.tar.gz) = 41344c5a474124a0ddbff1b2086ec3a0d15b4fcc475db993c4ad71782ae3cc7a
+SIZE (shelldap-0.1.tar.gz) = 12179
diff --git a/net/shelldap/pkg-descr b/net/shelldap/pkg-descr
new file mode 100644
index 000000000000..278df234a628
--- /dev/null
+++ b/net/shelldap/pkg-descr
@@ -0,0 +1,15 @@
+This is shelldap, a handy shell-like interface for browsing
+LDAP servers and editing their content.
+
+Among its features:
+
+ - history
+ - sane autocompletes
+ - credential caching
+ - site-wide and individual config
+ - it's in perl
+ - it's fun to say! shelldap! shelldap! shelldap!
+
+For more info, 'perldoc' the script.
+
+Author: Mahlon E. Smith <mahlon@martini.nu>