aboutsummaryrefslogtreecommitdiff
path: root/net/silc-server
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-11-09 07:50:55 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-11-09 07:50:55 +0000
commit71c77b1076c4591849619fc5fd1764954cbb5628 (patch)
tree6e4489c2236b3a939dce80f2970e138476bedd2d /net/silc-server
parent22f6a5de2184e95d6e400606afa1d63138fbc6f0 (diff)
downloadports-71c77b1076c4591849619fc5fd1764954cbb5628.tar.gz
ports-71c77b1076c4591849619fc5fd1764954cbb5628.zip
o Add port silc-server version 0.6.2: Secure Internet Live Conferencing
(SILC) network server o With invaluable feedback from debolaz during our all-nighter porting work :) Reviewed by: Anders Nor Berle <debolaz@debolaz.com>
Notes
Notes: svn path=/head/; revision=49866
Diffstat (limited to 'net/silc-server')
-rw-r--r--net/silc-server/Makefile66
-rw-r--r--net/silc-server/distinfo1
-rw-r--r--net/silc-server/files/patch-Makefile.in13
-rw-r--r--net/silc-server/files/patch-configure11
-rw-r--r--net/silc-server/files/patch-lib:Makefile.in28
-rw-r--r--net/silc-server/files/patch-lib:dotconf:src:Makefile.in11
-rw-r--r--net/silc-server/files/patch-lib:silccrypt:silcrng.c26
-rw-r--r--net/silc-server/pkg-comment1
-rw-r--r--net/silc-server/pkg-descr17
-rw-r--r--net/silc-server/pkg-plist3
10 files changed, 177 insertions, 0 deletions
diff --git a/net/silc-server/Makefile b/net/silc-server/Makefile
new file mode 100644
index 000000000000..a2f1b486dd01
--- /dev/null
+++ b/net/silc-server/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: silc server
+# Date created: Thu Nov 8 01:50:05 BRST 2001
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= silc
+PORTVERSION= 0.6.2
+CATEGORIES= net security
+MASTER_SITES= http://www.silcnet.org/download/ \
+ ftp://ftp.silcnet.org/pub/silc/
+PKGNAMESUFFIX= -server
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+
+MAINTAINER= lioux@FreeBSD.org
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-silcd-config-file=${PREFIX}/etc/${PORTNAME}/silcd.conf \
+ --with-docdir=share/doc/${PORTNAME} \
+ --with-etcdir=${PREFIX}/etc/${PORTNAME} \
+ --with-helpdir=share/${PORTNAME}/help \
+ --with-logsdir=${PORTNAME}/logs \
+ --with-silcd-pid-file=/var/run \
+ --with-simdir=libexec/${PORTNAME}/modules
+INSTALLS_SHLIB= yes
+PLIST_SUB= INSTALL_DIR="${INSTALL_DIR}"
+
+INSTALL_DIR?= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
+
+.ifdef(WITHOUT_OPTIMIZED_ASM)
+CONFIGURE_ARGS+= --disable-asm
+.endif
+
+.ifndef(WITH_PTHREADS)
+CONFIGURE_ARGS+= --disable-threads
+.else
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} ${PTHREAD_LIBS}"
+.endif
+
+pre-everything::
+.ifndef(WITHOUT_OPTIMIZED_ASM)
+ @${ECHO_MSG} '===> Define WITHOUT_OPTIMIZED_ASM to disable assembler optimizations'
+.endif
+.ifndef(WITH_PTHREADS)
+ @${ECHO_MSG} '===> Define WITH_PTHREADS to enable pthreads support'
+.endif
+ @${ECHO_MSG}
+.ifndef(WITH_OPTIMIZED_CFLAGS)
+ @${ECHO_MSG} '===> Define WITH_OPTIMIZED_CFLAGS to enable compilation optimizations'
+ @${ECHO_MSG} '===> which is known to break some platforms (e.g., alpha)'
+.endif
+
+post-patch:
+.ifndef(WITH_OPTIMIZED_CFLAGS)
+ @${PERL} -pi -e 's/-O2//' ${WRKSRC}/${CONFIGURE_SCRIPT}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+WITHOUT_OPTIMIZED_ASM= yes
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/silc-server/distinfo b/net/silc-server/distinfo
new file mode 100644
index 000000000000..b5f884a8e537
--- /dev/null
+++ b/net/silc-server/distinfo
@@ -0,0 +1 @@
+MD5 (silc-server-0.6.2.tar.bz2) = aaef2947dc28d6b5d3651d99213ce0c1
diff --git a/net/silc-server/files/patch-Makefile.in b/net/silc-server/files/patch-Makefile.in
new file mode 100644
index 000000000000..9a4ef20e994d
--- /dev/null
+++ b/net/silc-server/files/patch-Makefile.in
@@ -0,0 +1,13 @@
+--- Makefile.in.orig Fri Nov 9 00:26:32 2001
++++ Makefile.in Fri Nov 9 00:26:39 2001
+@@ -543,10 +543,6 @@
+ $(etcdir)/silcd.conf; \
+ chmod go= $(etcdir)/silcd.conf; \
+ fi
+- -@if test '!' -f $(etcdir)/silc.conf ; then \
+- $(INSTALL_DATA) $(srcdir)/doc/example_silc.conf \
+- $(etcdir)/silc.conf; \
+- fi
+
+ @SILC_DIST_CLIENT_TRUE@install-data-hook: install-dirs sim-install doc-install etc-install
+ @SILC_DIST_CLIENT_FALSE@install-data-hook: install-dirs generate-server-key sim-install doc-install etc-install
diff --git a/net/silc-server/files/patch-configure b/net/silc-server/files/patch-configure
new file mode 100644
index 000000000000..0a9dcb4a76dd
--- /dev/null
+++ b/net/silc-server/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Thu Nov 8 14:44:02 2001
++++ configure Thu Nov 8 14:45:48 2001
+@@ -8499,7 +8499,7 @@
+ fi
+ ;;
+ *-freebsd2.2*)
+- CFLAGS="$CFLAGS -D_THREAD_SAFE"
++ CFLAGS="$CFLAGS"
+ ;;
+ *-sysv5uw7*) # UnixWare 7
+ if test "$GCC" != "yes"; then
diff --git a/net/silc-server/files/patch-lib:Makefile.in b/net/silc-server/files/patch-lib:Makefile.in
new file mode 100644
index 000000000000..77bac513fd33
--- /dev/null
+++ b/net/silc-server/files/patch-lib:Makefile.in
@@ -0,0 +1,28 @@
+--- lib/Makefile.in.orig Fri Nov 9 00:36:48 2001
++++ lib/Makefile.in Fri Nov 9 00:37:05 2001
+@@ -116,13 +116,12 @@
+ silcutil \
+ silcclient \
+ silcsftp \
+- dotconf \
+ trq
+
+
+ # zlib
+-SUBDIRS = contrib silccore silccrypt silcsim silcmath silcske silcutil trq dotconf silcsftp
+-DIST_SUBDIRS = contrib silccore silccrypt silcsim silcmath silcske silcutil trq dotconf silcsftp
++SUBDIRS = contrib silccore silccrypt silcsim silcmath silcske silcutil trq silcsftp
++DIST_SUBDIRS = contrib silccore silccrypt silcsim silcmath silcske silcutil trq silcsftp
+
+ # SILC Library dirs
+ SILCLIB_DIRS = \
+@@ -134,8 +133,7 @@
+ silcske \
+ silcutil \
+ silcsftp \
+- trq \
+- dotconf
++ trq
+
+
+ # SILC Client Library dirs
diff --git a/net/silc-server/files/patch-lib:dotconf:src:Makefile.in b/net/silc-server/files/patch-lib:dotconf:src:Makefile.in
new file mode 100644
index 000000000000..2353fa102336
--- /dev/null
+++ b/net/silc-server/files/patch-lib:dotconf:src:Makefile.in
@@ -0,0 +1,11 @@
+--- lib/dotconf/src/Makefile.in.orig Thu Nov 8 23:46:47 2001
++++ lib/dotconf/src/Makefile.in Thu Nov 8 23:47:31 2001
+@@ -91,7 +91,7 @@
+ noinst_HEADERS = readdir.h
+ lib_LTLIBRARIES = libdotconf.la
+ libdotconf_la_SOURCES = dotconf.c readdir.c
+-libdotconf_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -release $(LT_RELEASE) -export-dynamic
++libdotconf_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -export-dynamic
+
+
+ EXTRA_DIST = dotconf.dsp
diff --git a/net/silc-server/files/patch-lib:silccrypt:silcrng.c b/net/silc-server/files/patch-lib:silccrypt:silcrng.c
new file mode 100644
index 000000000000..17a24e0684b0
--- /dev/null
+++ b/net/silc-server/files/patch-lib:silccrypt:silcrng.c
@@ -0,0 +1,26 @@
+--- lib/silccrypt/silcrng.c.orig Sun Nov 4 07:59:11 2001
++++ lib/silccrypt/silcrng.c Thu Nov 8 14:34:30 2001
+@@ -28,12 +28,23 @@
+
+ #include "silcincludes.h"
+
++#if (defined(__unix__) || defined(unix)) && !defined(USG)
++#include <sys/param.h>
++#endif
++
++#if (defined(BSD) && (BSD >= 199103))
++# if defined(HAVE_GETSID) || defined(HAVE_GETPGID)
++# include <unistd.h>
++# endif
++#else
++
+ #ifdef HAVE_GETSID
+ extern __pid_t getsid (__pid_t __pid);
+ #endif
+
+ #ifdef HAVE_GETPGID
+ extern __pid_t getpgid (__pid_t __pid);
++#endif
+ #endif
+
+ #undef SILC_RNG_DEBUG
diff --git a/net/silc-server/pkg-comment b/net/silc-server/pkg-comment
new file mode 100644
index 000000000000..fc48e5201d9e
--- /dev/null
+++ b/net/silc-server/pkg-comment
@@ -0,0 +1 @@
+Secure Internet Live Conferencing (SILC) network server
diff --git a/net/silc-server/pkg-descr b/net/silc-server/pkg-descr
new file mode 100644
index 000000000000..0d94b58856c6
--- /dev/null
+++ b/net/silc-server/pkg-descr
@@ -0,0 +1,17 @@
+[ from developer's site FAQ ]
+
+This is a SILC network server
+
+Q: What is SILC?
+
+A: SILC (Secure Internet Live Conferencing) is a protocol which
+provides secure conferencing services in the Internet over insecure
+channel. SILC is IRC like although internally they are very different.
+Biggest similarity between SILC and IRC is that they both provide
+conferencing services and that SILC has almost same commands as
+IRC. Other than that they are nothing alike.
+
+Biggest differences are that SILC is secure what IRC is not in any
+way. The network model is also entirely different compared to IRC.
+
+WWW: http://www.silcnet.org/
diff --git a/net/silc-server/pkg-plist b/net/silc-server/pkg-plist
new file mode 100644
index 000000000000..a1788bb458a8
--- /dev/null
+++ b/net/silc-server/pkg-plist
@@ -0,0 +1,3 @@
+etc/silc/silcd.conf
+sbin/i386--freebsd4.4-silcd
+@dirrm etc/silc