aboutsummaryrefslogtreecommitdiff
path: root/net/sipsak
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-10-26 14:12:14 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-10-26 14:12:14 +0000
commite7835108d79501ff36e7f617dbabe856da0b7513 (patch)
tree19d470dce26994c6baf0861339e4d6b1dc292197 /net/sipsak
parent33f57ea588ed6c094d754fa6d0b579c54d112b6c (diff)
downloadports-e7835108d79501ff36e7f617dbabe856da0b7513.tar.gz
ports-e7835108d79501ff36e7f617dbabe856da0b7513.zip
- Update to 0.8.11
PR: ports/73104 Submitted by: Hendrik Scholz <hendrik@scholz.net> Approved by: jesusr (maintainer)
Notes
Notes: svn path=/head/; revision=120226
Diffstat (limited to 'net/sipsak')
-rw-r--r--net/sipsak/Makefile2
-rw-r--r--net/sipsak/distinfo4
-rw-r--r--net/sipsak/files/patch-helper.c11
-rw-r--r--net/sipsak/files/patch-sipsak.c31
-rw-r--r--net/sipsak/files/patch-sipsak.h10
5 files changed, 55 insertions, 3 deletions
diff --git a/net/sipsak/Makefile b/net/sipsak/Makefile
index e0fedadf1207..a6b57484e213 100644
--- a/net/sipsak/Makefile
+++ b/net/sipsak/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sipsak
-PORTVERSION= 0.8.9
+PORTVERSION= 0.8.11
CATEGORIES= net
MASTER_SITES= http://download.berlios.de/sipsak/
diff --git a/net/sipsak/distinfo b/net/sipsak/distinfo
index 43b2c3a22c11..94fb0f856414 100644
--- a/net/sipsak/distinfo
+++ b/net/sipsak/distinfo
@@ -1,2 +1,2 @@
-MD5 (sipsak-0.8.9.tar.gz) = 567aaf2e746e005852fec8d7ab86dc0b
-SIZE (sipsak-0.8.9.tar.gz) = 125919
+MD5 (sipsak-0.8.11.tar.gz) = 6ec31fe34412028050be304ae728c371
+SIZE (sipsak-0.8.11.tar.gz) = 133219
diff --git a/net/sipsak/files/patch-helper.c b/net/sipsak/files/patch-helper.c
new file mode 100644
index 000000000000..ef847bf4f05e
--- /dev/null
+++ b/net/sipsak/files/patch-helper.c
@@ -0,0 +1,11 @@
+--- helper.c.orig Tue Oct 26 15:49:48 2004
++++ helper.c Tue Oct 26 15:53:43 2004
+@@ -23,6 +23,8 @@
+ #include <sys/utsname.h>
+ #include <string.h>
+ #include <ctype.h>
++#include <sys/types.h>
++#include <netinet/in.h>
+ #include <arpa/inet.h>
+
+ #include "helper.h"
diff --git a/net/sipsak/files/patch-sipsak.c b/net/sipsak/files/patch-sipsak.c
new file mode 100644
index 000000000000..9190b37e0731
--- /dev/null
+++ b/net/sipsak/files/patch-sipsak.c
@@ -0,0 +1,31 @@
+--- sipsak.c.orig Fri Oct 8 20:07:14 2004
++++ sipsak.c Tue Oct 26 15:55:19 2004
+@@ -207,6 +207,9 @@
+ char buff[BUFSIZE];
+ int length, c, i, j;
+ char *delim, *delim2;
++ pid_t pid;
++ struct timespec ts;
++ int upp;
+ #ifdef HAVE_GETOPT_LONG
+ int option_index = 0;
+ static struct option l_opts[] = {
+@@ -269,9 +272,6 @@
+ memset(ack, 0, BUFSIZE);
+ memset(fqdn, 0, FQDN_SIZE);
+ memset(messusern, 0, FQDN_SIZE);
+- pid_t pid;
+- struct timespec ts;
+- int upp;
+
+ if (argc==1) print_help();
+
+@@ -354,7 +354,7 @@
+ flood=1;
+ break;
+ case 'f':
+- if strncmp(optarg, "-", 1) {
++ if (strncmp(optarg, "-", 1)) {
+ /* file is opened in binary mode so that the cr-lf is
+ preserved */
+ pf = fopen(optarg, "rb");
diff --git a/net/sipsak/files/patch-sipsak.h b/net/sipsak/files/patch-sipsak.h
new file mode 100644
index 000000000000..79b1ec189ad0
--- /dev/null
+++ b/net/sipsak/files/patch-sipsak.h
@@ -0,0 +1,10 @@
+--- sipsak.h.orig Fri Oct 8 19:30:52 2004
++++ sipsak.h Tue Oct 26 15:49:07 2004
+@@ -19,6 +19,7 @@
+ #ifndef SIPSAK_H
+ #define SIPSAK_H
+
++#include <sys/types.h>
+ #include <regex.h>
+
+ #if HAVE_CONFIG_H