aboutsummaryrefslogtreecommitdiff
path: root/net/sipxpbx
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-02-12 00:22:40 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-02-12 00:22:40 +0000
commitb6af2c0f48e30d17b42cb10e63ca861c3cd4b942 (patch)
tree827d8f221174328f7bdb0651af551750c78f08c7 /net/sipxpbx
parent10ae353f6f1445796c100bb7de8b6f77c3b1ba7d (diff)
downloadports-b6af2c0f48e30d17b42cb10e63ca861c3cd4b942.tar.gz
ports-b6af2c0f48e30d17b42cb10e63ca861c3cd4b942.zip
- Fix build problems with last mod_cplusplus update
- Fix point to the correct locations for INSTALL.ssl - Bump PORTREVISION Submitted by: Mike Durian <durian@shadetreesoftware.com> (maintainer)
Notes
Notes: svn path=/head/; revision=184932
Diffstat (limited to 'net/sipxpbx')
-rw-r--r--net/sipxpbx/Makefile1
-rw-r--r--net/sipxpbx/files/patch-src_mod_sipxauth_SIPXAuthHandler.cpp23
-rw-r--r--net/sipxpbx/files/patch-src_mod_sipxauth_SIPXAuthHandler.h11
-rw-r--r--net/sipxpbx/files/pkg-message.in2
4 files changed, 36 insertions, 1 deletions
diff --git a/net/sipxpbx/Makefile b/net/sipxpbx/Makefile
index c57e4995615d..044575541bdb 100644
--- a/net/sipxpbx/Makefile
+++ b/net/sipxpbx/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sipxpbx
PORTVERSION= 3.6.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.sipfoundry.org/pub/sipX/3.6/SRC/
diff --git a/net/sipxpbx/files/patch-src_mod_sipxauth_SIPXAuthHandler.cpp b/net/sipxpbx/files/patch-src_mod_sipxauth_SIPXAuthHandler.cpp
new file mode 100644
index 000000000000..38153e5f2586
--- /dev/null
+++ b/net/sipxpbx/files/patch-src_mod_sipxauth_SIPXAuthHandler.cpp
@@ -0,0 +1,23 @@
+--- src/mod_sipxauth/SIPXAuthHandler.cpp.orig Sun Feb 11 18:35:47 2007
++++ src/mod_sipxauth/SIPXAuthHandler.cpp Sun Feb 11 18:41:37 2007
+@@ -168,7 +168,7 @@
+ rPidStr = temp;
+ }
+
+-SIPXAuthHandler::SIPXAuthHandler() : ApacheHandler()
++SIPXAuthHandler::SIPXAuthHandler(ApacheServerRec *pRequest) : ApacheHandler(pRequest)
+ {
+ // do NOT Initialize the IMDB Singleton - Note this is called
+ // running as user root so delay until running as user apache
+@@ -625,9 +625,9 @@
+
+ /*=====================INSTANCIATORS==========================*/
+
+-ApacheHandler *instanciate_auth()
++ApacheHandler *instanciate_auth(ApacheServerRec *pServer)
+ {
+- return new SIPXAuthHandler();
++ return new SIPXAuthHandler(pServer);
+ }
+
+ // Make sure this symbol is exported and also it is crucial
diff --git a/net/sipxpbx/files/patch-src_mod_sipxauth_SIPXAuthHandler.h b/net/sipxpbx/files/patch-src_mod_sipxauth_SIPXAuthHandler.h
new file mode 100644
index 000000000000..f218ca2efc43
--- /dev/null
+++ b/net/sipxpbx/files/patch-src_mod_sipxauth_SIPXAuthHandler.h
@@ -0,0 +1,11 @@
+--- src/mod_sipxauth/SIPXAuthHandler.h.orig Sun Feb 11 18:35:54 2007
++++ src/mod_sipxauth/SIPXAuthHandler.h Sun Feb 11 18:42:19 2007
+@@ -56,7 +56,7 @@
+ };
+
+ /** Ctor */
+- SIPXAuthHandler (void);
++ SIPXAuthHandler (ApacheServerRec *pRequest);
+
+ /** Dtor */
+ ~SIPXAuthHandler(void);
diff --git a/net/sipxpbx/files/pkg-message.in b/net/sipxpbx/files/pkg-message.in
index fb718cbe520f..c91912ee87e5 100644
--- a/net/sipxpbx/files/pkg-message.in
+++ b/net/sipxpbx/files/pkg-message.in
@@ -21,7 +21,7 @@ Please read:
sipX provide a couple scripts to simplify the SSL certificate
generation and installation procedure. Please read:
- %%DOCSDIR%%/INSTALL.ssl
+ %%PREFIX%%/share/doc/sipxcommserverlib/INSTALL.ssl
You will also need to adjust your %%APACHEETCDIR%%/httpd.conf file.
Ensure httpd runs as user sipx and group sipx. Ala: