aboutsummaryrefslogtreecommitdiff
path: root/net/smokeping
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-02-09 21:00:17 +0000
committerLars Thegler <lth@FreeBSD.org>2005-02-09 21:00:17 +0000
commit4c4ce880cc394f5459bb7714f318b067305f1bb5 (patch)
treebe1ef86cf7c2fa8777a1e85a762d5726a95f3bf1 /net/smokeping
parent3e18e828e3abd70532013e9170302b35b024817f (diff)
downloadports-4c4ce880cc394f5459bb7714f318b067305f1bb5.tar.gz
ports-4c4ce880cc394f5459bb7714f318b067305f1bb5.zip
- Update to 1.38
- Rearranged man pages and port docs accordingly Noticed by: Daniel Johansson <donnex@gmail.com>
Notes
Notes: svn path=/head/; revision=128411
Diffstat (limited to 'net/smokeping')
-rw-r--r--net/smokeping/Makefile69
-rw-r--r--net/smokeping/distinfo4
-rw-r--r--net/smokeping/files/patch-bin-smokeping.dist16
-rw-r--r--net/smokeping/files/patch-htdocs-smokeping.cgi.dist6
-rw-r--r--net/smokeping/pkg-plist104
5 files changed, 126 insertions, 73 deletions
diff --git a/net/smokeping/Makefile b/net/smokeping/Makefile
index c1f2db0f9284..26608fc963d0 100644
--- a/net/smokeping/Makefile
+++ b/net/smokeping/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= smokeping
-PORTVERSION= 1.31
-PORTREVISION= 1
+PORTVERSION= 1.38
CATEGORIES= net www
MASTER_SITES= http://people.ee.ethz.ch/~oetiker/webtools/smokeping/pub/
@@ -58,12 +57,12 @@ NO_BUILD= yes
USE_REINPLACE= yes
USE_PERL5= yes
-MAN1= CiscoRTTMonDNS.pm.1 CiscoRTTMonEchoICMP.pm.1 CiscoRTTMonTcpConnect.pm.1 \
- Curl.pm.1 DNS.pm.1 EchoPing.pm.1 EchoPingChargen.pm.1 EchoPingDiscard.pm.1 \
- EchoPingHttp.pm.1 EchoPingHttps.pm.1 EchoPingIcp.pm.1 EchoPingSmtp.pm.1 \
- FPing.pm.1 FPing6.pm.1 IOSPing.pm.1 ParseConfig.pm.1 RemoteFPing.pm.1 \
- Smokeping.pm.1 base.pm.1 basefork.pm.1 basevars.pm.1 smokeping.1 \
- smokeping.cgi.1 smokeping_config.1 smokeping_install.1 telnetIOSPing.pm.1
+MAN1= ParseConfig.pm.1 \
+ Smokeping.pm.1 \
+ smokeping.1 \
+ smokeping.cgi.1 \
+ smokeping_config.1 \
+ smokeping_install.1
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGINSTALL= ${WRKDIR}/pkg-install
@@ -82,19 +81,48 @@ FILES_SUB= USER=${USER} GROUP=${GROUP} \
PERL=${PERL} PREFIX=${PREFIX}
DOC1= CHANGES CONTRIBUTORS COPYING COPYRIGHT README TODO
-DOC2= CiscoRTTMonDNS.pm CiscoRTTMonEchoICMP.pm CiscoRTTMonTcpConnect.pm \
- Curl.pm DNS.pm EchoPing.pm EchoPingChargen.pm EchoPingDiscard.pm \
- EchoPingHttp.pm EchoPingHttps.pm EchoPingIcp.pm EchoPingSmtp.pm \
- FPing.pm FPing6.pm IOSPing.pm ParseConfig.pm RemoteFPing.pm Smokeping.pm \
- base.pm basefork.pm basevars.pm smokeping.cgi \
- smokeping smokeping_config smokeping_install telnetIOSPing.pm
+DOC2= ParseConfig.pm \
+ Smokeping.pm \
+ matchers/avgratio.pm \
+ matchers/base.pm \
+ matchers/median.pm \
+ probes/AnotherDNS.pm \
+ probes/AnotherSSH.pm \
+ probes/CiscoRTTMonDNS.pm \
+ probes/CiscoRTTMonEchoICMP.pm \
+ probes/CiscoRTTMonTcpConnect.pm \
+ probes/Curl.pm \
+ probes/DNS.pm \
+ probes/EchoPing.pm \
+ probes/EchoPingChargen.pm \
+ probes/EchoPingDiscard.pm \
+ probes/EchoPingHttp.pm \
+ probes/EchoPingHttps.pm \
+ probes/EchoPingIcp.pm \
+ probes/EchoPingSmtp.pm \
+ probes/FPing.pm \
+ probes/FPing6.pm \
+ probes/IOSPing.pm \
+ probes/LDAP.pm \
+ probes/Radius.pm \
+ probes/RemoteFPing.pm \
+ probes/SSH.pm \
+ probes/base.pm \
+ probes/basefork.pm \
+ probes/basevars.pm \
+ probes/passwordchecker.pm \
+ probes/telnetIOSPing.pm \
+ smokeping.cgi \
+ smokeping \
+ smokeping_config \
+ smokeping_install
ETC1= basepage.html config smokemail config-echoping
# Things that shouldn't have been in the tarball in the first place
post-extract:
@${RM} ${WRKSRC}/lib/BER.pm
@${RM} ${WRKSRC}/lib/SNMP_*.pm
- @${RM} ${WRKSRC}/lib/probes/patch
+ @${RM} ${WRKSRC}/lib/ISG/.#ParseConfig.pm.1.26
post-patch:
@${FIND} ${WRKSRC} -name \*.orig -delete
@@ -104,6 +132,7 @@ pre-configure:
${WRKSRC}/bin/smokeping.dist \
${WRKSRC}/htdocs/smokeping.cgi.dist \
${WRKSRC}/etc/config.dist \
+ ${WRKSRC}/etc/config-echoping.dist \
${WRKSRC}/lib/probes/*.pm
@${FIND} ${WRKSRC} -name \*.bak -delete
@${SED} ${FILES_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
@@ -126,15 +155,17 @@ do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/bin/smokeping ${PREFIX}/bin
.if !defined(NOPORTDOCS)
.for FILE in ${MAN1}
- @${INSTALL_MAN} ${WRKSRC}/doc/${FILE} ${PREFIX}/man/man1
+ @${INSTALL_MAN} ${WRKSRC}/doc/man/man1/${FILE} ${PREFIX}/man/man1
.endfor
@${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}/matchers
+ @${MKDIR} ${DOCSDIR}/probes
.for FILE in ${DOC1}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}/${FILE}
.endfor
.for FILE in ${DOC2}
- @${INSTALL_DATA} ${WRKSRC}/doc/${FILE}.html ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/${FILE}.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${FILE}.html ${DOCSDIR}/${FILE}.html
+ ${INSTALL_DATA} ${WRKSRC}/doc/${FILE}.txt ${DOCSDIR}/${FILE}.txt
.endfor
.endif
@${MKDIR} ${PREFIX}/etc/smokeping
diff --git a/net/smokeping/distinfo b/net/smokeping/distinfo
index 3213701cd8c1..a28858b741d6 100644
--- a/net/smokeping/distinfo
+++ b/net/smokeping/distinfo
@@ -1,2 +1,2 @@
-MD5 (smokeping-1.31.tar.gz) = 1d175cdc39cdacaa7d81059501bdd725
-SIZE (smokeping-1.31.tar.gz) = 200712
+MD5 (smokeping-1.38.tar.gz) = d885a9d27fdbbc3ddf8f3295d283faa8
+SIZE (smokeping-1.38.tar.gz) = 225115
diff --git a/net/smokeping/files/patch-bin-smokeping.dist b/net/smokeping/files/patch-bin-smokeping.dist
index f0fae8d5038c..c0011a8e6935 100644
--- a/net/smokeping/files/patch-bin-smokeping.dist
+++ b/net/smokeping/files/patch-bin-smokeping.dist
@@ -1,24 +1,22 @@
---- bin/smokeping.dist.orig Sun Jan 18 15:48:21 2004
-+++ bin/smokeping.dist Sun Jan 18 15:52:40 2004
-@@ -1,14 +1,11 @@
--#!/usr/sepp/bin/perl -w
+--- bin/smokeping.dist.orig Sun Jan 30 17:56:30 2005
++++ bin/smokeping.dist Mon Feb 7 21:46:26 2005
+@@ -1,12 +1,11 @@
+-#!/usr/sepp/bin/perl-5.8.0 -w
+#!%%PERL%% -w
# -*-perl-*-
--use lib qw(/home/oetiker/data/projects/AABN-rrdtool/perl-shared/blib/lib);
--use lib qw(/home/oetiker/data/projects/AABN-rrdtool/perl-shared/blib/arch);
--use lib qw(/usr/pack/rrdtool-1.0.40-ds/lib/perl/5.8.0);
+-use lib qw(/usr/pack/rrdtool-1.0.47-to/lib);
-use lib qw(/home/oetiker/data/projects/AADJ-smokeping/dist/lib);
+use lib qw(%%PREFIX%%/smokeping/lib);
- use Smokeping 1.31;
+ use Smokeping 1.38;
-Smokeping::main("etc/config.dist");
+Smokeping::main("%%PREFIX%%/etc/smokeping/config");
=head1 NAME
-@@ -86,22 +83,8 @@
+@@ -101,22 +100,8 @@
=head1 SETUP
diff --git a/net/smokeping/files/patch-htdocs-smokeping.cgi.dist b/net/smokeping/files/patch-htdocs-smokeping.cgi.dist
index c9fd03cc12fc..b8535089133e 100644
--- a/net/smokeping/files/patch-htdocs-smokeping.cgi.dist
+++ b/net/smokeping/files/patch-htdocs-smokeping.cgi.dist
@@ -1,5 +1,5 @@
---- htdocs/smokeping.cgi.dist.orig Sun Oct 5 16:20:06 2003
-+++ htdocs/smokeping.cgi.dist Sun Jan 11 18:03:19 2004
+--- htdocs/smokeping.cgi.dist.orig Sun Jan 30 17:56:30 2005
++++ htdocs/smokeping.cgi.dist Mon Feb 7 21:49:11 2005
@@ -1,12 +1,11 @@
-#!/usr/sepp/bin/speedy -w
+#!%%PREFIX%%/bin/speedy -w
@@ -9,7 +9,7 @@
-use lib qw(/home/oetiker/data/projects/AADJ-smokeping/dist/lib);
+use lib qw(%%PREFIX%%/smokeping/lib);
- use Smokeping 1.31;
+ use Smokeping 1.38;
-Smokeping::cgi("/home/oetiker/data/projects/AADJ-smokeping/dist/etc/config");
+Smokeping::cgi("%%PREFIX%%/etc/smokeping/config");
diff --git a/net/smokeping/pkg-plist b/net/smokeping/pkg-plist
index 836609111c19..7560f1e67dd2 100644
--- a/net/smokeping/pkg-plist
+++ b/net/smokeping/pkg-plist
@@ -18,48 +18,10 @@ etc/smokeping/config-echoping.dist
%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%%%DOCSDIR%%/CiscoRTTMonDNS.pm.html
-%%PORTDOCS%%%%DOCSDIR%%/CiscoRTTMonDNS.pm.txt
-%%PORTDOCS%%%%DOCSDIR%%/CiscoRTTMonEchoICMP.pm.html
-%%PORTDOCS%%%%DOCSDIR%%/CiscoRTTMonEchoICMP.pm.txt
-%%PORTDOCS%%%%DOCSDIR%%/CiscoRTTMonTcpConnect.pm.html
-%%PORTDOCS%%%%DOCSDIR%%/CiscoRTTMonTcpConnect.pm.txt
-%%PORTDOCS%%%%DOCSDIR%%/Curl.pm.html
-%%PORTDOCS%%%%DOCSDIR%%/Curl.pm.txt
-%%PORTDOCS%%%%DOCSDIR%%/DNS.pm.html
-%%PORTDOCS%%%%DOCSDIR%%/DNS.pm.txt
-%%PORTDOCS%%%%DOCSDIR%%/EchoPing.pm.html
-%%PORTDOCS%%%%DOCSDIR%%/EchoPing.pm.txt
-%%PORTDOCS%%%%DOCSDIR%%/EchoPingChargen.pm.html
-%%PORTDOCS%%%%DOCSDIR%%/EchoPingChargen.pm.txt
-%%PORTDOCS%%%%DOCSDIR%%/EchoPingDiscard.pm.html
-%%PORTDOCS%%%%DOCSDIR%%/EchoPingDiscard.pm.txt
-%%PORTDOCS%%%%DOCSDIR%%/EchoPingHttp.pm.html
-%%PORTDOCS%%%%DOCSDIR%%/EchoPingHttp.pm.txt
-%%PORTDOCS%%%%DOCSDIR%%/EchoPingHttps.pm.html
-%%PORTDOCS%%%%DOCSDIR%%/EchoPingHttps.pm.txt
-%%PORTDOCS%%%%DOCSDIR%%/EchoPingIcp.pm.html
-%%PORTDOCS%%%%DOCSDIR%%/EchoPingIcp.pm.txt
-%%PORTDOCS%%%%DOCSDIR%%/EchoPingSmtp.pm.html
-%%PORTDOCS%%%%DOCSDIR%%/EchoPingSmtp.pm.txt
-%%PORTDOCS%%%%DOCSDIR%%/FPing.pm.html
-%%PORTDOCS%%%%DOCSDIR%%/FPing.pm.txt
-%%PORTDOCS%%%%DOCSDIR%%/FPing6.pm.html
-%%PORTDOCS%%%%DOCSDIR%%/FPing6.pm.txt
-%%PORTDOCS%%%%DOCSDIR%%/IOSPing.pm.html
-%%PORTDOCS%%%%DOCSDIR%%/IOSPing.pm.txt
%%PORTDOCS%%%%DOCSDIR%%/ParseConfig.pm.html
%%PORTDOCS%%%%DOCSDIR%%/ParseConfig.pm.txt
-%%PORTDOCS%%%%DOCSDIR%%/RemoteFPing.pm.html
-%%PORTDOCS%%%%DOCSDIR%%/RemoteFPing.pm.txt
%%PORTDOCS%%%%DOCSDIR%%/Smokeping.pm.html
%%PORTDOCS%%%%DOCSDIR%%/Smokeping.pm.txt
-%%PORTDOCS%%%%DOCSDIR%%/base.pm.html
-%%PORTDOCS%%%%DOCSDIR%%/base.pm.txt
-%%PORTDOCS%%%%DOCSDIR%%/basefork.pm.html
-%%PORTDOCS%%%%DOCSDIR%%/basefork.pm.txt
-%%PORTDOCS%%%%DOCSDIR%%/basevars.pm.html
-%%PORTDOCS%%%%DOCSDIR%%/basevars.pm.txt
%%PORTDOCS%%%%DOCSDIR%%/smokeping.cgi.html
%%PORTDOCS%%%%DOCSDIR%%/smokeping.cgi.txt
%%PORTDOCS%%%%DOCSDIR%%/smokeping.html
@@ -68,12 +30,71 @@ etc/smokeping/config-echoping.dist
%%PORTDOCS%%%%DOCSDIR%%/smokeping_config.txt
%%PORTDOCS%%%%DOCSDIR%%/smokeping_install.html
%%PORTDOCS%%%%DOCSDIR%%/smokeping_install.txt
-%%PORTDOCS%%%%DOCSDIR%%/telnetIOSPing.pm.html
-%%PORTDOCS%%%%DOCSDIR%%/telnetIOSPing.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/matchers/avgratio.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/matchers/avgratio.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/matchers/base.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/matchers/base.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/matchers/median.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/matchers/median.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/AnotherDNS.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/AnotherDNS.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/AnotherSSH.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/AnotherSSH.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/CiscoRTTMonDNS.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/CiscoRTTMonDNS.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/CiscoRTTMonEchoICMP.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/CiscoRTTMonEchoICMP.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/CiscoRTTMonTcpConnect.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/CiscoRTTMonTcpConnect.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/Curl.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/Curl.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/DNS.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/DNS.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/EchoPing.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/EchoPing.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/EchoPingChargen.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/EchoPingChargen.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/EchoPingDiscard.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/EchoPingDiscard.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/EchoPingHttp.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/EchoPingHttp.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/EchoPingHttps.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/EchoPingHttps.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/EchoPingIcp.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/EchoPingIcp.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/EchoPingSmtp.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/EchoPingSmtp.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/FPing.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/FPing.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/FPing6.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/FPing6.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/IOSPing.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/IOSPing.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/LDAP.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/LDAP.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/Radius.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/Radius.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/RemoteFPing.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/RemoteFPing.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/SSH.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/SSH.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/base.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/base.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/basefork.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/basefork.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/basevars.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/basevars.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/passwordchecker.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/passwordchecker.pm.txt
+%%PORTDOCS%%%%DOCSDIR%%/probes/telnetIOSPing.pm.html
+%%PORTDOCS%%%%DOCSDIR%%/probes/telnetIOSPing.pm.txt
smokeping/htdocs/smokeping.cgi
smokeping/lib/ISG/ParseConfig.pm
smokeping/lib/Smokeping.pm
smokeping/lib/ciscoRttMonMIB.pm
+smokeping/lib/matchers/base.pm
+smokeping/lib/matchers/median.pm
+smokeping/lib/matchers/avgratio.pm
smokeping/lib/probes/AnotherDNS.pm
smokeping/lib/probes/AnotherSSH.pm
smokeping/lib/probes/CiscoRTTMonDNS.pm
@@ -109,7 +130,10 @@ smokeping/lib/probes/telnetIOSPing.pm
@unexec rmdir %D/var 2>/dev/null || true
@dirrm smokeping/htdocs
@dirrm smokeping/lib/probes
+@dirrm smokeping/lib/matchers
@dirrm smokeping/lib/ISG
@dirrm smokeping/lib
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/probes
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/matchers
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@unexec rmdir %D/smokeping 2>/dev/null || true