aboutsummaryrefslogtreecommitdiff
path: root/net/spread4/pkg-install
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-03-02 16:59:30 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-03-02 16:59:30 +0000
commit1825eac2c9e98835dc70730709169f3dfb6ff319 (patch)
tree3aad28d0f1c6fff5c1e4ee6ecdcb6b050f259d18 /net/spread4/pkg-install
parentb04648ed0f4f9c722860e336b6862c3ed1ec28c0 (diff)
downloadports-1825eac2c9e98835dc70730709169f3dfb6ff319.tar.gz
ports-1825eac2c9e98835dc70730709169f3dfb6ff319.zip
- update to 3.16.1
- pass maintainership to submitter - make the java dependency more flexible - get rid of NO_PACKAGE and add a pkg-install script to create the user/group needed - use DOCSDIR instead of the port-specific DOCDIR - set PKGMESSAGE to the license file - sort pkg-plist - respect PREFIX PR: 35407 Submitted by: Joshua Goodall <joshua@roughtrade.net> (new maintainer)
Notes
Notes: svn path=/head/; revision=55404
Diffstat (limited to 'net/spread4/pkg-install')
-rw-r--r--net/spread4/pkg-install102
1 files changed, 102 insertions, 0 deletions
diff --git a/net/spread4/pkg-install b/net/spread4/pkg-install
new file mode 100644
index 000000000000..52ce661bb46e
--- /dev/null
+++ b/net/spread4/pkg-install
@@ -0,0 +1,102 @@
+#!/bin/sh
+
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+USER=spread
+USER_HOMEDIR=/nonexistent
+GROUP=spread
+RUNDIR=/var/run/spread
+NOLOGIN=/sbin/nologin
+
+case $2 in
+PRE-INSTALL)
+ if pw group show "${GROUP}" 2>/dev/null; then
+ echo "You already have a group \"${GROUP}\", so I will use it."
+ else
+ if pw groupadd ${GROUP}; then
+ echo "Added group \"${GROUP}\"."
+ else
+ echo "Adding group \"${GROUP}\" failed..."
+ exit 1
+ fi
+ fi
+
+ if pw user show "${USER}" 2>/dev/null; then
+ echo "You already have a user \"${USER}\", so I will use it."
+ if pw usermod ${USER} -d ${USER_HOMEDIR}
+ then
+ echo "Changed home directory of \"${USER}\" to \"${USER_HOMEDIR}\"."
+ else
+ echo "Changing home directory of \"${USER}\" to \"${USER_HOMEDIR}\" failed."
+ exit 1
+ fi
+ else
+ if pw useradd ${USER} -g ${GROUP} -h - \
+ -d ${USER_HOMEDIR} -s ${NOLOGIN} -c "Spread User"
+ then
+ echo "Added user \"${USER}\"."
+ else
+ echo "Adding user \"${USER}\" failed..."
+ exit 1
+ fi
+ fi
+ ;;
+POST-INSTALL)
+ if [ ! -d ${RUNDIR} ]; then
+ install -d -o ${USER} -g ${GROUP} -m 0750 ${RUNDIR}
+ fi
+ ;;
+*)
+ echo 'unexpect argument to pkg-install'
+ ;;
+esac
+#!/bin/sh
+
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+USER=spread
+USER_HOMEDIR=/nonexistent
+GROUP=spread
+RUNDIR=/var/run/spread
+NOLOGIN=/sbin/nologin
+
+case $2 in
+PRE-INSTALL)
+ if pw group show "${GROUP}" 2>/dev/null; then
+ echo "You already have a group \"${GROUP}\", so I will use it."
+ else
+ if pw groupadd ${GROUP}; then
+ echo "Added group \"${GROUP}\"."
+ else
+ echo "Adding group \"${GROUP}\" failed..."
+ exit 1
+ fi
+ fi
+
+ if pw user show "${USER}" 2>/dev/null; then
+ echo "You already have a user \"${USER}\", so I will use it."
+ if pw usermod ${USER} -d ${USER_HOMEDIR}
+ then
+ echo "Changed home directory of \"${USER}\" to \"${USER_HOMEDIR}\"."
+ else
+ echo "Changing home directory of \"${USER}\" to \"${USER_HOMEDIR}\" failed."
+ exit 1
+ fi
+ else
+ if pw useradd ${USER} -g ${GROUP} -h - \
+ -d ${USER_HOMEDIR} -s ${NOLOGIN} -c "Spread User"
+ then
+ echo "Added user \"${USER}\"."
+ else
+ echo "Adding user \"${USER}\" failed..."
+ exit 1
+ fi
+ fi
+ ;;
+POST-INSTALL)
+ if [ ! -d ${RUNDIR} ]; then
+ install -d -o ${USER} -g ${GROUP} -m 0750 ${RUNDIR}
+ fi
+ ;;
+*)
+ echo 'unexpect argument to pkg-install'
+ ;;
+esac