aboutsummaryrefslogtreecommitdiff
path: root/net/spread
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2014-06-01 19:20:33 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2014-06-01 19:20:33 +0000
commit4cb69a9d661f575c320e1456428c306dd3aa6cb6 (patch)
treea21216122187c008ddcb257dfb5824e917df5588 /net/spread
parent1670410b86b77f52da88a46ad129e70bf7931e76 (diff)
downloadports-4cb69a9d661f575c320e1456428c306dd3aa6cb6.tar.gz
ports-4cb69a9d661f575c320e1456428c306dd3aa6cb6.zip
net/spread: fix staging
- fix staging - simplify config samples handling - bump PORTREVISION Submitted by: swills (private email) Approved by: portmgr (blanket)
Notes
Notes: svn path=/head/; revision=356164
Diffstat (limited to 'net/spread')
-rw-r--r--net/spread/Makefile3
-rw-r--r--net/spread/pkg-plist9
2 files changed, 5 insertions, 7 deletions
diff --git a/net/spread/Makefile b/net/spread/Makefile
index 39e50c972795..59d2dab755f8 100644
--- a/net/spread/Makefile
+++ b/net/spread/Makefile
@@ -3,7 +3,7 @@
PORTNAME= spread
PORTVERSION= 3.17.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net perl5
MASTER_SITES= http://bsdforge.com/projects/source/apache2/
DISTNAME= ${PORTNAME}-src-${PORTVERSION}
@@ -73,5 +73,6 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/Readme.txt ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/license.txt ${STAGEDIR}${DOCSDIR}/LICENSE
${INSTALL} -m 750 -d ${STAGEDIR}${RUNDIR}
+ ${SED} -i '' 's|^${STAGEDIR}||' ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Spread/.packlist
.include <bsd.port.post.mk>
diff --git a/net/spread/pkg-plist b/net/spread/pkg-plist
index 5ed3fa2d27a5..9128859b542a 100644
--- a/net/spread/pkg-plist
+++ b/net/spread/pkg-plist
@@ -2,12 +2,8 @@ bin/spflooder
bin/spmonitor
bin/sptuser
bin/spuser
-@unexec if cmp -s %D/etc/spread.access_ip.sample %D/etc/spread.access_ip; then rm -f %D/etc/spread.access_ip; fi
-etc/spread.access_ip.sample
-@exec if [ ! -f %D/etc/spread.access_ip ] ; then cp -p %D/%F %B/spread.access_ip; fi
-@unexec if cmp -s %D/etc/spread.conf.sample %D/etc/spread.conf; then rm -f %D/etc/spread.conf; fi
-etc/spread.conf.sample
-@exec if [ ! -f %D/etc/spread.conf ] ; then cp -p %D/%F %B/spread.conf; fi
+@sample etc/spread.access_ip.sample
+@sample etc/spread.conf.sample
include/sp.h
include/sp_events.h
include/sp_func.h
@@ -36,6 +32,7 @@ man/man3/SP_poll.3.gz
man/man3/SP_receive.3.gz
man/man3/SP_scat_multicast.3.gz
man/man3/SP_scat_receive.3.gz
+%%PERL5_MAN3%%/Spread.3.gz
%%SITE_PERL%%/%%PERL_ARCH%%/Spread.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Spread/.packlist
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Spread/Spread.bs