aboutsummaryrefslogtreecommitdiff
path: root/net/ssldump
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2009-03-11 19:52:28 +0000
committerErwin Lansing <erwin@FreeBSD.org>2009-03-11 19:52:28 +0000
commitbbaff4a278ef49d3035d802f3f9364d2a0130653 (patch)
tree6c5fe0e3d41356f017999c6849d81e48376a0c1a /net/ssldump
parent377e3790b7bc21ae8af2579f374b9196f9f6b72d (diff)
downloadports-bbaff4a278ef49d3035d802f3f9364d2a0130653.tar.gz
ports-bbaff4a278ef49d3035d802f3f9364d2a0130653.zip
Fix a segfault when receiving duplicate packets.
Submitted by: Gregg Stefancik
Notes
Notes: svn path=/head/; revision=229906
Diffstat (limited to 'net/ssldump')
-rw-r--r--net/ssldump/Makefile2
-rw-r--r--net/ssldump/files/patch-base_tcppack.c11
2 files changed, 2 insertions, 11 deletions
diff --git a/net/ssldump/Makefile b/net/ssldump/Makefile
index eccf8334e290..154a359d4cfa 100644
--- a/net/ssldump/Makefile
+++ b/net/ssldump/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ssldump
PORTVERSION= 0.9b3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net security
MASTER_SITES= http://www.rtfm.com/ssldump/
diff --git a/net/ssldump/files/patch-base_tcppack.c b/net/ssldump/files/patch-base_tcppack.c
index a196ea951379..7b9f98ab002a 100644
--- a/net/ssldump/files/patch-base_tcppack.c
+++ b/net/ssldump/files/patch-base_tcppack.c
@@ -1,5 +1,5 @@
--- base/tcppack.c.orig 2002-09-09 21:02:58.000000000 +0000
-+++ base/tcppack.c 2009-03-11 09:09:07.000000000 +0000
++++ base/tcppack.c 2009-03-11 19:40:48.000000000 +0000
@@ -222,7 +222,6 @@
int r,_status;
tcp_seq seq,right_edge;
@@ -62,12 +62,3 @@
_seg.p=p;
_seg.s_seq=seq;
-@@ -422,6 +425,8 @@
-
- l=_seq - (s)->s_seq; /* number of bytes to trim
- from the left of s */
-+ if(l < 1) return(0);
-+
- off=(s)->p->tcp->th_off*4;
- if(l>((s)->p->len-off)) ERETURN(R_BAD_DATA);
-