aboutsummaryrefslogtreecommitdiff
path: root/net/stone
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-06-08 12:16:52 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-06-08 12:16:52 +0000
commitbe9289b42c7af5c13483aa3155ba1ecc8fa9d0b0 (patch)
treee24c1723b103563d32ca33f6c16ab999e14eb15f /net/stone
parent1f6e6e79fe38d624c774d012ebda861fc69a76bc (diff)
downloadports-be9289b42c7af5c13483aa3155ba1ecc8fa9d0b0.tar.gz
ports-be9289b42c7af5c13483aa3155ba1ecc8fa9d0b0.zip
Update to 2.2.
PR: ports/53042 Submitted by: Yoshihiko Sarumaru <mistral@imasy.or.jp>
Notes
Notes: svn path=/head/; revision=82523
Diffstat (limited to 'net/stone')
-rw-r--r--net/stone/Makefile32
-rw-r--r--net/stone/distinfo2
-rw-r--r--net/stone/files/base.patch13
-rw-r--r--net/stone/files/patch-aa11
-rw-r--r--net/stone/files/patch-ab10
-rw-r--r--net/stone/files/ports.patch13
6 files changed, 24 insertions, 57 deletions
diff --git a/net/stone/Makefile b/net/stone/Makefile
index 8373b0be6108..d8c42ff7f231 100644
--- a/net/stone/Makefile
+++ b/net/stone/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= stone
-PORTVERSION= 2.1d
+PORTVERSION= 2.2
CATEGORIES= net
MASTER_SITES= http://www.gcd.org/sengoku/stone/
@@ -16,18 +16,31 @@ COMMENT= Stone is a TCP/IP packet repeater in the application layer
MAN1= ${PORTNAME}.1
MANLANG= "" ja
-.include <bsd.port.pre.mk>
+USE_REINPLACE= yes
-pre-patch:
-.if exists(/usr/bin/openssl)
+.if exists(${PREFIX}/lib/libssl.so)
ALL_TARGET= bsd-ssl
-EXTRA_PATCHES= ${FILESDIR}/base.patch
-.elif exists(${PREFIX}/bin/openssl)
+MAKE_ARGS= -e SSL_FLAGS="-DUSE_SSL -I${PREFIX}/include" SSL_LIBS="-L${PREFIX}/lib -lssl -lcrypto"
+.elif exists(/usr/lib/libssl.so)
ALL_TARGET= bsd-ssl
-EXTRA_PATCHES= ${FILESDIR}/ports.patch
+MAKE_ARGS= -e SSL_FLAGS="-DUSE_SSL" SSL_LIBS="-lssl -lcrypto"
.else
ALL_TARGET= bsd-pop
- @${ECHO} "You can build stone with SSL support by installing OpenSSL."
+MAKE_ARGS= -e POP_LIBS="-lmd"
+NEED_GLOBAL_H= yes
+.endif
+
+pre-everything::
+.if ${ALL_TARGET} != bsd-ssl
+ @${ECHO_CMD} "You can build stone with SSL support by installing OpenSSL."
+.endif
+
+pre-patch:
+ ${REINPLACE_CMD} -e "s/-D_THREAD_SAFE/${PTHREAD_CFLAGS}/g;s/-pthread/${PTHREAD_LIBS}/g" ${WRKSRC}/Makefile
+
+pre-build:
+.if defined(NEED_GLOBAL_H)
+ ${TOUCH} ${WRKSRC}/global.h
.endif
do-install:
@@ -35,4 +48,5 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/stone.1 ${PREFIX}/man/man1/stone.1
${INSTALL_MAN} ${WRKSRC}/stone.1.ja ${PREFIX}/man/ja/man1/stone.1
-.include <bsd.port.post.mk>
+#.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/stone/distinfo b/net/stone/distinfo
index 18d4e70790a7..4d50027393f3 100644
--- a/net/stone/distinfo
+++ b/net/stone/distinfo
@@ -1 +1 @@
-MD5 (stone-2.1d.tar.gz) = cc1bb4518fde5a5b843933c239248e97
+MD5 (stone-2.2.tar.gz) = 70ae17e2d9a5d9310177468475554c23
diff --git a/net/stone/files/base.patch b/net/stone/files/base.patch
deleted file mode 100644
index 62e30a371d03..000000000000
--- a/net/stone/files/base.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.orig Thu Apr 26 15:25:03 2001
-+++ Makefile Thu Apr 26 15:23:26 2001
-@@ -15,8 +15,8 @@
- # -DOS2 OS/2 with EMX
- # -DWINDOWS Windows95/98/NT
-
--SSL_FLAGS= -DUSE_SSL -I/usr/local/ssl/include
--SSL_LIBS= -L/usr/local/ssl/lib -lssl -lcrypto
-+SSL_FLAGS= -DUSE_SSL
-+SSL_LIBS= -lssl -lcrypto
-
- POP_FLAGS= -DUSE_POP
- POP_LIBS= -lmd
diff --git a/net/stone/files/patch-aa b/net/stone/files/patch-aa
deleted file mode 100644
index 7baec92625ee..000000000000
--- a/net/stone/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig Thu Apr 26 15:28:17 2001
-+++ Makefile Thu Apr 26 15:28:05 2001
-@@ -19,7 +19,7 @@
- SSL_LIBS= -L/usr/local/ssl/lib -lssl -lcrypto
-
- POP_FLAGS= -DUSE_POP
--POP_LIBS= md5c.o
-+POP_LIBS= -lmd
-
- all:
- @echo "run make with one of the following arguments"
diff --git a/net/stone/files/patch-ab b/net/stone/files/patch-ab
deleted file mode 100644
index 9b0db0146cb2..000000000000
--- a/net/stone/files/patch-ab
+++ /dev/null
@@ -1,10 +0,0 @@
---- stone.c.orig Thu Jun 14 22:00:00 2001
-+++ stone.c Tue Jun 19 15:36:19 2001
-@@ -249,7 +249,6 @@
- char *cipher_list = NULL;
- #else
- #ifdef USE_POP
--#include "global.h"
- #include "md5.h"
- #endif
- #endif
diff --git a/net/stone/files/ports.patch b/net/stone/files/ports.patch
deleted file mode 100644
index d4cb49435d6f..000000000000
--- a/net/stone/files/ports.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.orig Thu Apr 26 15:25:03 2001
-+++ Makefile Thu Apr 26 15:27:36 2001
-@@ -15,8 +15,8 @@
- # -DOS2 OS/2 with EMX
- # -DWINDOWS Windows95/98/NT
-
--SSL_FLAGS= -DUSE_SSL -I/usr/local/ssl/include
--SSL_LIBS= -L/usr/local/ssl/lib -lssl -lcrypto
-+SSL_FLAGS= -DUSE_SSL -I$(PREFIX)/include
-+SSL_LIBS= -L$(PREFIX)/lib -lssl -lcrypto
-
- POP_FLAGS= -DUSE_POP
- POP_LIBS= -lmd