aboutsummaryrefslogtreecommitdiff
path: root/net/tcludp
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2008-04-17 14:27:45 +0000
committerWesley Shields <wxs@FreeBSD.org>2008-04-17 14:27:45 +0000
commit8358bc6ac072fc3d9347751e15e319aede2b6020 (patch)
tree703dc673c40ac817f5f55d433c1513d15a9b7cb5 /net/tcludp
parent4bcb0f29b8b4c5c0e020856ba39fe70884e34950 (diff)
downloadports-8358bc6ac072fc3d9347751e15e319aede2b6020.tar.gz
ports-8358bc6ac072fc3d9347751e15e319aede2b6020.zip
This package provides support for using UDP through Tcl. The package
provides a new channel type and attempts to permit the use of packet oriented UDP over stream oriented Tcl channels. PR: ports/122315 Submitted by: Frank Fenor <frank@fenor.de> Approved by: garga (mentor)
Notes
Notes: svn path=/head/; revision=211447
Diffstat (limited to 'net/tcludp')
-rw-r--r--net/tcludp/Makefile28
-rw-r--r--net/tcludp/distinfo3
-rw-r--r--net/tcludp/pkg-descr7
3 files changed, 38 insertions, 0 deletions
diff --git a/net/tcludp/Makefile b/net/tcludp/Makefile
new file mode 100644
index 000000000000..a70cccf35931
--- /dev/null
+++ b/net/tcludp/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: tcludp
+# Date created: 24 March 2008
+# Whom: Frank Fenor <frank@fenor.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcludp
+PORTVERSION= 1.0.8
+CATEGORIES= net tcl
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=tcludp
+
+MAINTAINER= frank@fenor.de
+COMMENT= UDP extension for TCL
+
+USE_TCL= 80+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-tcl=${TCL_LIBDIR}
+USE_LDCONFIG= ${PREFIX}/lib/udp${PORTVERSION}
+MANN= udp.n
+MANCOMPRESSED= no
+
+PLIST_FILES= lib/udp1.0.8/libudp1.0.8.so \
+ lib/udp1.0.8/pkgIndex.tcl
+PLIST_DIRS= lib/udp1.0.8
+
+.include <bsd.port.mk>
diff --git a/net/tcludp/distinfo b/net/tcludp/distinfo
new file mode 100644
index 000000000000..00f64c9200c1
--- /dev/null
+++ b/net/tcludp/distinfo
@@ -0,0 +1,3 @@
+MD5 (tcludp-1.0.8.tar.gz) = 60dd3a553fc8e579ecfd6622252da2d2
+SHA256 (tcludp-1.0.8.tar.gz) = 8ba802aebb6ca2bd88e05c312827ff5f16b77ee94d9355f77e287011ade2c819
+SIZE (tcludp-1.0.8.tar.gz) = 129410
diff --git a/net/tcludp/pkg-descr b/net/tcludp/pkg-descr
new file mode 100644
index 000000000000..8fd163ac985c
--- /dev/null
+++ b/net/tcludp/pkg-descr
@@ -0,0 +1,7 @@
+From the website:
+
+ This package provides support for using UDP through Tcl. The package
+ provides a new channel type and attempts to permit the use of packet
+ oriented UDP over stream oriented Tcl channels.
+
+WWW: http://tcludp.sourceforge.net/