aboutsummaryrefslogtreecommitdiff
path: root/net/tcpillust
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-27 11:57:21 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-27 11:57:21 +0000
commita89a56ffb31e001c35862e63ae85910b88d8eddb (patch)
tree5a1f1eeffe71f656c5b22d6915ec488984e9e625 /net/tcpillust
parent72c3e8ffe008c2badda8f614ff285f6f7f43fae6 (diff)
downloadports-a89a56ffb31e001c35862e63ae85910b88d8eddb.tar.gz
ports-a89a56ffb31e001c35862e63ae85910b88d8eddb.zip
- Use TCL/TK 8.4
- Use PLIST_FILES PR: 110421 Submitted by: Martin Tournoij <carpetsmoker@xs4all.nl> Approved by: maintainer
Notes
Notes: svn path=/head/; revision=188535
Diffstat (limited to 'net/tcpillust')
-rw-r--r--net/tcpillust/Makefile54
-rw-r--r--net/tcpillust/pkg-descr2
-rw-r--r--net/tcpillust/pkg-plist12
3 files changed, 34 insertions, 34 deletions
diff --git a/net/tcpillust/Makefile b/net/tcpillust/Makefile
index 50258329b5c4..ac52388b5eb1 100644
--- a/net/tcpillust/Makefile
+++ b/net/tcpillust/Makefile
@@ -7,36 +7,46 @@
PORTNAME= tcpillust
PORTVERSION= 1.0a
-CATEGORIES= net tk82 tcl82
+PORTREVISION= 1
+CATEGORIES= net tk84 tcl84
MASTER_SITES= ftp://ftp.csl.sony.co.jp/CSL/nishida/
MAINTAINER= nishida@csl.sony.co.jp
COMMENT= A graphical TCP connection analysis tool
-LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82 \
- tcl82.1:${PORTSDIR}/lang/tcl82
-
-USE_IMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS=
+USE_TCL= yes
+USE_TK= yes
+USE_TK_BUILD= yes
+USE_XLIB= yes
USE_MOTIF= yes
-MAN1= tcpillust.1
-
-DOCS= README
-
-SAMPLES= tcpclient.log tcpserver.log
-
-post-install:
+MAN1= tcpillust.1
+PORTDOCS= README FAQ tcpclient.log tcpserver.log
+PLIST_DIRS= share/tcpillust
+PLIST_FILES= bin/tcpillust \
+ share/tcpillust/tcpillust.tcl \
+ share/tcpillust/back.xbm \
+ share/tcpillust/forward.xbm \
+ share/tcpillust/zoomin.xbm \
+ share/tcpillust/zoomout.xbm
+
+do-build:
+.for file in binread.c button.c draw.c parser.c tcpillust.c
+ ${CC} ${CFLAGS} -I${LOCALBASE}/include/ -I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR} \
+ -I${X11BASE}/include -DILTDIR=\"${DATADIR}\" -c ${WRKSRC}/${file} -o ${WRKSRC}/${file:S/.c/.o/}
+.endfor
+ ${CC} ${CFLAGS} -L${TCL_LIBDIR} -L${TK_LIBDIR} -L${LOCALBASE}/lib \
+ -lm -lpcap -ltcl${TCL_VER:S/.//} -ltk${TK_VER:S/.//} ${WRKSRC}/*.o -o ${WRKSRC}/tcpillust
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tcpillust ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/tcpillust.tcl ${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/*.xbm ${DATADIR}/
+ ${INSTALL_MAN} ${WRKSRC}/tcpillust.man ${PREFIX}/man/man1/tcpillust.1
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/tcpillust
- for i in $(DOCS); do \
- ${INSTALL_DATA} ${WRKSRC}/$$i ${PREFIX}/share/doc/tcpillust; \
- done
- ${MKDIR} ${PREFIX}/share/doc/tcpillust/sample
- for i in $(SAMPLES); do \
- ${INSTALL_DATA} ${WRKSRC}/sample/$$i ${PREFIX}/share/doc/tcpillust/sample; \
- done
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/FAQ ${WRKSRC}/sample/* ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/net/tcpillust/pkg-descr b/net/tcpillust/pkg-descr
index e478c9109a34..39c8aef51a35 100644
--- a/net/tcpillust/pkg-descr
+++ b/net/tcpillust/pkg-descr
@@ -2,3 +2,5 @@ Tcpillust - A graphical TCP connection analysis tool
Tcpillust takes tcpdump file(s) specified on the command line and draw
pictures like figures in the ``TCP/IP Illustrated'' series.
+
+WWW: http://www.csl.sony.co.jp/person/nishida/tcpillust.html
diff --git a/net/tcpillust/pkg-plist b/net/tcpillust/pkg-plist
deleted file mode 100644
index d5b26a098c9e..000000000000
--- a/net/tcpillust/pkg-plist
+++ /dev/null
@@ -1,12 +0,0 @@
-bin/tcpillust
-lib/X11/tcpillust/tcpillust.tcl
-lib/X11/tcpillust/back.xbm
-lib/X11/tcpillust/forward.xbm
-lib/X11/tcpillust/zoomin.xbm
-lib/X11/tcpillust/zoomout.xbm
-share/doc/tcpillust/sample/tcpclient.log
-share/doc/tcpillust/sample/tcpserver.log
-share/doc/tcpillust/README
-@dirrm lib/X11/tcpillust
-@dirrm share/doc/tcpillust/sample
-@dirrm share/doc/tcpillust