aboutsummaryrefslogtreecommitdiff
path: root/net/tcpproxy
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-04-03 11:22:54 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-04-03 11:22:54 +0000
commit107234ba1bf7be2b5efbdcaf2d00ffd7546da13f (patch)
tree0e1d9e6715c1003eb0ec478648abb1c9b0fb941a /net/tcpproxy
parentd9f65402ab3313dc3e4437ae847598a900d3362a (diff)
downloadports-107234ba1bf7be2b5efbdcaf2d00ffd7546da13f.tar.gz
ports-107234ba1bf7be2b5efbdcaf2d00ffd7546da13f.zip
tcpproxy is a simple tcp connection proxy which combines the features of
rinetd and 6tunnel. tcpproxy supports IPv4 and IPv6 and also supports connections from IPv6 to IPv4 endpoints and vice versa. WWW: http://www.spreadspace.org/tcpproxy/ PR: ports/156108 Submitted by: Alexander Hausner <alex@hugo.bmg.gv.at>
Notes
Notes: svn path=/head/; revision=272145
Diffstat (limited to 'net/tcpproxy')
-rw-r--r--net/tcpproxy/Makefile38
-rw-r--r--net/tcpproxy/distinfo2
-rw-r--r--net/tcpproxy/files/tcpproxy.in31
-rw-r--r--net/tcpproxy/pkg-descr5
4 files changed, 76 insertions, 0 deletions
diff --git a/net/tcpproxy/Makefile b/net/tcpproxy/Makefile
new file mode 100644
index 000000000000..21573bd6e60b
--- /dev/null
+++ b/net/tcpproxy/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: tcpproxy
+# Date created: 2011-03-30
+# Whom: Alexander Hausner <alex@hugo.bmg.gv.at>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcpproxy
+PORTVERSION= 1.0
+CATEGORIES= net
+MASTER_SITES= http://www.spreadspace.org/tcpproxy/releases/ \
+ http://alex.bmg.gv.at/programs/
+
+MAINTAINER= alex@hugo.bmg.gv.at
+COMMENT= A simple tcp connection proxy for ipv4 and ipv6
+
+BUILD_DEPENDS= ragel:${PORTSDIR}/devel/ragel
+
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+
+USERS= _tcpproxy
+GROUPS= _tcpproxy
+
+MAN8= tcpproxy.8
+
+USE_RC_SUBR= tcpproxy
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+
+PLIST_FILES= bin/tcpproxy etc/tcpproxy_sample.conf
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tcpproxy ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/contrib/example.conf ${PREFIX}/etc/tcpproxy_sample.conf
+ ${INSTALL_MAN} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/doc/${MAN8} ${PREFIX}/man/man8
+
+.include <bsd.port.mk>
diff --git a/net/tcpproxy/distinfo b/net/tcpproxy/distinfo
new file mode 100644
index 000000000000..4c0df45f1510
--- /dev/null
+++ b/net/tcpproxy/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tcpproxy-1.0.tar.gz) = 8d21bca2849b87b05566549859666a8bde0e21ed1a304390a71a12929e937f70
+SIZE (tcpproxy-1.0.tar.gz) = 35946
diff --git a/net/tcpproxy/files/tcpproxy.in b/net/tcpproxy/files/tcpproxy.in
new file mode 100644
index 000000000000..567cda127ffd
--- /dev/null
+++ b/net/tcpproxy/files/tcpproxy.in
@@ -0,0 +1,31 @@
+#!/bin/sh
+#
+# PROVIDE: tcpproxy
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# tcpproxy_enable (bool): Set to NO by default.
+# Set it to YES to enable tcpproxy.
+# tcpproxy_config (path): Set to %%PREFIX%%/etc/tcpproxy.conf
+# by default.
+#
+
+. /etc/rc.subr
+
+name="tcpproxy"
+rcvar=${name}_enable
+
+command=%%PREFIX%%/bin/${name}
+pidfile=/var/run/${name}.pid
+
+load_rc_config $name
+
+: ${tcpproxy_enable="NO"}
+: ${tcpproxy_config="%%PREFIX%%/etc/tcpproxy.conf"}
+
+command_args="-P $pidfile -c $tcpproxy_config -u _tcpproxy -g _tcpproxy"
+
+run_rc_command "$1"
diff --git a/net/tcpproxy/pkg-descr b/net/tcpproxy/pkg-descr
new file mode 100644
index 000000000000..438ea8116b70
--- /dev/null
+++ b/net/tcpproxy/pkg-descr
@@ -0,0 +1,5 @@
+tcpproxy is a simple tcp connection proxy which combines the features of
+rinetd and 6tunnel. tcpproxy supports IPv4 and IPv6 and also supports
+connections from IPv6 to IPv4 endpoints and vice versa.
+
+WWW: http://www.spreadspace.org/tcpproxy/