aboutsummaryrefslogtreecommitdiff
path: root/net/tcpsg/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-20 13:44:51 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-20 13:44:51 +0000
commit698ced054ef40e7e6f875e17c1ccc6487e913649 (patch)
tree86a6a09063083d1cab096e3ea41d8b0865eef7e2 /net/tcpsg/Makefile
parent5d824297fb72f7719603bab88c950c2263150191 (diff)
downloadports-698ced054ef40e7e6f875e17c1ccc6487e913649.tar.gz
ports-698ced054ef40e7e6f875e17c1ccc6487e913649.zip
add tcpsg 0.02
A simple TCP port forwarder PR: 44751 Submitted by: Michael L. Hostbaek <mich@freebsdcluster.org>
Notes
Notes: svn path=/head/; revision=70596
Diffstat (limited to 'net/tcpsg/Makefile')
-rw-r--r--net/tcpsg/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/net/tcpsg/Makefile b/net/tcpsg/Makefile
new file mode 100644
index 000000000000..08a1fa71fd35
--- /dev/null
+++ b/net/tcpsg/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: tcpsg
+# Date created: Tue Oct 30, 2002
+# Whom: Michael L. Hostbaek (mich@freebsdcluster.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcpsg
+PORTVERSION= 0.0.2
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= mich@freebsdcluster.org
+
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/tcpsg.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/tcpsg.conf ${PREFIX}/etc/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
+ ${INSTALL_DATA} ${WRKSRC}/tcpsg.ctl ${DOCSDIR}/tcpsg.ctl
+.endif
+
+.include <bsd.port.mk>