aboutsummaryrefslogtreecommitdiff
path: root/net/tightvnc/files
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-10-29 11:08:48 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-10-29 11:08:48 +0000
commit047cf46f0a774df2afa48a9c5c85e27d3b4a0a6e (patch)
tree4adfd4a9150b17234e3c14a6521ebd326581356b /net/tightvnc/files
parent86090e839546e9a40933fa3f48f60b5ad9509b03 (diff)
downloadports-047cf46f0a774df2afa48a9c5c85e27d3b4a0a6e.tar.gz
ports-047cf46f0a774df2afa48a9c5c85e27d3b4a0a6e.zip
- RUN_DEPEND on xauth and xorg-fonts [1]
- OPTIONify Java-based vnc viewer and depend on Java in this case (first use of bsd.port.options.mk YAY!) - add patches for core-dumps on amd64 [2] - bump PORTREVISION for above PR: ports/113854 [1], ports/108414 [2] Submitted by: Michael Scheidell [1], Tsurutani Naoki [2]
Notes
Notes: svn path=/head/; revision=202281
Diffstat (limited to 'net/tightvnc/files')
-rw-r--r--net/tightvnc/files/patch-Xvnc::config::cf::FreeBSD.cf20
-rw-r--r--net/tightvnc/files/patch-Xvnc::config::cf::Imake.cf15
-rw-r--r--net/tightvnc/files/patch-Xvnc::programs::Xserver::os::access.c11
3 files changed, 40 insertions, 6 deletions
diff --git a/net/tightvnc/files/patch-Xvnc::config::cf::FreeBSD.cf b/net/tightvnc/files/patch-Xvnc::config::cf::FreeBSD.cf
index 1aa0f83d7d98..83b3d1f55259 100644
--- a/net/tightvnc/files/patch-Xvnc::config::cf::FreeBSD.cf
+++ b/net/tightvnc/files/patch-Xvnc::config::cf::FreeBSD.cf
@@ -1,18 +1,26 @@
---- Xvnc/config/cf/FreeBSD.cf.orig Sun Jun 11 08:00:51 2000
-+++ Xvnc/config/cf/FreeBSD.cf Tue Sep 26 19:07:31 2006
-@@ -253,9 +253,9 @@
+--- Xvnc/config/cf/FreeBSD.cf.orig 2000-06-11 21:00:51.000000000 +0900
++++ Xvnc/config/cf/FreeBSD.cf 2007-09-04 17:11:16.000000000 +0900
+@@ -253,11 +253,17 @@
#endif
#ifdef i386Architecture
-# define OptimizedCDebugFlags DefaultGcc2i386Opt
-+# define OptimizedCDebugFlags %%CFLAGS%%
++# define OptimizedCDebugFlags -O -pipe
#else
-# define OptimizedCDebugFlags -O2
-+# define OptimizedCDebugFlags %%CFLAGS%%
++# define OptimizedCDebugFlags -O -pipe
#endif
++#ifdef x86_64Architecture
++# define OptimizedCDebugFlags -O -pipe
++# define ServerOSDefines XFree86ServerOSDefines -DDDXTIME
++# define ServerExtraDefines GccGasOption XFree86ServerDefines -D_XSERVER64
++#endif /* x86_64Architecture */
++
#ifndef PreIncDir
-@@ -359,6 +359,5 @@
+ # define PreIncDir /usr/include
+ #endif
+@@ -359,6 +366,5 @@
#include <bsdLib.rules>
diff --git a/net/tightvnc/files/patch-Xvnc::config::cf::Imake.cf b/net/tightvnc/files/patch-Xvnc::config::cf::Imake.cf
new file mode 100644
index 000000000000..1aaf39698bcb
--- /dev/null
+++ b/net/tightvnc/files/patch-Xvnc::config::cf::Imake.cf
@@ -0,0 +1,15 @@
+--- Xvnc/config/cf/Imake.cf.orig 2006-12-23 21:07:55.000000000 +0900
++++ Xvnc/config/cf/Imake.cf 2007-09-05 07:45:05.000000000 +0900
+@@ -206,6 +206,12 @@
+ # define i386Architecture
+ # undef i386
+ # endif
++# ifdef __x86_64__
++# ifndef x86_64Architecture
++# define x86_64Architecture
++# endif
++# undef __x86_64__
++# endif
+ # ifdef __alpha__
+ # define AlphaBsdArchitecture
+ # define AlphaArchitecture
diff --git a/net/tightvnc/files/patch-Xvnc::programs::Xserver::os::access.c b/net/tightvnc/files/patch-Xvnc::programs::Xserver::os::access.c
new file mode 100644
index 000000000000..820b5ccac84f
--- /dev/null
+++ b/net/tightvnc/files/patch-Xvnc::programs::Xserver::os::access.c
@@ -0,0 +1,11 @@
+--- Xvnc/programs/Xserver/os/access.c.orig 2000-06-11 21:00:51.000000000 +0900
++++ Xvnc/programs/Xserver/os/access.c 2007-09-05 12:07:30.000000000 +0900
+@@ -634,7 +634,7 @@
+ #endif
+ ifc.ifc_len = sizeof (buf);
+ ifc.ifc_buf = buf;
+- if (ifioctl (fd, (int) SIOCGIFCONF, (pointer) &ifc) < 0)
++ if (ifioctl (fd, SIOCGIFCONF, (pointer) &ifc) < 0)
+ Error ("Getting interface configuration (4)");
+
+ #ifdef ISC