aboutsummaryrefslogtreecommitdiff
path: root/net/turses/Makefile
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2015-07-07 11:48:02 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2015-07-07 11:48:02 +0000
commita6d1f0198c85632f66f3094817f7e8a571e13bb3 (patch)
treefb5d19d178db35daf0419596d5283f91c6a27bfe /net/turses/Makefile
parent99cf0fb8d9e7d2d1146798f8e7e0c94441052bd8 (diff)
downloadports-a6d1f0198c85632f66f3094817f7e8a571e13bb3.tar.gz
ports-a6d1f0198c85632f66f3094817f7e8a571e13bb3.zip
net/turses: Update to 0.3.0, Unbreak.
- Update to 0.3.0, unbreaking due to 2.3+ versions of net/py-tweepy in the ports tree - Patch setup.py to relax py-tweepy version requirement - oauth2 is no longer required - Set USES=python to 2.7, since this doesnt need the meta-port - Patch in setuptools test command support (setup.py) - Update TEST_DEPENDS and TESTS option description - Sort USE_PYTHON values - Add NO_ARCH Second half of: PR: 200621 Reported by: Patrick P. <freebsdbug patpro net> MFH: 2015Q3
Notes
Notes: svn path=/head/; revision=391502
Diffstat (limited to 'net/turses/Makefile')
-rw-r--r--net/turses/Makefile25
1 files changed, 13 insertions, 12 deletions
diff --git a/net/turses/Makefile b/net/turses/Makefile
index 7a60b0395213..26a160d4d798 100644
--- a/net/turses/Makefile
+++ b/net/turses/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= turses
-PORTVERSION= 0.2.22
+PORTVERSION= 0.3.0
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
@@ -11,22 +11,23 @@ COMMENT= Python Twitter client for the console
LICENSE= GPLv3
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}oauth2>0:${PORTSDIR}/net/py-oauth2 \
- ${PYTHON_PKGNAMEPREFIX}urwid>0:${PORTSDIR}/devel/py-urwid \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}urwid>0:${PORTSDIR}/devel/py-urwid \
${PYTHON_PKGNAMEPREFIX}tweepy>=2.2:${PORTSDIR}/net/py-tweepy
-
-TEST_DEPENDS:= ${RUN_DEPENDS} \
- ${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose \
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:${PORTSDIR}/devel/py-pytest \
${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock
-OPTIONS_DEFINE= TESTS
-TESTS_DESC= Install tools for unit tests
-TESTS_BUILD_DEPENDS= ${TEST_DEPENDS}
+OPTIONS_DEFINE= TESTS
+
+TESTS_DESC= Install test suite requirements
+TESTS_BUILD_DEPENDS= ${RUN_DEPENDS} \
+ ${TEST_DEPENDS}
+
+USES= python:2.7
+USE_PYTHON= autoplist distutils
-USES= python:2
-USE_PYTHON= distutils autoplist
+NO_ARCH= yes
regression-test: build
- @cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>