aboutsummaryrefslogtreecommitdiff
path: root/net/ulxmlrpcpp
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-10 04:04:08 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-10 04:04:08 +0000
commitd282b1fa3467558fa12ca01f6f9c8f2f6ca25f92 (patch)
treee5cdc50bf7baf672a25f023f25f408271a9356d8 /net/ulxmlrpcpp
parent039bd9d66cdf70db91fd6e36aeca8e03ed190422 (diff)
downloadports-d282b1fa3467558fa12ca01f6f9c8f2f6ca25f92.tar.gz
ports-d282b1fa3467558fa12ca01f6f9c8f2f6ca25f92.zip
add ulxmlrpcpp 1.2.4 beta 5
A ultra lightweight xml-rpc library written in C++
Notes
Notes: svn path=/head/; revision=95518
Diffstat (limited to 'net/ulxmlrpcpp')
-rw-r--r--net/ulxmlrpcpp/Makefile33
-rw-r--r--net/ulxmlrpcpp/distinfo1
-rw-r--r--net/ulxmlrpcpp/files/patch-config:ltmain.sh15
-rw-r--r--net/ulxmlrpcpp/files/patch-ulxmlrpcpp:ulxmlrpcpp.cpp11
-rw-r--r--net/ulxmlrpcpp/pkg-descr11
-rw-r--r--net/ulxmlrpcpp/pkg-plist33
6 files changed, 104 insertions, 0 deletions
diff --git a/net/ulxmlrpcpp/Makefile b/net/ulxmlrpcpp/Makefile
new file mode 100644
index 000000000000..d8ebb8244cad
--- /dev/null
+++ b/net/ulxmlrpcpp/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: ulxmlrpcpp
+# Date created: Dec 10, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= ulxmlrpcpp
+PORTVERSION= 1.2.4.b5
+CATEGORIES= net devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E:S/b/beta/}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A ultra lightweight xml-rpc library written in C++
+
+LIB_DEPENDS= expat.4:${PORTSDIR}/textproc/expat2 \
+ iconv.3:${PORTSDIR}/converters/libiconv
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --disable-doxygen --disable-latex-docs
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|-pthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/net/ulxmlrpcpp/distinfo b/net/ulxmlrpcpp/distinfo
new file mode 100644
index 000000000000..d6de46b2b173
--- /dev/null
+++ b/net/ulxmlrpcpp/distinfo
@@ -0,0 +1 @@
+MD5 (ulxmlrpcpp-1.2.4-beta5.tar.bz2) = 4a62f89e9d9820d5732fa6a437daa002
diff --git a/net/ulxmlrpcpp/files/patch-config:ltmain.sh b/net/ulxmlrpcpp/files/patch-config:ltmain.sh
new file mode 100644
index 000000000000..599d50bf4bfe
--- /dev/null
+++ b/net/ulxmlrpcpp/files/patch-config:ltmain.sh
@@ -0,0 +1,15 @@
+--- config/ltmain.sh.orig Sun Dec 8 16:53:29 2002
++++ config/ltmain.sh Wed Dec 10 11:43:13 2003
+@@ -4232,10 +4232,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/net/ulxmlrpcpp/files/patch-ulxmlrpcpp:ulxmlrpcpp.cpp b/net/ulxmlrpcpp/files/patch-ulxmlrpcpp:ulxmlrpcpp.cpp
new file mode 100644
index 000000000000..21108c0bd170
--- /dev/null
+++ b/net/ulxmlrpcpp/files/patch-ulxmlrpcpp:ulxmlrpcpp.cpp
@@ -0,0 +1,11 @@
+--- ulxmlrpcpp/ulxmlrpcpp.cpp.orig Thu Nov 27 02:44:22 2003
++++ ulxmlrpcpp/ulxmlrpcpp.cpp Wed Dec 10 11:34:49 2003
+@@ -742,7 +742,7 @@
+ {
+ size_t outbytes = sizeof(buffer);
+ char *outbuf = buffer;
+- char *inbuf = const_cast<char*>(val.data())+in_offset;
++ const char *inbuf = const_cast<char*>(val.data())+in_offset;
+ size_t inbytes = val.length()-in_offset;
+ #if defined(__SUN__) || defined(__CYGWIN__)
+ if ((int)iconv(con, &(const char*)inbuf, &inbytes, &outbuf, &outbytes) < 0)
diff --git a/net/ulxmlrpcpp/pkg-descr b/net/ulxmlrpcpp/pkg-descr
new file mode 100644
index 000000000000..08990fd69eaf
--- /dev/null
+++ b/net/ulxmlrpcpp/pkg-descr
@@ -0,0 +1,11 @@
+XML-RPC is an extensible mechanism allowing a computer to offer a limited set
+of services which can be accessed from anywhere in the net.
+
+XML-RPC uses common and easy to learn internet standards like XML. and HTTP.
+
+ulxmlrpcpp is a library to perform such calls in an object oriented approach
+implemented in C++. It is intended to have simple interfaces and to be easy to
+learn. But it shall still be fully compliant to the standards and safe in it's
+use.
+
+WWW: http://ulxmlrpcpp.sourceforge.net/
diff --git a/net/ulxmlrpcpp/pkg-plist b/net/ulxmlrpcpp/pkg-plist
new file mode 100644
index 000000000000..ef762c01a731
--- /dev/null
+++ b/net/ulxmlrpcpp/pkg-plist
@@ -0,0 +1,33 @@
+bin/introspect
+bin/meerkat_client
+bin/sum_server
+bin/ulxrstubber
+include/ulxmlrpcpp.h
+include/ulxmlrpcpp/ulxr_config.h
+include/ulxr_call.h
+include/ulxr_callparse.h
+include/ulxr_connection.h
+include/ulxr_dispatcher.h
+include/ulxr_except.h
+include/ulxr_expatwrap.h
+include/ulxr_http_client.h
+include/ulxr_http_connection.h
+include/ulxr_http_server.h
+include/ulxr_mtrpc_server.h
+include/ulxr_mutex.h
+include/ulxr_requester.h
+include/ulxr_response.h
+include/ulxr_responseparse.h
+include/ulxr_signature.h
+include/ulxr_tcpip_connection.h
+include/ulxr_value.h
+include/ulxr_valueparse.h
+include/ulxr_xmlparse.h
+@dirrm include/ulxmlrpcpp
+lib/libulxmlrpcpp.a
+lib/libulxmlrpcpp.so
+lib/libulxmlrpcpp.so.4
+%%DATADIR%%/httpd/index.html
+%%DATADIR%%/httpd/logo-ulxmlrpcpp.png
+@dirrm %%DATADIR%%/httpd
+@dirrm %%DATADIR%%