aboutsummaryrefslogtreecommitdiff
path: root/net/unfs3/Makefile
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2021-09-06 22:48:54 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2021-09-29 09:34:29 +0000
commita6dfa43d8f1d397cc649e85de336555c6b4967bb (patch)
tree4132855227949544c7eec93c9dbf7afccaa6b2ac /net/unfs3/Makefile
parent5e019790c2b185e80a55c3f8779cdfbb644ca66b (diff)
downloadports-a6dfa43d8f1d397cc649e85de336555c6b4967bb.tar.gz
ports-a6dfa43d8f1d397cc649e85de336555c6b4967bb.zip
net/unfs3: Fix build with -fno-common (FreeBSD 13 or later)
* Update MASTER_SITES and WWW as project has moved to GitHub * Pass maintainership to submitter * Clean up and reformat Makefile PR: 258326 Approved by: meta (mentor) MFH: 2021Q3 Differential Revision: https://reviews.freebsd.org/D32220 (cherry picked from commit 4c35fa18e7434733681f5cc05337bf571241dbae)
Diffstat (limited to 'net/unfs3/Makefile')
-rw-r--r--net/unfs3/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/net/unfs3/Makefile b/net/unfs3/Makefile
index 401b383ab369..fd87caae14bb 100644
--- a/net/unfs3/Makefile
+++ b/net/unfs3/Makefile
@@ -1,30 +1,33 @@
# Created by: Clement Laforet <clement@FreeBSD.org>
PORTNAME= unfs3
-PORTVERSION= 0.9.22
-PORTREVISION= 1
+DISTVERSION= 0.9.22
+PORTREVISION= 2
CATEGORIES= net
-MASTER_SITES= SF
+MASTER_SITES= https://github.com/unfs3/unfs3/releases/download/unfs3-${DISTVERSION}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= fuz@fuz.su
COMMENT= User-space implementation of the NFSv3 server specification
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_FreeBSD_13= ld: error: duplicate symbol: export_path
-BROKEN_FreeBSD_14= ld: error: duplicate symbol: export_path
-
USES= autoreconf
GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
CONFIGURE_ENV= YACC=byacc
-PLIST_FILES= sbin/unfsd man/man7/tags.7.gz man/man8/unfsd.8.gz
-
MAKE_JOBS_UNSAFE= yes
+INSTALL_TARGET= install-strip
+
+PLIST_FILES= man/man7/tags.7.gz \
+ man/man8/unfsd.8.gz \
+ sbin/unfsd
OPTIONS_DEFINE= CLUSTER_EXT
+CLUSTER_EXT_DESC= include clustering extensions
CLUSTER_EXT_CONFIGURE_ON= --enable-cluster
+post-extract:
+ @${RM} ${WRKSRC}/Config/lex.yy.c
+
.include <bsd.port.mk>