aboutsummaryrefslogtreecommitdiff
path: root/net/unison/Makefile
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2008-09-24 14:01:32 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2008-09-24 14:01:32 +0000
commit726d3032f2200b1bd554448c1f4d8505355067a6 (patch)
tree12734f9d06693fbfaa11cb9bdde144ea985869d5 /net/unison/Makefile
parentdb881fc98790019d48041a65b0dbd078820707ea (diff)
downloadports-726d3032f2200b1bd554448c1f4d8505355067a6.tar.gz
ports-726d3032f2200b1bd554448c1f4d8505355067a6.zip
Those changes should deal with an upcomming new slave port net/unison-nox11
(PR/127117): . add CONFLICTS; . add pkg-message.nox11 file; . show apropriate message file; . switch from '=' to '?=' for PORTREVISION (seems that slave port should be rarely bumpted having only 5 dependencies); . bump PORTREVISION. PR: 127118 Submitted by: bsam (me) Approved by: maintainer (timeout for 19 days)
Notes
Notes: svn path=/head/; revision=220675
Diffstat (limited to 'net/unison/Makefile')
-rw-r--r--net/unison/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/net/unison/Makefile b/net/unison/Makefile
index ff60f0dbe62f..605c346b2936 100644
--- a/net/unison/Makefile
+++ b/net/unison/Makefile
@@ -7,7 +7,7 @@
PORTNAME= unison
PORTVERSION= 2.27.57
-PORTREVISION= 1
+PORTREVISION?= 2
CATEGORIES= net
MASTER_SITES= http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${DISTNAME}/
DISTFILES= ${EXTRACT_ONLY} ${EXTRA_DOCS}
@@ -20,7 +20,7 @@ COMMENT= A user-level file synchronization tool
PLIST_SUB= PORTVERSION=${PORTVERSION}
USE_GMAKE= yes
MAKE_ARGS= CFLAGS=""
-CONFLICTS= unison-devel-[0-9]*
+CONFLICTS= unison-devel-[0-9]* unison-nox11-[0-9]*
.include <bsd.port.pre.mk>
@@ -60,14 +60,16 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/unison ${PREFIX}/bin
post-install:
-.if defined(WITH_GTK2)
- @${INSTALL_PROGRAM} ${WRKSRC}/unison-text ${PREFIX}/bin
-.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
cd ${DISTDIR}/${DIST_SUBDIR} && ${INSTALL_DATA} ${EXTRA_DOCS} ${DOCSDIR}
.endif
+.if defined(WITH_GTK2)
+ @${INSTALL_PROGRAM} ${WRKSRC}/unison-text ${PREFIX}/bin
@${CAT} ${PKGMESSAGE}
+.else
+ @${CAT} ${PKGMESSAGE}.nox11
+.endif
.include <bsd.port.post.mk>