aboutsummaryrefslogtreecommitdiff
path: root/net/vinagre
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-12-16 19:33:16 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-12-16 19:33:16 +0000
commit4ca865398dab25f1577888b473bd8c602d8b4bdb (patch)
tree334be3f7bee728248303e2382e7fea6a192e3a9c /net/vinagre
parent261846f1578612bae246393aabe505a5eb5e823a (diff)
downloadports-4ca865398dab25f1577888b473bd8c602d8b4bdb.tar.gz
ports-4ca865398dab25f1577888b473bd8c602d8b4bdb.zip
Add vinagre, a VNC viewer for the GNOME Desktop.
Notes
Notes: svn path=/head/; revision=203866
Diffstat (limited to 'net/vinagre')
-rw-r--r--net/vinagre/Makefile40
-rw-r--r--net/vinagre/distinfo3
-rw-r--r--net/vinagre/files/patch-Makefile.in11
-rw-r--r--net/vinagre/pkg-descr10
-rw-r--r--net/vinagre/pkg-plist57
5 files changed, 121 insertions, 0 deletions
diff --git a/net/vinagre/Makefile b/net/vinagre/Makefile
new file mode 100644
index 000000000000..bba8efa59712
--- /dev/null
+++ b/net/vinagre/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: vinagre
+# Date created: 16 December 2007
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vinagre
+PORTVERSION= 0.4
+CATEGORIES= net gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= VNC client for the GNOME Desktop
+
+LIB_DEPENDS= gtk-vnc-1.0.0:${PORTSDIR}/net/gtk-vnc \
+ avahi-core.5:${PORTSDIR}/net/avahi
+
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_XLIB= yes
+USE_GNOME= gnomeprefix intlhack gnomehack libglade2 gconf2
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+CONFIGURE_ARGS= --enable-avahi
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-install:
+ @-update-desktop-database
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in AUTHORS COPYING ChangeLog INSTALL MAINTAINERS NEWS README
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/vinagre/distinfo b/net/vinagre/distinfo
new file mode 100644
index 000000000000..5d984c827b08
--- /dev/null
+++ b/net/vinagre/distinfo
@@ -0,0 +1,3 @@
+MD5 (vinagre-0.4.tar.bz2) = 97dee0faa1b78e2497b9d231053b2f6d
+SHA256 (vinagre-0.4.tar.bz2) = 547663727bc6e14688a6d9f9cf0fd5a724ed678a6279ab457afb40a61e89a2e3
+SIZE (vinagre-0.4.tar.bz2) = 363407
diff --git a/net/vinagre/files/patch-Makefile.in b/net/vinagre/files/patch-Makefile.in
new file mode 100644
index 000000000000..d54e01e7f3d1
--- /dev/null
+++ b/net/vinagre/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2007-12-16 14:18:35.000000000 -0500
++++ Makefile.in 2007-12-16 14:19:09.000000000 -0500
+@@ -667,7 +667,7 @@ info: info-recursive
+
+ info-am:
+
+-install-data-am: install-vinagredocDATA
++install-data-am:
+
+ install-dvi: install-dvi-recursive
+
diff --git a/net/vinagre/pkg-descr b/net/vinagre/pkg-descr
new file mode 100644
index 000000000000..9aa3ad1fa1fc
--- /dev/null
+++ b/net/vinagre/pkg-descr
@@ -0,0 +1,10 @@
+Vinagre is a VNC Client for the GNOME Desktop. Its features include:
+
+* You can connect to several machines at the same time, we like tabs
+* You can keep track of your most used connections, we like favorites
+* You can keep track of your recently used connections, we like GtkRecent
+* You can browse your network for VNC servers, we like avahi
+* You don't need to supply the password on every connection, we like GNOME
+ Keyring
+
+WWW: http://www.gnome.org/projects/vinagre/
diff --git a/net/vinagre/pkg-plist b/net/vinagre/pkg-plist
new file mode 100644
index 000000000000..f19455abb7f0
--- /dev/null
+++ b/net/vinagre/pkg-plist
@@ -0,0 +1,57 @@
+bin/vinagre
+share/applications/vinagre-file.desktop
+share/applications/vinagre.desktop
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/MAINTAINERS
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+share/icons/hicolor/16x16/apps/vinagre.png
+share/icons/hicolor/16x16/mimetypes/application-x-remote-connection.png
+share/icons/hicolor/16x16/mimetypes/application-x-vnc.png
+share/icons/hicolor/22x22/apps/vinagre.png
+share/icons/hicolor/22x22/mimetypes/application-x-remote-connection.png
+share/icons/hicolor/22x22/mimetypes/application-x-vnc.png
+share/icons/hicolor/24x24/apps/vinagre.png
+share/icons/hicolor/24x24/mimetypes/application-x-remote-connection.png
+share/icons/hicolor/24x24/mimetypes/application-x-vnc.png
+share/icons/hicolor/32x32/apps/vinagre.png
+share/icons/hicolor/32x32/mimetypes/application-x-remote-connection.png
+share/icons/hicolor/32x32/mimetypes/application-x-vnc.png
+share/icons/hicolor/48x48/apps/vinagre.png
+share/icons/hicolor/48x48/mimetypes/application-x-remote-connection.png
+share/icons/hicolor/48x48/mimetypes/application-x-vnc.png
+share/icons/hicolor/scalable/apps/vinagre.svg
+share/icons/hicolor/scalable/mimetypes/application-x-remote-connection.svg
+share/icons/hicolor/scalable/mimetypes/application-x-vnc.svg
+share/locale/ar/LC_MESSAGES/vinagre.mo
+share/locale/bg/LC_MESSAGES/vinagre.mo
+share/locale/ca/LC_MESSAGES/vinagre.mo
+share/locale/de/LC_MESSAGES/vinagre.mo
+share/locale/es/LC_MESSAGES/vinagre.mo
+share/locale/fi/LC_MESSAGES/vinagre.mo
+share/locale/fr/LC_MESSAGES/vinagre.mo
+share/locale/gl/LC_MESSAGES/vinagre.mo
+share/locale/hu/LC_MESSAGES/vinagre.mo
+share/locale/it/LC_MESSAGES/vinagre.mo
+share/locale/nb/LC_MESSAGES/vinagre.mo
+share/locale/nl/LC_MESSAGES/vinagre.mo
+share/locale/oc/LC_MESSAGES/vinagre.mo
+share/locale/pt_BR/LC_MESSAGES/vinagre.mo
+share/locale/si/LC_MESSAGES/vinagre.mo
+share/locale/sl/LC_MESSAGES/vinagre.mo
+share/locale/sv/LC_MESSAGES/vinagre.mo
+share/mime/packages/vinagre-mime.xml
+share/vinagre/vinagre-ui.xml
+share/vinagre/vinagre.glade
+@dirrm share/vinagre
+@dirrmtry share/locale/si/LC_MESSAGES
+@dirrmtry share/locale/si
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@dirrmtry share/applications