aboutsummaryrefslogtreecommitdiff
path: root/net/vino/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-03-21 06:20:04 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-03-21 06:20:04 +0000
commit6f6eb857be0547186bc826c251ae4c1b82460323 (patch)
tree89568e8295d097f5ed8dae3e041d957ad2d2b4f0 /net/vino/Makefile
parenta8d51e90a142a5a56ff0c29be8786bae78e2606a (diff)
downloadports-6f6eb857be0547186bc826c251ae4c1b82460323.tar.gz
ports-6f6eb857be0547186bc826c251ae4c1b82460323.zip
Make IPv6 support optional (defaulting to off). The reason for off by default
is that if vino can establish an IPv6 socket, then it will not create an IPv4 socket. None of the FreeBSD VNC clients seem to support IPv6 (prove me wrong) so defaulting v6 to off is probably a good thing.
Notes
Notes: svn path=/head/; revision=187832
Diffstat (limited to 'net/vino/Makefile')
-rw-r--r--net/vino/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/net/vino/Makefile b/net/vino/Makefile
index c56835ec6b58..909de0871ad1 100644
--- a/net/vino/Makefile
+++ b/net/vino/Makefile
@@ -8,6 +8,7 @@
PORTNAME= vino
PORTVERSION= 2.18.0
+PORTREVISION= 1
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -31,4 +32,14 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
GCONF_SCHEMAS= vino-server.schemas
-.include <bsd.port.mk>
+OPTIONS= IPV6 "Enable IPv6 support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6
+.else
+CONFIGURE_ARGS+= --disable-ipv6
+.endif
+
+.include <bsd.port.post.mk>