aboutsummaryrefslogtreecommitdiff
path: root/net/vnc
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2008-04-09 20:43:02 +0000
committerAnders Nordby <anders@FreeBSD.org>2008-04-09 20:43:02 +0000
commit611563bbc9d6b8bf0b34d5ec3b2c27fe60b6fa32 (patch)
tree28329ed3c48287f2263a0185ef2cd0eed41628ee /net/vnc
parentb4937943626417f469b7578fe6d5fa67eab4a58f (diff)
downloadports-611563bbc9d6b8bf0b34d5ec3b2c27fe60b6fa32.tar.gz
ports-611563bbc9d6b8bf0b34d5ec3b2c27fe60b6fa32.zip
Make port build with GCC 4.
Lose USE_GCC dependency. Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=210953
Diffstat (limited to 'net/vnc')
-rw-r--r--net/vnc/Makefile1
-rw-r--r--net/vnc/files/extra-patch-xc-config-util-printver.c10
-rw-r--r--net/vnc/files/patch-xc-config-util-printver.c10
3 files changed, 20 insertions, 1 deletions
diff --git a/net/vnc/Makefile b/net/vnc/Makefile
index ba4f5fa69ce5..3affcb5a1015 100644
--- a/net/vnc/Makefile
+++ b/net/vnc/Makefile
@@ -20,7 +20,6 @@ COMMENT= Display X and Win32 desktops on remote X/Win32/Java displays
GNU_CONFIGURE= yes
# The vnc supplied zlib seg. faults if compiled with -O
CONFIGURE_ARGS= --with-installed-zlib
-USE_GCC= 3.4
USE_XLIB= yes
USE_XPM= yes
WANT_PERL= yes
diff --git a/net/vnc/files/extra-patch-xc-config-util-printver.c b/net/vnc/files/extra-patch-xc-config-util-printver.c
new file mode 100644
index 000000000000..1b98eec89f32
--- /dev/null
+++ b/net/vnc/files/extra-patch-xc-config-util-printver.c
@@ -0,0 +1,10 @@
+--- xc/config/util/printver.c.orig 2003-02-26 10:21:33.000000000 +0100
++++ xc/config/util/printver.c 2008-03-16 10:07:56.000000000 +0100
+@@ -8,6 +8,7 @@
+ /* $XFree86: xc/config/util/printver.c,v 1.2 2003/02/26 09:21:33 dawes Exp $ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "xf86Version.h"
+ #include "xf86Date.h"
+
diff --git a/net/vnc/files/patch-xc-config-util-printver.c b/net/vnc/files/patch-xc-config-util-printver.c
new file mode 100644
index 000000000000..1b98eec89f32
--- /dev/null
+++ b/net/vnc/files/patch-xc-config-util-printver.c
@@ -0,0 +1,10 @@
+--- xc/config/util/printver.c.orig 2003-02-26 10:21:33.000000000 +0100
++++ xc/config/util/printver.c 2008-03-16 10:07:56.000000000 +0100
+@@ -8,6 +8,7 @@
+ /* $XFree86: xc/config/util/printver.c,v 1.2 2003/02/26 09:21:33 dawes Exp $ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "xf86Version.h"
+ #include "xf86Date.h"
+