aboutsummaryrefslogtreecommitdiff
path: root/net/vortex/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-03-20 10:53:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-03-20 10:53:08 +0000
commit654ccc6aac9c7681ed39c2cd2d10d8360ec7a9bc (patch)
treec30aa05ffe4be67ca3bb38317073b7e6603daa7c /net/vortex/Makefile
parent3dc362ac88ab73d6f0b3635628a59d9597e6da4e (diff)
downloadports-654ccc6aac9c7681ed39c2cd2d10d8360ec7a9bc.tar.gz
ports-654ccc6aac9c7681ed39c2cd2d10d8360ec7a9bc.zip
Install net/libnet headers and libraries back in the location where other
ports expect it. The files were put in a different location to avoid a conflict with net/libnet10 but this port has been removed a while ago now. PR: 208122 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=411432
Diffstat (limited to 'net/vortex/Makefile')
-rw-r--r--net/vortex/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/net/vortex/Makefile b/net/vortex/Makefile
index d6eff948cf7e..2865fd9d33a3 100644
--- a/net/vortex/Makefile
+++ b/net/vortex/Makefile
@@ -12,17 +12,15 @@ COMMENT= Network surveillance engine
LICENSE= GPLv2
-BUILD_DEPENDS= ${LOCALBASE}/lib/libnids.a:${PORTSDIR}/net/libnids-libnet11
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnids.a:${PORTSDIR}/net/libnids
LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
-LIBNET_CONFIG= ${LOCALBASE}/bin/libnet11-config
-
WRKSRC= ${WRKDIR}/${PORTNAME}-2.9.0
USE_GNOME= glib20
do-build:
cd ${WRKSRC} && ${CC} -c vortex.c -I${LOCALBASE}/include
- cd ${WRKSRC} && ${CC} -v -o vortex vortex.o -L${LOCALBASE}/lib ${LOCALBASE}/lib/libnids.a `${LIBNET_CONFIG} --libs` -lglib-2.0 -lgthread-2.0 -lpcap -pthread
+ cd ${WRKSRC} && ${CC} -v -o vortex vortex.o -L${LOCALBASE}/lib ${LOCALBASE}/lib/libnids.a -lnet -lglib-2.0 -lgthread-2.0 -lpcap -pthread
cd ${WRKSRC} && ${CC} -o xpipes xpipes.c -pthread
do-install: