aboutsummaryrefslogtreecommitdiff
path: root/net/whois
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-22 09:34:14 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-22 09:34:14 +0000
commitbd1a679bbbbcc47c2f75f7412a7d1981445e32b8 (patch)
tree6c1cd63f2080928d336bc30e0e6c755518b7d122 /net/whois
parent9b0f5e977692ddac5162cf2d34934735dad26423 (diff)
downloadports-bd1a679bbbbcc47c2f75f7412a7d1981445e32b8.tar.gz
ports-bd1a679bbbbcc47c2f75f7412a7d1981445e32b8.zip
- Update to 4.7.27
Notes
Notes: svn path=/head/; revision=218983
Diffstat (limited to 'net/whois')
-rw-r--r--net/whois/Makefile13
-rw-r--r--net/whois/distinfo6
-rw-r--r--net/whois/files/patch-aa54
-rw-r--r--net/whois/pkg-plist3
4 files changed, 44 insertions, 32 deletions
diff --git a/net/whois/Makefile b/net/whois/Makefile
index 22b7f3279e33..7d859e336858 100644
--- a/net/whois/Makefile
+++ b/net/whois/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= whois
-PORTVERSION= 4.7.26
+PORTVERSION= 4.7.27
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= miwi@FreeBSD.org
-COMMENT= Marco d'Itri whois client
+COMMENT= Marco d\'Itri whois client
USE_GMAKE= yes
USE_ICONV= yes
@@ -20,10 +20,13 @@ USE_PERL5_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+LDFLAGS+= -L/usr/local/lib
+CFLAGS+= -I/usr/local/include
+
MAKE_ENV= LDFLAGS="${LDFLAGS}"
MAKE_ARGS= OPTS=""
-MAN1= mwhois.1
+MAN1= whois.1 mkpasswd.1
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
@@ -35,9 +38,7 @@ NO_PO= yes
.endif
post-patch:
- @${REINPLACE_CMD} -e "s|prefix\=/usr/local|prefix\=${PREFIX}|g ; \
- s|/usr/local|${LOCALBASE}|g ; \
- s|share/man/|man/|g ; \
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e "s|/usr/share|${PREFIX}/share|g" ${WRKSRC}/po/Makefile
@if [ -n "${NO_PO}" ]; \
diff --git a/net/whois/distinfo b/net/whois/distinfo
index 27376f743217..7cfe86c48bb7 100644
--- a/net/whois/distinfo
+++ b/net/whois/distinfo
@@ -1,3 +1,3 @@
-MD5 (whois_4.7.26.tar.gz) = f069304ae912ff4fdec59f33de405076
-SHA256 (whois_4.7.26.tar.gz) = 515ff7eae37f64f4786ce0fe5d9f7c91790cc64fe73bfda6764d5d4c627d1541
-SIZE (whois_4.7.26.tar.gz) = 67809
+MD5 (whois_4.7.27.tar.gz) = 0937f34c714e3954894d056b4346d69b
+SHA256 (whois_4.7.27.tar.gz) = 1a1a3e29302f1941d8c5819311ffd958f2b7cf27eeea03a8d839d3e07d42f3b9
+SIZE (whois_4.7.27.tar.gz) = 67996
diff --git a/net/whois/files/patch-aa b/net/whois/files/patch-aa
index 6d50e19a25e5..3541c67cc4ad 100644
--- a/net/whois/files/patch-aa
+++ b/net/whois/files/patch-aa
@@ -1,35 +1,45 @@
---- Makefile.orig 2008-04-05 15:46:24.000000000 +0200
-+++ Makefile 2008-06-21 14:57:26.965023476 +0200
-@@ -6,8 +6,8 @@
- #whois_LDADD += -lnsl -lsocket
-
- # FreeBSD
--#LDFLAGS=-L/usr/local/lib -lgnugetopt -lintl
--#CFLAGS=-I/usr/local/include
-+LDFLAGS+=-L/usr/local/lib
-+CFLAGS+=-I/usr/local/include
-
- # OS/2 EMX
- #LDFLAGS=-lsocket -Zexe -Dstrncasecmp=strnicmp
-@@ -57,16 +57,15 @@
+--- Makefile.orig 2008-05-06 11:41:16.000000000 +0200
++++ Makefile 2008-08-21 13:25:03.000000000 +0200
+@@ -1,6 +1,9 @@
+ prefix = %%PREFIX%%
+
+-CFLAGS = -g -O2
++LDFLAGS+=-L%%LOCALBASE%%/lib -lintl
++CFLAGS+=-I%%LOCALBASE%%/include
++
++CFLAGS += -g -O2
+
+ PERL = perl
+
+@@ -63,22 +66,22 @@
+ $(PERL) -w make_tld_serv.pl < tld_serv_list > $@
+
##############################################################################
- install: whois
+-install: install-whois install-mkpasswd install-pos
++install: install-whois install-mkpasswd
+
+ install-whois: whois
install -d $(BASEDIR)$(prefix)/bin/
- install -d $(BASEDIR)$(prefix)/share/man/man1/
- install -m 0755 whois $(BASEDIR)$(prefix)/bin/
- install -m 0644 whois.1 $(BASEDIR)$(prefix)/share/man/man1/
-- cd po && $(MAKE) $@
-+ install -d $(BASEDIR)$(prefix)/man/man1/
-+ install -m 0755 whois ${PREFIX}/bin/mwhois
-+ install -m 0644 whois.1 ${PREFIX}/man/man1/mwhois.1
++ install -d $(prefix)/man/man1/
++ install -m 0755 whois $(prefix)/bin/
++ install -m 0644 whois.1 $(prefix)/man/man1/
install-mkpasswd: mkpasswd
install -d $(BASEDIR)$(prefix)/bin/
- install -d $(BASEDIR)$(prefix)/share/man/man1/
-+ install -d $(BASEDIR)$(prefix)/man/man1/
- install -m 0755 mkpasswd $(BASEDIR)$(prefix)/bin/
+- install -m 0755 mkpasswd $(BASEDIR)$(prefix)/bin/
- install -m 0644 mkpasswd.1 $(BASEDIR)$(prefix)/share/man/man1/
-+ install -m 0644 mkpasswd.1 $(BASEDIR)$(prefix)/man/man1/
++ install -d $(BASEDIR)$(prefix)/man/man1/
++ install -m 0755 mkpasswd $(prefix)/bin/
++ install -m 0644 mkpasswd.1 $(prefix)/man/man1/
+
+-install-pos:
+- cd po && $(MAKE) $@
++#install-pos:
++# cd po && $(MAKE) $@
distclean: clean
rm -f po/whois.pot
diff --git a/net/whois/pkg-plist b/net/whois/pkg-plist
index 27eca5ce97e8..3c405506c105 100644
--- a/net/whois/pkg-plist
+++ b/net/whois/pkg-plist
@@ -1,4 +1,5 @@
-bin/mwhois
+bin/whois
+bin/mkpasswd
%%NLS%%share/locale/cs/LC_MESSAGES/whois.mo
%%NLS%%share/locale/de/LC_MESSAGES/whois.mo
%%NLS%%share/locale/el/LC_MESSAGES/whois.mo