aboutsummaryrefslogtreecommitdiff
path: root/net/x11vnc
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2016-06-30 18:57:57 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2016-06-30 18:57:57 +0000
commit897563cc15333915d65ed3066582f38ef3fb9521 (patch)
tree88d63723759c5848bfb8af43d917b985abd7c710 /net/x11vnc
parentcb4957eb3d6e46c80164332e0747761800bc7d34 (diff)
downloadports-897563cc15333915d65ed3066582f38ef3fb9521.tar.gz
ports-897563cc15333915d65ed3066582f38ef3fb9521.zip
- support build with libressl
Notes
Notes: svn path=/head/; revision=417834
Diffstat (limited to 'net/x11vnc')
-rw-r--r--net/x11vnc/Makefile2
-rw-r--r--net/x11vnc/files/patch-x11vnc_enc.h13
2 files changed, 14 insertions, 1 deletions
diff --git a/net/x11vnc/Makefile b/net/x11vnc/Makefile
index 945a92523cbc..fd37804bd5df 100644
--- a/net/x11vnc/Makefile
+++ b/net/x11vnc/Makefile
@@ -20,7 +20,7 @@ USE_XORG= x11 xcb xdamage xfixes xrandr xinerama xext xtst xau xrender \
# Sets LDFLAGS and adds to CONFIGURE_ENV, therefore we set LDFLAGS
LDFLAGS+= -L${LOCALBASE}/lib
USE_OPENSSL= yes
-USES= iconv jpeg pkgconfig
+USES= iconv pkgconfig jpeg
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/net/x11vnc/files/patch-x11vnc_enc.h b/net/x11vnc/files/patch-x11vnc_enc.h
new file mode 100644
index 000000000000..544878ba83e8
--- /dev/null
+++ b/net/x11vnc/files/patch-x11vnc_enc.h
@@ -0,0 +1,13 @@
+--- x11vnc/enc.h.orig 2011-08-10 22:31:32 UTC
++++ x11vnc/enc.h
+@@ -454,8 +454,10 @@ extern void enc_do(char *ciph, char *key
+ p++;
+ if (strstr(p, "md5+") == p) {
+ Digest = EVP_md5(); p += strlen("md5+");
++#ifndef OPENSSL_NO_SHA0
+ } else if (strstr(p, "sha+") == p) {
+ Digest = EVP_sha(); p += strlen("sha+");
++#endif
+ } else if (strstr(p, "sha1+") == p) {
+ Digest = EVP_sha1(); p += strlen("sha1+");
+ } else if (strstr(p, "ripe+") == p) {