aboutsummaryrefslogtreecommitdiff
path: root/net/xisp
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-02-03 13:12:07 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-02-03 13:12:07 +0000
commit1c8dffbd8be9c16a76565dbab824c42c8a80e2c9 (patch)
treefb9c866155c579cfd4dd7a3417464801c1d25c9d /net/xisp
parent324cdfefce2a3d44e13df2427a9e13e86a12262c (diff)
downloadports-1c8dffbd8be9c16a76565dbab824c42c8a80e2c9.tar.gz
ports-1c8dffbd8be9c16a76565dbab824c42c8a80e2c9.zip
Maintainer update:
Upgrade to version 2.7 Fix build with xforms PR: ports/42650 Submitted by: tm@onepost.net (Takeshi Morishima)
Notes
Notes: svn path=/head/; revision=74571
Diffstat (limited to 'net/xisp')
-rw-r--r--net/xisp/Makefile21
-rw-r--r--net/xisp/distinfo4
-rw-r--r--net/xisp/files/patch-Makefile13
-rw-r--r--net/xisp/files/patch-Makefile.nodes86
-rw-r--r--net/xisp/files/patch-warn.c8
-rw-r--r--net/xisp/files/patch-xisp.c11
-rw-r--r--net/xisp/files/patch-xispterm.c11
-rw-r--r--net/xisp/pkg-plist2
8 files changed, 25 insertions, 131 deletions
diff --git a/net/xisp/Makefile b/net/xisp/Makefile
index 26fcfed5f805..3813bc1dee6f 100644
--- a/net/xisp/Makefile
+++ b/net/xisp/Makefile
@@ -1,29 +1,24 @@
# New ports collection makefile for: xisp
# Date created: June 24, 1999
-# Whom: morishim@cig.mot.com
+# Whom: tm@onepost.net
#
# $FreeBSD$
#
PORTNAME= xisp
-PORTVERSION= 2.6
+PORTVERSION= 2.7
CATEGORIES= net
-MASTER_SITES= http://www.ml-search.com/xisp/distfiles/
-DISTFILES= xisp-2.6-noufc.tar.gz \
- xisp-2.6-freebsd-patch.tar.gz
+MASTER_SITES= http://xisp.hellug.gr/release/
-MAINTAINER= morishim@cig.mot.com
+PATCH_SITES= http://www.ml-search.com/xisp/distfiles/
+PATCHFILES= xisp-2.7-freebsd-patch-20030126.gz
+
+MAINTAINER= tm@onepost.net
LIB_DEPENDS= forms.1:${PORTSDIR}/x11-toolkits/xforms
USE_XPM= yes
-WRKSRC= ${WRKDIR}/xisp-2.6
+
MAN1= xisp.1
-HAS_CONFIGURE= yes
-.if defined(WITH_DES)
-CONFIGURE_ENV= USE_DESLIB="yes"
-.else
-CONFIGURE_ENV= USE_DESLIB="no"
-.endif
.include <bsd.port.mk>
diff --git a/net/xisp/distinfo b/net/xisp/distinfo
index 8807875e0c6c..1cc39fe30203 100644
--- a/net/xisp/distinfo
+++ b/net/xisp/distinfo
@@ -1,2 +1,2 @@
-MD5 (xisp-2.6-noufc.tar.gz) = bb06960ab5eacb669c9bc788c18b8103
-MD5 (xisp-2.6-freebsd-patch.tar.gz) = b65096edb77490372472ffbd71fcf197
+MD5 (xisp-2.7.tar.gz) = cf942ff8f19f05a5e67120723a45e1f9
+MD5 (xisp-2.7-freebsd-patch-20030126.gz) = c514bd6c309a5a382e1c556b7a09c185
diff --git a/net/xisp/files/patch-Makefile b/net/xisp/files/patch-Makefile
new file mode 100644
index 000000000000..b1861b2b67fb
--- /dev/null
+++ b/net/xisp/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig Mon Feb 3 04:59:04 2003
++++ Makefile Mon Feb 3 04:59:28 2003
+@@ -13,8 +13,8 @@
+ #=====================================================================
+ #
+ CC = gcc
+-PREFIX = /usr/local
+-X11PREFIX = /usr/X11R6
++PREFIX = ${LOCALBASE}
++X11PREFIX = ${X11BASE}
+ INCX11 = $(X11PREFIX)/include
+ LIBX11 = $(X11PREFIX)/lib
+ INCFORMS = $(X11PREFIX)/include/X11
diff --git a/net/xisp/files/patch-Makefile.nodes b/net/xisp/files/patch-Makefile.nodes
deleted file mode 100644
index d69670accece..000000000000
--- a/net/xisp/files/patch-Makefile.nodes
+++ /dev/null
@@ -1,86 +0,0 @@
---- Makefile.nodes.orig Sun Aug 8 06:43:28 1999
-+++ Makefile.nodes Wed Nov 27 04:43:56 2002
-@@ -201,10 +201,9 @@
- GROUP = dialer
- CHAT_PATH = /usr/bin
- PPPD_PATH = /usr/sbin
--GCCFLAGS = -Wall -O
- EXTRALIBS =
- LINKX11 = -Wl,-R$(LIBX11)
--LINKFORMS = -L$(LIBFORMS) -lxforms
-+LINKFORMS = -L$(LIBFORMS) -lforms
- INSTALL = /usr/bin/install
- MODEM_DEV = cuaa0
- MODEM_DEVS = cuaa0 cuaa1 cuaa2 cuaa3
-@@ -238,7 +237,7 @@
- #
- # gcc option flags
- #------------------
--GCCOPTS = $(GCCFLAGS) $(DEFINES) $(EXTRADEFS)
-+GCCOPTS = $(CFLAGS) $(DEFINES) $(EXTRADEFS)
- #
- #=====================================================================
- # You shouldn't need to edit anything below this line |
-@@ -247,49 +246,49 @@
- all: xisp xispdial xisprccv xispterm xispid
-
- xisp: xisp.o nodes.o warn.o network.o rcio.o logs.o
-- gcc $(LINKX11) -o xisp xisp.o nodes.o warn.o network.o rcio.o logs.o $(EXTRALIBS) -L$(LIBX11) $(LINKFORMS) -lXpm -lX11 -lm -lmd
-+ $(CC) $(LINKX11) -o xisp xisp.o nodes.o warn.o network.o rcio.o logs.o $(EXTRALIBS) -L$(LIBX11) $(LINKFORMS) -lXpm -lX11 -lm -lmd
-
- xisp.o: xisp.h xisp.c xisp.xpm version.h common.h pcode.h network.h rcio.h logs.h help.c peHelp.c excl.xpm
-- gcc $(GCCOPTS) -I$(INCX11) -I$(INCFORMS) -c xisp.c
-+ $(CC) $(GCCOPTS) -I$(INCX11) -I$(INCFORMS) -c xisp.c
-
- xisp.xpm:
- cp $(XPMIMAGE) xisp.xpm
-
- pcode.o: pcode.h pcode.c
-- gcc $(GCCOPTS) -c pcode.c
-+ $(CC) $(GCCOPTS) -c pcode.c
-
- nodes.o: pcode.h
-- gcc $(GCCOPTS) -c nodes.c
-+ $(CC) $(GCCOPTS) -c nodes.c
-
- warn.o:
-- gcc $(GCCOPTS) -I$(INCX11) -I$(INCFORMS) -c warn.c
-+ $(CC) $(GCCOPTS) -I$(INCX11) -I$(INCFORMS) -c warn.c
-
- nowarn.o:
-- gcc $(GCCOPTS) -c nowarn.c
-+ $(CC) $(GCCOPTS) -c nowarn.c
-
- network.o: network.h network.c
-- gcc $(GCCOPTS) -c network.c
-+ $(CC) $(GCCOPTS) -c network.c
-
- xispdial: xispdial.c common.h version.h
-- gcc $(GCCOPTS) -o xispdial xispdial.c
-+ $(CC) $(GCCOPTS) -o xispdial xispdial.c
-
- xisprccv: xisprccv.o nodes.o nowarn.o
- gcc -o xisprccv xisprccv.o nodes.o nowarn.o $(EXTRALIBS) -lm -lmd
-
- xisprccv.o: xisprccv.c common.h version.h pcode.h logs.h
-- gcc $(GCCOPTS) -c xisprccv.c
-+ $(CC) $(GCCOPTS) -c xisprccv.c
-
- xispterm: xispterm.h xispterm.c
-- gcc $(GCCOPTS) -I$(INCX11) -I$(INCFORMS) -o xispterm xispterm.c $(EXTRALIBS) -L$(LIBX11) $(LINKFORMS) -lX11 -lm
-+ $(CC) $(GCCOPTS) -I$(INCX11) -I$(INCFORMS) -o xispterm xispterm.c $(EXTRALIBS) -L$(LIBX11) $(LINKFORMS) -lX11 -lm
-
- rcio.o: rcio.h rcio.c common.h version.h
-- gcc $(GCCOPTS) -c rcio.c
-+ $(CC) $(GCCOPTS) -c rcio.c
-
- logs.o: logs.h logs.c version.h
-- gcc $(GCCOPTS) -c logs.c
-+ $(CC) $(GCCOPTS) -c logs.c
-
- xispid: xispid.c
-- gcc $(GCCOPTS) -o xispid xispid.c
-+ $(CC) $(GCCOPTS) -o xispid xispid.c
-
- install: xisp xispdial xisprccv xispterm xispid
- if [ ! -d $(DESTDIR)$(BINX11) ]; then $(INSTALL) -d $(DESTDIR)$(BINX11); fi
diff --git a/net/xisp/files/patch-warn.c b/net/xisp/files/patch-warn.c
deleted file mode 100644
index 3eeae44484b8..000000000000
--- a/net/xisp/files/patch-warn.c
+++ /dev/null
@@ -1,8 +0,0 @@
---- warn.c.orig Wed Nov 27 04:34:55 2002
-+++ warn.c Wed Nov 27 04:35:24 2002
-@@ -1,4 +1,4 @@
--#include <forms.h>
-+#include <X11/forms.h>
-
- /*
- * No DES information
diff --git a/net/xisp/files/patch-xisp.c b/net/xisp/files/patch-xisp.c
deleted file mode 100644
index 1286fff52fc4..000000000000
--- a/net/xisp/files/patch-xisp.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- xisp.c.orig Wed Nov 27 04:36:07 2002
-+++ xisp.c Wed Nov 27 04:36:12 2002
-@@ -18,7 +18,7 @@
- For author contact information, look in the README file.
- */
-
--#include <forms.h>
-+#include <X11/forms.h>
- #include <stdio.h>
- #include <stdlib.h>
- #include <errno.h>
diff --git a/net/xisp/files/patch-xispterm.c b/net/xisp/files/patch-xispterm.c
deleted file mode 100644
index 55aba061dd06..000000000000
--- a/net/xisp/files/patch-xispterm.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- xispterm.c.orig Wed Nov 27 04:35:03 2002
-+++ xispterm.c Wed Nov 27 04:35:08 2002
-@@ -18,7 +18,7 @@
- For author contact information, look in the README file.
- */
-
--#include <forms.h>
-+#include <X11/forms.h>
- #include <stdio.h>
- #include <stdlib.h>
- #include <varargs.h>
diff --git a/net/xisp/pkg-plist b/net/xisp/pkg-plist
index 2273b5a3de45..76853edfc0c2 100644
--- a/net/xisp/pkg-plist
+++ b/net/xisp/pkg-plist
@@ -1,11 +1,13 @@
@cwd /etc/ppp
ip-down
ip-up
+
@exec mkdir -p %D/peers
peers/xisp_cuaa0
peers/xisp_cuaa1
peers/xisp_cuaa2
peers/xisp_cuaa3
+peers/xisp_umodem
peers/xisp_dialer
@cwd /usr/X11R6