aboutsummaryrefslogtreecommitdiff
path: root/net/xmlrpc-c-devel/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-31 10:00:33 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-31 10:00:33 +0000
commit267e15e9f10d1c6d85275afcebfd63960944d2b3 (patch)
tree5aab452cbbea086397f4b907c6d985e6e12eddb2 /net/xmlrpc-c-devel/Makefile
parent7433748ccc0207f4dafc7b9fc40b328225e36d61 (diff)
downloadports-267e15e9f10d1c6d85275afcebfd63960944d2b3.tar.gz
ports-267e15e9f10d1c6d85275afcebfd63960944d2b3.zip
- Update to 1.06.25
PR: 122078 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=210216
Diffstat (limited to 'net/xmlrpc-c-devel/Makefile')
-rw-r--r--net/xmlrpc-c-devel/Makefile47
1 files changed, 26 insertions, 21 deletions
diff --git a/net/xmlrpc-c-devel/Makefile b/net/xmlrpc-c-devel/Makefile
index c6a165fd23a0..31680f53c672 100644
--- a/net/xmlrpc-c-devel/Makefile
+++ b/net/xmlrpc-c-devel/Makefile
@@ -7,44 +7,49 @@
#
PORTNAME= xmlrpc-c
-PORTVERSION= 1.06.24
+PORTVERSION= 1.06.25
CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION}
+MASTER_SITES= SF
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= XML-RPC library for C and C++
-OPTIONS= CURL "Compile with curl support" on \
+OPTIONS= DEBUG "Compile with debugging information" off \
+ CURL "Compile with curl support" on \
LIBWWW "Compile with libwww support" off
-USE_AUTOTOOLS= libtool:15:env
+CONFLICTS= xmlrpc-epi-0.*
+
+USE_GNOME= gnometarget
+USE_PERL5= yes
USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15:env
GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
-USE_PERL5= yes
MAKEFILE= GNUmakefile
-MAKE_ENV+= CFLAGS_FREEBSD="${CFLAGS}" \
- CXXFLAGS_FREEBSD="${CXXFLAGS}"
-
-CONFLICTS= xmlrpc-epi-0.*
+MAKE_ARGS= LIBTOOL="${LIBTOOL}" \
+ CFLAGS_COMMON="${CFLAGS}" \
+ CXXFLAGS_COMMON="${CXXFLAGS}"
+USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
-.if defined(WITH_LIBWWW) || (!defined(WITHOUT_LIBWWW) && exists(${LOCALBASE}/lib/libwwwcore.so.1))
-LIB_DEPENDS+= wwwcore.1:${PORTSDIR}/www/libwww
-OPT_LIBWWW= yes
-.else
-CONFIGURE_ARGS+= --disable-libwww-client
+.if !defined(WITH_DEBUG)
+CFLAGS+= -DNDEBUG
.endif
-.if !defined(WITHOUT_CURL)
+.if defined(WITHOUT_CURL)
+CONFIGURE_ARGS+= --disable-curl-client
+.else
LIB_DEPENDS+= curl.4:${PORTSDIR}/ftp/curl
OPT_CURL= yes
+.endif
+
+.if defined(WITH_LIBWWW)
+LIB_DEPENDS+= wwwcore.1:${PORTSDIR}/www/libwww
+OPT_LIBWWW= yes
.else
-CONFIGURE_ARGS+= --disable-curl-client
+CONFIGURE_ARGS+= --disable-libwww-client
.endif
.if !defined(OPT_LIBWWW) && !defined(OPT_CURL)
@@ -54,7 +59,7 @@ PLIST_SUB+= CLIENT=""
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
- ${WRKSRC}/configure
+ @${GREP} -lR '\-lpthread' ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|-lpthread|${PTHREAD_LIBS}|g'
.include <bsd.port.post.mk>