aboutsummaryrefslogtreecommitdiff
path: root/net/xmlrpc-c
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2002-11-14 11:15:42 +0000
committerOliver Braun <obraun@FreeBSD.org>2002-11-14 11:15:42 +0000
commit1b75b0021ca13620989acc49cf1ce704339a9dff (patch)
treeea52cd287d1ae5a8c33df818b1f35f914efec26f /net/xmlrpc-c
parent9b20aabe3e50cb613bd75053bb29bb968ca38efb (diff)
downloadports-1b75b0021ca13620989acc49cf1ce704339a9dff.tar.gz
ports-1b75b0021ca13620989acc49cf1ce704339a9dff.zip
* correct use of '#include <string>' and 'use namespace'
(fixes build on -current) * PERL->REINPLACE PR: ports/45286 Submitted by: Volker Stolz <vs@foldr.org>
Notes
Notes: svn path=/head/; revision=70106
Diffstat (limited to 'net/xmlrpc-c')
-rw-r--r--net/xmlrpc-c/Makefile6
-rw-r--r--net/xmlrpc-c/files/patch-src-XmlRpcCpp.h12
2 files changed, 15 insertions, 3 deletions
diff --git a/net/xmlrpc-c/Makefile b/net/xmlrpc-c/Makefile
index 618b47f09036..b7edb2f00c30 100644
--- a/net/xmlrpc-c/Makefile
+++ b/net/xmlrpc-c/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= wwwcore.1:${PORTSDIR}/www/libwww
RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Frontier/Client.pm:${PORTSDIR}/net/p5-Frontier-RPC
+USE_REINPLACE= yes
USE_LIBTOOL= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
@@ -26,10 +27,9 @@ MAN1= meerkat-app-list.1 xml-rpc-api2cpp.1 xmlrpc-c-config.1 \
MAN7= xmlrpc-c.7
pre-patch:
- @${PERL} -pi -e 's,<malloc.h>,<stdlib.h>,' \
+ @${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,' \
${WRKSRC}/lib/abyss/src/data.c \
- ${WRKSRC}/tools/turbocharger/mod_gzip.c \
- ${WRKSRC}/tools/turbocharger/mod_gzip.c
+ ${WRKSRC}/tools/turbocharger/mod_gzip.c
post-install:
@${RM} -f ${PREFIX}/lib/*.la
diff --git a/net/xmlrpc-c/files/patch-src-XmlRpcCpp.h b/net/xmlrpc-c/files/patch-src-XmlRpcCpp.h
new file mode 100644
index 000000000000..21e18d881ebc
--- /dev/null
+++ b/net/xmlrpc-c/files/patch-src-XmlRpcCpp.h
@@ -0,0 +1,12 @@
+--- src/XmlRpcCpp.h.orig Thu Nov 14 09:17:52 2002
++++ src/XmlRpcCpp.h Thu Nov 14 09:18:17 2002
+@@ -45,8 +45,8 @@
+ // work with our version of g++). So this header name is technically wrong.
+ // Tell me what your compiler does; I can provide some autoconf magic to the
+ // Right Thing on most platforms.
++using namespace std;
+ #include <string>
+-// using namespace std;
+
+ #include <xmlrpc.h>
+ #include <xmlrpc_client.h>